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COMPUTER FUNDAMENTAL

Lecture - 1
Computer System= Hardware (H/W) + Software(S/W)
Or
Common Operating Machine Purposely Used for Technological and Educational Research
Common Oriented Machine Particularly United and used under Technical and Educational Research.
Hardware
:-Computer hardware is the collection of physical parts of a computer system. This
includes the computer case, monitor, keyboard, and mouse. It also includes all the parts inside
the computer case, such as the hard disk drive, motherboard, video card, and many others. Computer
hardwareis what you can physically touch.

Software

:-Logical Components (We can or can not seen and do work something according
to object/goal).
COMPUTER SYSTEM: Hardware
o Input Devices (Ex:-Mouse,keyboard, Joystick,Light Pen,OMR,MICR,OBR etc)
o Processor(CPU).
o Output Devices(Ex Monitor,Speeker,Printer,Plotter, etc)
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o Storage Devices(Ex Hard Disk,CD ROM,DVD ,Floppy Disk, Pen drive, Memory Chip)
 Software
Operating System Example :-MS WindowsXP,VISTA,MSDOS, LINUX,UNIX,Window
7 etc
Application S/W Example :- MS word, MS excel, MS Power Point etc
Development S/w Example:- C++, C#, Java, COBOL, PASCAL, BASIC etc
EXAMPLE OF HARDWARE (H/W): Mouse (Left Button, Right Button and Scroll Button).
Name: Douglas Carl Engelbart
Born: January 30, 1925 in Portland, Oregon, USA
Death: July 2, 2013 (Age: 88)
Mouse Technique:a) Click
b) Double Click
c) Drag
d) Drag& Drop
e) Point
 Keyboard
a) Cherry Keyboard (Costly and repairable).
b) Membrane (Cheaper & non repairable).
 CPU (Central Processing Unit)→It is the brain of computer.
 CPU Fan (It is used for cooling CPU).
 Motherboard/PCB (Printed Circuit Board)/Main Board).
 RAM (Random Access Memory).
 ROM (Read Only Memory).
 Hard Disk (It is used for storing programs/files/Images/Video/Graphics etc).
 CD ROM/DVD /Blu Ray Disk.
 CD Drive/DVD Drive/ Blu Ray Disk Drive.
 SMPS (Switched Mode Power Supply). It convert AC current into DC current.
 Monitor (CRT/LCD/LED/PLASMA).
 UPS (Uninterruptible Power Supply).
 Speaker.
Etc
Software (S/W):-It is logical part of computer.
Example Software (S/W): MS word.
MS Excel.
MS PowerPoint.
MS Access.
 Tally.
Paint Brush.
Notepad.
Word Pad.
 Calculator.
Coral Draw.
PageMaker.
Photoshop.
 VLC media player.
Window Media Player. Etc.
INTRODUCING THE COMP UTER KEYBOAR D
Christopher Latham Sholes. Christopher Latham Sholes (February 14, 1819 – February 17, 1890) was
an American inventor who invented the first practical typewriter and the QWERTY keyboard still in
use today. The computer keyboard has lots of extra keys as well as letters and numbers. These keys will
help you to use your computer and keyboard.
Move down this page to find out more about all these different keys.
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ESSENTIAL KEYS
Space Bar. Press this to insert a space between words.
Ente&*r Key This large key to the right of the letters is also sometimes called the Return Key. If you
are keying in text you can press it once and the text cursor will move down to the next line. Press it
twice to create a line space between paragraphs.
Backspace Key. This key deletes the last letter to the left of the cursor. You can use it to correct any
mistakes as you type.
Delete Key. This key deletes the first letter to the right of the cursor.
Caps Lock. This is used for keying in capital letters. There's a light on the top of the keyboard to show
whether the Caps Lock is on. It has often a letter A below it. Holding down the Shift Key at the same
time as a letter key will also turn it into a capital letter.
NB Caps Lock does not give you the upper number key symbols. For these you need to use the Shift
Key.
Shift Key. Hold this down to type capital letters and the symbols on the upper part of a key, e.g. the !
above 1.There is a Shift key on both sides of the keyboard.
Arrow Keys These move your text cursor around the screen. They can also move the page up or down,
and left or right if it is wider than the screen.
USEFUL KEYS
Windows Key. This up the Start Menu and can also be used in combination with other keys for
shortcuts.
Scroll keys. These are used to move the text cursor around words you are keying in or a web page you
are viewing:
 Home takes the text cursor to the top of the page you are keying into or viewing
 End takesthe text cursor to the bottom of the page you are keying in or viewing
 Page Up moves the text cursor up the screen
 Page Down moves the text cursor down the screen
Ctrl (Control) Keys. These are used for keyboard shortcuts, e.g. holding down Ctrl and pressing A
(Ctrl-A) will select everything on a page. But take care! It's easy to press Ctrl by mistake for Shift - and
then unexpected things may happen. If you think that you may have used a Ctrl key by accident, try
using Ctrl-Z. This is the undo button, and will often get you back to where you were. There is a Ctrl key
on both sides of the keyboard.
Alt Key. This is used in similar ways to Ctrl. If you have several windows open on your computer, you
can press Alt and Tab together to switch between them.
Tab Key. This moves the text cursor to the next box in a table or a form.
Esc (Escape) Key. This clears any text that you have typed in a text box online.
Menu Key. This brings up a menu of commands, like clicking the right mouse button.
Number Key Pad. As well as the number row, the Number Key Pad also lets you type numbers. The
Number Lock button must be pressed for this to work; there will be a light above it to show that it's on.
There is also an Enter key in the Number Keys which works just like the one on the main keyboard.
List of Commands:Windows logo
Start
Windows logoD +D
Display the desk top
Windows logo +M
Minimize all of the windows.
Windows logo+E
Open My Computer.
Ctrl+Windows logo+F
Search for a file or a folder.
Windows logo+F1
Display windows help.
Windows logo+R
Open the run dialog box.
Windows logo+U
Open utility manager.
Alt+Space+R
Restore size of open windows.
Alt +Space+X
Maximize Size of Windows.
Alt +Space +N
Minimize size of Windows.
Alt +Space +Tab
Minimize to maximize or minimize to restore.
Alt+Space
Open Control menu.
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Alt/F10
Tab
F5
Alt+Underline Character
Ctrl+C
Ctrl+X
Ctrl+V
Ctrl+Z
Ctrl+Y
Ctrl+A
Alt+Shift+F10
Ctrl+F10
Ctrl+F5
F2
Ctrl+F4
Sl.No.
01.
02.
03.
04.
05.
06.
07.
08.
09.
10.
11.
12.
13.
14.
15.
16.
17.
18.
19.
20.
21.
22.
23.
24.
25.
26.
27.
28.
29.
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Activate Menu Bar.
To select item.
Refresh.
Open menu.
Copy.
Cut.
Paste.
Undo.
Redo/Repeat.
Select All.
Display the windows menu.
Display the action shortcut menu for the selected
item.
Maximize the active consol windows.
Restore the active consol windows.
Rename The selected item.
Close the active console windows.

Short Cut Key
Ctrl + B
Ctrl + I
Ctrl+U
Ctrl+Shift+D
Ctrl+E
Ctrl+R
Ctrl+L
Ctrl+J
Ctrl+1
Ctrl+2
Ctrl+5
Ctrl+C
Ctrl+A
Ctrl+V
Ctrl+Insert
Shift+Insert
Ctrl+X
Ctrl+S
F12
Ctrl+N
Ctrl+Z
Ctrl+Y
Ctrl+[
Ctrl+]
Ctrl+Shift+>
Ctrl+Shift+<
Ctrl+P
Ctrl+Alt+I
Ctrl+K
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Effect
Bold
Italic
Under Line
Double Underline
Center Align
Right Align
Left Align
Justify
Single Line Spacing
Double Line Spacing
1.5 Line Spacing
Copy
All Select
Paste
Copy
Past
Cut
Save
Save As
New Page
Undo
Redo
Decreasing Font Size
Increasing Font Size
Increasing Font Size
Increasing Font Size
Print
Print Preveiw
Insert Hyperlink
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30.
31.
32.
33.
34.
35.
36.
37.
38.
39.
40.
41.
42.
43.
44.
45.
46.
47.
48.
49.
50.
51.
52.
53.
54.
55.
56.
57.
58.
59.
60.
61.
62.
63.
64.
65.
66.
67.
68.

Ctrl+D
Ctrl+Shift+F
Ctrl+Alt+N
Ctrl+Alt+O
Ctrl+Alt+P
Ctrl+=
Ctrl+Shift+=
Alt+Shift+D
Alt+Shift+T
Ctrl+Shift+W
Ctrl+F3
Ctrl+Shift+A
Ctrl+Shift+M
Ctrl+M
Ctrl+Alt+L
Ctrl+Shift+L
Ctrl+W
Alt+F4
Ctrl+Alt+Z
F1
Shift+F5
Ctrl+G
Ctrl+F
Ctrl+H
Ctrl+Shift+L
F10
Ctrl+O
Shift+F10
Alt+Space+N
Tab
Ctrl+Enter
Alt +Ctrl+R
Alt+ Ctrl +C
Alt+Ctrl+T
Shift+F1
Alt+F+A
Alt+V+H
Alt+V+Z
Alt+V+U

Font Window
Font Window
View Normal
Outline
View Page
Subscript
Superscript
Date
Time
Word Underline
Capitalize Word
All Capital
Indent Increase
Indent Decrease
Insert List Number
Bullet
Close
Close
Go Back
Help
Go Back
Goto
Find
Replace
Bullet
Menu
Open
Short Cut Menu
Minimize Size of Windows
To Select Item
Break page/Enter New Page
Register trademark Symbol
Copyright symbol
The Trademark Symbol
Context sensitive help
Save As
Header & Footer
Zoom
Full screen

BASIC PC SHORTCUT KEYS
Shortcut Keys
Alt + F
Alt + E
Alt + Tab

Description
File menu options in current program.
Edit options in current program
Switch between open programs
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F1
F2
F5
Ctrl + N
Ctrl + O
Ctrl + A
Ctrl + B
Ctrl + I
Ctrl + U
Ctrl + F
Ctrl + S
Ctrl + X
Shift + Del
Ctrl + C
Ctrl + Ins
Ctrl + V
Shift + Ins
Ctrl + K
Ctrl + P
Home
Ctrl + Home
End
Ctrl + End
Shift + Home
Shift + End
Ctrl + Left arrow
Ctrl + Right
arrow
Ctrl + Esc
Ctrl + Shift + Esc
Alt + F4
Alt + Enter
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Universal Help in almost every Windows program.
Rename a selected file
Refresh the current program window
Create a new, blank document in some software programs
Open a file in current software program
Select all text.
Change selected text to be Bold
Change selected text to be in Italics
Change selected text to be Underlined
Open find window for current document or window.
Save current document file.
Cut selected item.
Cut selected item.
Copy selected item.
Copy selected item
Paste
Paste
Insert hyperlink for selected text
Print the current page or document.
Goes to beginning of current line.
Goes to beginning of document.
Goes to end of current line.
Goes to end of document.
Highlights from current position to beginning of line.
Highlights from current position to end of line.
Moves one word to the left at a time.
Moves one word to the right at a time.
Opens the START menu
Opens Windows Task Manager
Close the currently active program
Open the Properties for the selected item (file, folder, shortcut,
etc.)
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GENERAL WINDOWS KEYBOARD SHORTCUTS
Alt + Tab
Switch between open applications in all versions of Windows. Reverse the direction by pressing Alt +
Shift + Tab at the same time.
Ctrl + Tab
Switches between program groups, tabs, or document windows in applications that support this feature.
Reverse the direction by pressing Ctrl + Shift + Tab at the same time.
Alt + double-click
Display the properties of the object you double-click on in Windows 95 and later. For example, doing
this on a file would display its properties.
Alt + Print Screen
Create a screen shot only for the active program window in all versions of Windows. For example, if
you opened the calculator and did this only the calculator window would be created as a screen shot. If
just the Print Screen key is pressed the whole screen will be made into a screen shot.
Ctrl + Alt + Del
Open the Windows option screen for locking computer, switching user, Task Manager, etc. in later
versions of Windows. Pressing Ctrl+Alt+Del multiple times will rebootthe computer.
Ctrl + Shift + Esc
Immediately bring up the Windows Task Manager in Windows 2000 and later.
Ctrl + Esc
Open the Windows Start menu in most versions of Windows. In Windows 8 this opens the Start
screen and in Windows 3.x this would bring up the Task Manager.
Alt + Esc
Switch between open applications on Taskbar in Windows 95 and later.
Alt + Space bar
Drops down the window control menu for the currently open Windows program in Windows 95 and
later.
Alt + Enter
Opens properties window of selected icon or program in Windows 95 and later.
Shift + Del
Will delete any file or other object without throwing it into the Recycle Bin in Windows 95 and later.
Hold down the Shift key
When putting in an audio or data CD that uses Autoplay, holding down the Shift key will prevent that
CD from playing.
WINDOWS FUNCTION KEY SHORTCUTS
F1
Activates help for current open application. If you're at the Windows Desktop, this will activate the help
for Windows.
F2
Renames a highlighted icon, file, or folder in all versions of Windows.
F3
Starts find or search when at the Windows Desktop in all versions of Windows.
F4
In Windows 95 and later this opens the drive selection or address bar when browsing files in Windows
Explorer.
 Pressing Alt + F4 closes the current open program window without a prompt in all versions of
Windows.
 Pressing Ctrl + F4 closes the open window within the current active window in Microsoft
Windows. This only works in programs that support multiple windows or tabs in the same
program window.
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F6
While in Windows Explorer, this will move the cursor to different Windows Explorer pane or in
Windows 7 browse available drives.
F8
Pressing F8 over and over as the computer is booting will start the computer in Safe Mode.
F10
Activates the File menu bar in all versions of Windows.
 Simulates a right-click on selected item. This is useful if right-click is difficult or impossible
using the mouse.
WINDOWS KEYBOARD KEY SHORTCUTS
All versions of Windows
WINKEY
Pressing the Windows key alone opens or hides the Windows Start menu. In Windows 8, this opens or
hides the Start screen.
WINKEY + F1
Open the Microsoft Windows help and support center.
WINKEY + Pause / Break key
Open the System Properties window.
WINKEY + D
Opens the Desktop to the top of all other windows.
WINKEY + E
Open Microsoft Windows Explorer.
WINKEY + F
Display the Windows Search or Find feature.
WINKEY + Ctrl + F
Display the search for computers window.
WINKEY + L
Lock the computer and switch users if needed (Windows XP and above only).
WINKEY + M
Minimizes all windows.
WINKEY + Shift + M
Undo the minimize done by WINKEY + M and WINKEY + D.
WINKEY + R
Open the run window.
WINKEY + U
Windows XP only
WINKEY + Tab
Cycle through open programs through the Taskbar.
Windows 7 and 8 only
WINKEY + 1-0
Pressing the Windows key and any of the top row number keys from 1 to 0 opens the program
corresponding to the number of icon on the Taskbar. For example, if the first icon on the Taskbar was
Internet Explorer, pressing WINKEY + 1 would open that program or switch to it if already open.
WINKEY + (Plus (+) or Minus (-))
Open Windows Magnifier and zoom in with the plus symbol (+) and zoom out with the minus symbol
(-).
 Press the WINKEY + ESC to close the Magnifier
WINKEY + Home
Minimize all windows except the active window.
WINKEY + P
Change between the monitor and projection display types or how second screen displays computer
screen.
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WINKEY + T
Set the focus on the Taskbar icons
WINKEY + Left arrow
Shrinks the window to 1/2 screen on the left side for side by side viewing.
WINKEY + Right arrow
Shrinks the window to 1/2 screen on the right side for side by side viewing.
WINKEY + Up arrow
When in the side by side viewing mode, this shortcut takes the screen back to full size.
WINKEY + Down arrow
Minimizes the screen. Also, when in the side by side viewing mode, this shortcut takes the screen back
to a minimized size.
Windows 8 only
WINKEY + ,
Peek at the Windows Desktop.
WINKEY + .
Snap a Windows App to the sides of the screen. Pressing it multiple times will switch between the right
and left-hand side of the screen or unsnap the app.
WINKEY + Enter
Open Windows Narrator
WINKEY + C
Open the Charms.
WINKEY + G
Cycle through Desktop gadgets.
WINKEY + H
Open Share in Charms.
WINKEY + I
Open the Settings in Charms.
WINKEY + J
Switch between snapped apps.
WINKEY + K
Open Devices in Charms.
WINKEY + O
Lock the screen orientation.
WINKEY + X
Open the power user menu, which gives you access to many of the features most power users would
want to use such as Device Manager, Control Panel, Event Viewer, Command Prompt, and much more.

What Is Computer

Lecture - 2

Making for Calculations & Measurement.
Based on Arithmetical and Logical.
Arithmetic/Numeric Operation (+, -, *, /, ^, % (modulo operator/Remainder Operator)).
&
Logical Operation (True, False, Yes, No).
General Definition 1:It (Computer) can perform only those operations or calculations (Arithmetical and
Logical), Measurement and controlling functions, which can be expressed there, result in
terms of numerical or logical.
Program:The basic function/task/work of computer is the execution of program.
It is sequence of instructions, which operate on computer data to perform certain welldefined task or achieve a goal.
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It is facts and figure that is represented in the form of 0 and 1.It is known as Bits(Binary
Digits).
Modern Definition 2:It is an automatic electronic apparatus/Machine making for controlling operations and
performing arithmetical and logical operations and can also perform measurement.
Which can be expressed there result in terms of numerical or logical.
Data:-

Structure of Computer
Structure of computer was given by Von Neumann. He was a British mathematician and physicist
Main
Memory

Data & Information
Interconnections

Address Interconnection
CPU (Central Processing Unit)
ALU

CU

OR

Data & Control Information Interconnections
I/O
Input Gives→ instructions & data after Ouput→Produce Result (Numerical or Logical)
Explanation of Von Neumann Architecture:CPU:-It is the brain of computer which consist of following three components
 ALU:- By This unit it can perform all types of arithmetical and logical operations
 CU:- It is used for controlling operations inside CPU.It accept signal from out side &
produce their corresponding signal. It is the heart of computer.
 OR:- It is a special type of temporary storage area where actual processing is to be performed
by CPU.The size of register determines processing speed of CPU.Processing speed
measured in MIPS. (Million Instruction Per Seconds) & Heartz unit.
ALU :-Arithmetic & Logic unit.
CU
:-Control Unit.
OR
:-Operational Register.
Main Memory:It is needed in a computer to store instructions and the data at the time of program execution.
Computer data represented in the form of 0 and 1.It is known as bits (Binary digits).
0
Off/False/No/Black/Low.
1
On/True/Yes/White/High.
1

0

0

1

0

0

0

8 bits=One Byte.
One Nibble=1/2 of Byte Example:-1001
One Byte=One Character.
Example:-VARANASI=8 Bytes=8*8=64 Bits.
 1Kilo Byte (KB) =1024 Bytes=2 10 Bytes.
 1 Mega Byte (MB) =1024 *1024 Bytes=2 20 Bytes.
 1 Giga Byte (GB) =1024*1024*1024 Bytes=230 Bytes.
 1 Tera Byte (TB) =1024*1024*1024 *1024 Bytes=2 40 Bytes.
 1 Peta Byte (PB) =1024*1024*1024 *1024* 1024Bytes=2 50 Bytes.
 1 Exabyte (EB) = 2 60 Bytes.
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 1 Zettabyte (ZB) = 270 Bytes.
 1 Yottabyte (YB) = 280 Bytes.
Notes:-Bits was invented by Lady Ada.She had written First program of computer.
I/O Devices:- (Input/Output Devices)
Input
Processing (CPU)
OUTPUT
The term can also be used as part of an action; to "perform I/O" is to perform
an input or output operation. I/O devices are used by a human (or other system) to communicate
with a computer. For instance, a keyboard or mouse is an input device for a computer, while
monitors and printers are output devices.INPUT DEVICES.

Input Devices: Keyboard
 Cherry Keyboard (Costly and repairable).
 Membranes Keyboard (Cheaper & non repairable).
 Mouse
 Trackball Mouse.
 Optical Mouse.(Better Quality).
 Joystick. (It is used for playing game).
 Light pen.(It is used for drawing on screen directly).
 OMR. (Optical Mark Recognition/Reader).
Example:A
B
C
D
 OBR (Optical Bar Reader). It is used for identification of items. It interprets pencil marks on
papers.

 MICR (Magnetic Ink Character recognition/Reader).→It is used in banking industry.
MICR characters are printed on a document in either of the MICR fonts. The ink used in the
printing is a magnetic ink or toner, usually containing iron oxide. The MICR text is passed
before a MICR reader. The ink in the plane of the paper is first magnetized.
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Scanner:-It is used for scanning documents, graphics and images,signature in
digital form.
Voice Speech Synthesizer:-It is used for recognizing audio sound/voice.(Used in
cockpit of airlines).

 Mike.
 Gamepad, Joystick, Steering wheel.
 Pen / Stylus
 Webcam
 Biometrics (Thumb impression / Face detection)
 Digital cameras
 Electronic Whiteboard
 MIDI keyboard etc
OUTPUT DEVICES: 3D Printer
 Braille embosser:Braille embossers are "printers" for Braille. Whereas a printer adds ink to a
page to make visible characters, an embosser creates raised dots on a page to
form braille characters.
 Braille reader
A Braille reader, also called a Braille display, is an electronic device that
allows a blind person to read the text displayed on a computer monitor. The
computer sends the text to the output device, where it is converted to Braille and
"displayed" by raising rounded pins through a flat surface on the machine.
 Flat panel
 GPS(Global

Positioning System)

GPS is a network of satellites that helps users determine a location on Earth
 Headphones
 Computer Output Microfilm (COM):-

Computer Output Microfilm is a system that converts stored data directly to
microfilm or microfiche.Computer Output Microfilm systems are still used today,
mostly by organizations who need to store payroll, accounting, insurance,
inventory, or employee data
 Monitor
 Plotter:-A device that draws pictures on paper based on commands from a computer.

Plotters differ from printers in that they draw lines using a pen. As a result, they can
produce continuous lines, whereas printers can only simulate lines by printing a closely
spaced series of dots. Multicolor plotters use different-colored pens to draw different
colors.
 Printer (Dot matrix printer, Inkjet printer, and Laser printer)
 Projector
 Sound card:-A device which can be slotted into a computer to allow the use of audio
components for multimedia applications.
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 Speakers
 Speech-generating device (SGD):-

A speech generating device ( SGD ), also referred to as voice-output communication aids
( VOCA ), are electronic devices that allow the user to select messages to be spoken
aloud, thereby assisting people who are unable to use natural speech to meet the majority
of their communication needs.
 TV
 Video card:-A printed circuit board controlling output to a display screen.

VDU(Visual Display Unit)Produce Soft Copy/Electronic mode copy
 CRT Screen (Cathode Ray Tube)Pixels (.) are fundamental elements of images.
 LCD Screen (Liquid Crystal Display) Crystal rods are used for creating graphical object
on screen.
 LED Screen (Light Emitting Diode)." An LED is an electronic device that emits

light when an electrical current is passed through it. Early LEDs produced only
red light, but modern LEDs can produce several different colors, including red,
green, and blue (RGB) light. Recent advances in LED technology have made it
possible for LEDs to produce white light as well.
 PLASMA Screen:-A plasma display is a computer video display in which
each pixel on the screen is illuminated by a tiny bit of plasma or charged gas,
somewhat like a tiny neon light.
Printer (Produce Hard Copy).
 Impact Printer (Inked ribbon is used).
 Dot Matrix Printer (DMP). (It prints only mono /single color).
 Daisy Wheel Printer.
 Drum Printer.
 Line Printer.
 Non Impact Printer (Used chemical for printing).
 Inkjet printer (Cartridge is used).It print both types color and Mono color).
 Laser Printer (Toner is used)It is the best printer in quality and speed.
Printing Speed measurement: CPS (Character Per Second).
 PPM (Page Per Minute).
 Plotter.
It is used by architect engineer for graphical output on paper/Flex.
 Speeker (It produces Sound).
Etc.
Both Input/Output devices: MODEM (Modulator & Demodulator).
It is used for internet connection.
Analog Signal
Digital Signal.

Analog Signal (Sine wave)
01 0
 Touch Screen.
 Communication Port.
 Network cards
 Headsets
 Facsimile Automated Xerox (FAX)
 Audio Cards / Sound Card etc
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1 0 Digital Signal (Bit Trains).
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Connector:-Male and Female in computer System

Male/Female Layout
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Characteristics of Computer:
Speed.

Accuracy.

Memory.

High Remembering power.

Deligency.

No Intelligency.

Emotionless.

Feeling less.

Versatility.
Types of Computer: Analog Computer (Consist of Analog Signal).
 Digital Computer(Consist of Digital Signal).
 Hybrid Computer (Consist of both types of signal).
Analog Computer:Such types of computers are used for measuring temperature, pressure, speed etc.
Example:Thermometer
:It is used for measuring temperature.
Speedometer
:It is used for measuring speed.
Barometer
:It is used for measuring pressure of air.
Digital Computer→ Classification Of computer:
Micro Computer.

Mini Computer.

Mainframe Computer.

Super Computer.
Micro Computer:It is small computer, which is used for personal work.Or SOHO.
Example:
PC (Personal Computer)/Desktop PC.

Laptop.

Tablet.

Palmtop.
Etc.
Mini Computer:Its configuration is larger than microcomputer which is used for small networking purpose. It may
support 30 to 50 terminals simultaneously. Example:-PDP-8,Wi-Fi(Wire -Fidelity), Small networking
system in bank.

Mini Computer System
Examples of Minicomputer would be:-MAI Basic4,DEC PDP and VAX Series,Prime Computer Prime 50,Wang
Laboratories 2200 and VS Series,Data General Nova etc.

Mainframe Computer:It is also used for networking purpose. It is suited for big organization.
It may support above 500 terminals simultaneously.
Example:- MEDHA, DEC, Sperry etc.
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Installation Arrangements Mainframe Computer: Arrangements of Power.
 Arrangement of Special room and environment.
 Cost of Mainframes exists between 40000$ to 1 Million dollar.
 Arrangement of LAN for making large network.
 Arrangement of computer professionals for working on terminal.
Super Computer:It is the fastest computing device, which is used for solving complex problems.
There are many CPU are used in Super Computer.
Example:PARAM PADMA.
CORAY.
INDIGINIOUS, Hitachi, EKKA.
Etc.
Application of Super Computer: Airlines Controlling.
 Weather forecasting.
 Shuttle space controlling. (Atalantice, Colambia).
 Medical Science.
 Satellite controlling. Etc
Hybrid Computer:Hybrid computers are computers that exhibit features of analog computers and digitalcomputers.
The digital component normally serves as the controller and provides logical and numerical
operations, while the analog component often serves as a solver of differential equations and
other mathematically complex equations..
It is used in Hospital, Nuclear controlling system, Hydrogenic System.

Lecture - 3

Number System (Computer Data Representation Technique):When we type some letters or words, the computer translates them in numbers as computers can understand only
numbers. A computer can understand positional number system where there are only a few symbols called digits and
these symbols represent different values depending on the position they occupy in the number.There are different
types of number system in computer.

 Binary Number System
 0 and 1
 Octal Number System
 Numbers/Symbol 0,1,2,3,4,5,6,7.
 Decimal Number System
 Numbers 0,1,2,3,4,5,6,7,8,9.
 Hexadecimal Number System
 Numbers 0,1,2,3,4,5,6,7,8,9,10,11,12,13,14,15
 10=A,11=B,12=C,13=D,14=E,15=F
Conversion:Decimal To Binary Numbers System
 Division Method
 Tabular Method
… 2048 1024 512 256 128 64 32 16 8 4 2 1
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Base /Radix=2.
Base/Radix=8.
Base/Radix=10.
Base/Radix=16/H.
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Division Method:Example (123)10= (?)2
2
123
Remainder
2
61
1
2
30
1
2
15
0
2
7
1
2
3
1
2
1
1
2
0
1
(123)10= (1111011)2
Example (209.45)10= (?)2
2
209
Remainder
2
104
1
2
52
0
2
26
0
2
13
0
2
6
1
2
3
0
2
1
1
2
0
1
.45*2
.90*2
.80*2
.60*2

=0.90
=1.80
=1.60
=1.20

=
=
=
=

0
1
1
1

= (11010001.0111)2
Tabular Method
… 2048 1024 512 256 128 64 32 16 8 4 2 1
Example (123)10=(?)2
128 64 32 16 8 4 2 1
0
1 1 1 1 01 1
(123)10 =(1111011)2
Example (17)10=(?)2
16 8 4 2 1
1 0 0 0 1
(17)10 =(10001)2
Example (27)10=(?)2
16 8 4 2 1
1 1 011
(27)10= (11011)2
Example (81)10=(?)2
64 32 16 8 4 2 1
1 0 1 0 0 0 1
(81)10=(1010001)2
Example (13)10= (?)2
8 4 2 1
1 1 01
(13)10= (1101)2
Example (9)10=(?)2
8 4 2 1
1 0 0 1
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(9)10=(1001)2
Example (2)10=(?)2
2 1
1 0
(2)10=(10)2
Binary To Decimal:Example:- (1111011)2=(?)10
1*2 6+1*25+1*24+1*23+0*2 2+1*2 1+1*20
=
64 +32 + 16 + 8 +0
+2 + 1
=
(123)10
Binary To Decimal:Example:- (1111011.101)2=(?)10
1*2 6+1*25+1*24+1*23+0*2 2+1*2 1+1*20+1*2 -1+0*2 -2+1*2 -3
=
64 +32 + 16 + 8 +0
+2 + 1 + .5 +0 + .125
=
(123.625)10
Binary To Decimal(Using Tabular Method):Example:- (1111011)2=(?)10
64 32 16 8 4 2 1
1 1 1 1 0 1 1
64+32+16+8+0+2+1=(123)10
Arithmetic Operations: Addition.(+)
 Subtraction.( -)
 Multiplication.( *)
 Division.( /)
Addition:Example:-1
111101
+ 111111
1111100
Carry= …16 8 4 2 1
Example:-2
111101
111101
+ 111111
10111001

0-0
1-0
1-1
0-1

Carry= 101

Subtraction/Minus:=
0
Borrow=0
=
1
Borrow=0
=
0
Borrow=0
=
1
Borrow=1

Example1:111111
- 111110
0 000 01
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Example2:1 10010
-1 11111
1 1 1 0 01 1
Negative result
Multiplication:1 1 1. 1 1
*111
11111
11111
11111

B=1

1 1 0 1 1 0 .0 1
Division:(1101)2/(11)2=(?)2
11 1 1 0 1
11
0 00100
11
0 0 100
11
0 0 001

1 0.0101

Quotient

Remainder

Decimal to Octal:Example (123)10=(?)8
8
123
Remainder
15
3
1
7
0
1
= (123)10=(173)8
Example (523)10=(?)8
8
523
Remainder
8
65
3
8
8
1
8
1
0
8
0
1
= (523)10=(1013)8
Example (503.66)10=(?)8
8
503
Remainder
8
62
7
8
7
6
8
0
7
.66*8
.28*8
.24*8
.92*8

=5.28
=2.24
=1.92
=7.36

=5
=2
=1
=7

= (503.66)10=(767.5217)8
Octal to Decimal:Example:-1
(1013)8=(?)10
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1*8 3+0*82+1*81+3*80
512 + 0 + 8 + 3
=(523)10
Example:-2
(313.35)8=(?)10
3*8 2+1*81+3*80+3*8-1+5*8-2
192 + 8 + 3 + .375 + .0789
=(203.4539)10
Binary To Octal :Example
(11111111.110001)2
01 1 1 1 1 1 1 1. 1 1 0 0 01
011=3
111=7
111=7
110=6
001=1
(377.61)8
Decimal To HexaDecimal :Example (503)10=(?)16
16
503
Remainder
16
31
7
16
1
15=F
16
0
1
=(1F7)16
Example (523.45)10=(?)16
16
523
Remainder
16
32
11=B
16
2
0
16
0
2
.45*16 =7.20 =7
.2*16 =3.2 =3
.2*16 =3.2 =3
=(20B.733)16
HexaDecimal To Decimal :(1F7)16=(?)10
=1*162+F*161+7*160
=256+15*16+7
=256+240+7
=256+247
=(503)10
Binary to HexaDecimal:(11111111.110001)2
1 1 1 1 1 1 1 1. 1 1 0 0 0 1 0 0
1 1 1 1=15=F
1 1 1 1=15=F
1 1 0 0=12=C
0 1 0 0=4
(FF.C4)16
Compliments:1’s Compliment.
2’s Compliment.
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Example:-1
1’s Compliment=
(10001)2
Example
:-2

1
0
01110

0
1

1’s

2’s Compliment=1’s Compliment +1
(10001)2
01110 +1=01111
Sign Magnitude:+
0
1
Example:(-17)10

+17
101110

1’s
010001
101110+1=101111

2’s
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Logic Gates:It is used for making digital circuit. A logic gate is an electronic circuit which produces a typical output
signals depending on its input signal.
Or
A logic gate is an elementary building block of a digital circuit. Most logic gates have two inputs
and one output. At any given moment, every terminal is in one of the two binary conditions low (0)
or high (1), represented by different voltage levels. There are many types of gates.
 AND Gate.
 OR Gate.
 NOT Gate.
 NAND Gate.
 NOR Gate.
 EX-OR Gate.
 EX-NOR Gate.
Input values in gates are used either or both Boolean numbers 0(F) and 1(T).

Logic gates
Digital systems are said to be constructed by using logic gates. These gates are the AND,
OR, NOT, NAND, NOR, EXOR and EXNOR gates. The basic operations are described
below with the aid of truth tables.
AND gate

OR gate
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NOT gate

NAND gate

NOR gate

EXOR gate

EXNOR gate

Table 1: Logic gate symbols
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Note:Functionally Complete set of gates:A set of gates by which any Boolean function can be implemented is called a
functionally complete set. The functionally complete sets are:
[AND, NOT],[NOR],[NAND],[OR,NOT]
PARITY BITS:It is an additional bits, which is used for finding and correcting errors in system.
There are two types of parity bits.
Or
A parity bit, or check bit is a bit added to the end of a string of binary code that indicates whether the
number of bits in the string with the value one is even or odd. Parity bits are used as the simplest form
of error detecting code.
 Odd parity bit
 Even parity bit
Example:Find out odd and even parity bit of following numbers.
(1000101)2
Solution:Odd parity bits of 1=0
Even parity bits of 1=1
Odd parity bits of 0=1
Even parity bits of 0=0
Example:Find out odd and even parity bit of following numbers.
(00001)2
Solution:Odd parity bits of 1= 0
Even parity bits of 1= 1
Odd parity bits of 0= 1
Even parity bits of 0= 0
CODING SYSTEM:A coding system is the patterns of 0s and 1s combinations used to represent characters.
There are following coding system uses in computer.
BCD
→
(Binary Coded Decimal)
EBCDIC
→
(Extended Binary Coded Decimal Interchange Code)
ASCII
→
(American Standard Code for Information Interchange)
BCD (Binary Coded Decimal):It is four bits of coding
. It is also known as 8-4-2-1.
d1

d2

d3

d4

Weight of d1=23=8.
Weight of d2=22=4.
Weight of d3=21=2.
Weight of d4=20=1.
One nibble= ½ of a byte=4 Bits.
EBCDIC (Extended Binary Coded Decimal Interchange):It is eight bits of coding system, which is used in only mainframe computer system.
The Extended Binary Coded Decimal Interchange Code is an 8-bit code which therefore permits 2 8 =
256 distinct characters. This code allowed for the coding of international characters.
d1

d2

d3

d4

d5

d6
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d7

d8
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ASCII (American Standard Code For Information Interchange)
(Or Alpha Numeric Codes)
It is also eight bits of coding system. It is used in microcomputer system.
Its value exist between 0 to 255.There are two categories of ASCII codes.
a:-Standard ASCII codes
→
(0-127)
Non Printing ASCII Codes 0-31
Printing ASCII Codes
32-127
b:-Extended ASCII codes
128-255
It is used for making symbols.
Example:65-90
A-Z
97-122
a-z
╠=204,Σ=228,Θ=239,≡=240,√=251
╠Σ
Alt+ASCII codes (Numeric Key Pads)
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HISTORY OF COMPUTER:Computer developed before 300BC at China. This computing device was known as abacus.
 Mechanical Computer.
 Electromechanical computer.
 Electronic Computer.
Mechanical Computer:It was very first attempt towards automatic computing device. Blaise Pascal designed a
mechanical computer that was known as Pascaline .It consist of a lot of gears and chains. It can
perform repeated addition and subtraction. After some time the grand father (Charles Babbage) of
modern computer also designed following two mechanical computer.
 Difference Engine.
 Analytical engine by Babbage.
Above both kinds of mechanical computer can perform repeated addition, subtraction,
multiply, division, solving polynomial equation and trigonometric problems.
Blaise Pascal→Date of Birth 19 June 1623→ France Date of Died 19 August 1662→Paris
Charles Babbage→ Date of Birth 26 Dec 1791→ London Date of Died 18 October1871→London
Electromechanical computer.
It was the next attempt towards automatic electronic apparatus that was afforded by Howard
Aiken at Harvard University. He designed first electromechanical computer that was known as
MARK-I. It was sponsored by IBM and UN Navy.
Date of Birth8 March 1900 →
Hoboken New Jersey →
Died 14 March 1973
Electronic computer:Generation: First generation
→
(1942 to 1955).
 Second Generation
→
(1955 to 1964).
 Third Generation
→
(1964 to 1975).
 Fourth Generation
→
(1975 to 1990).
 Fifth generation
→
(yet to come).
First generation:In this generation vacuum tube was used in processor(CPU) technology. There are many types
of vacuum tubes.

Diode(Cathode & Anode Plate)

Triode (Cathode , Anode Plate & Suppressor Grid).

Tetrode(Four plates).

Pentode(Five plates).
Using vacuum tubes following types of electronic computers was designed.

ENIAC (Electronic Numerical Integrator and calculator).
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EDVAC (Electronic Discrete Variable automatic Computer).

UNIVAC (Universal Automatic Computer).
Characteristics of ENIAC:
It was Very Giant Machine.

Its weight was 30 tones.

It may perform 5000 addition or 500 multiplications per minute.

It occupies a number of rooms.

It needed a lot of electricity.

It needed a lot of cooling requirements.

It emitted a lot of heat.

Portability is very complex task.

There were 18000 vacuum tubes were used.

Punched cards were used as input device.

Magnetic tapes & magnetic drums were used as secondary memory.

Binary codes or Machine language was used for programming.

ENIAC was based on decimal arithmetic rather than binary arithmetic.
Second generation:In this generation vacuum tube was replaced by transistor. By using transistor IBM
(International business Machine) designed IBM 700 series of processors. It consumes less electricity
and cooling requirement system. Its speed was faster than first generation computer.
Example of transistor:n-p-n
Transistor.
p-n-p
Transistor.
n-p
Transistor.
p-n
Transistor.
Transistor based processor much faster than vaccum-based processor.
Third generation:In this generation, integration technology known as IC (Integrated Circuit) was used. It
consists of a lot of transistor, capacitor and other electronics components.
IC Technology:SSI
(Small Scale Integrator).
MSI
(Medium Scale Integrator).
LSI
(Large Scale Integrator).
VLSI
(Very Large Scale Integrator).
ULSI
(Ultra Large Scale Integrator).
SSI
Number of gates below 100.
MSI
Number of gates upto 100 or more.
LSI
Number of gates upto 1000.
VLSI
Number of gates upto 106(Chips).
ULSI
Number of gates upto 108(Micro Chips).
Transistors,capacitor and conductors are fabricated on a semiconductor material such as
silicon,germanium.
Feature of IC:
Increase reliability.

Low cost

Greater operating speed

Better portability

Reduction in power and cooling requirements.
Fourth generation:In this generation, VLSI based technology used in processor (CPU) used.
Feature: Smaller.
 Faster.

25

26
 GUI (Graphic User Interface) .
Fifth generation:In this generation, ULSI based technology used in processor.
Example: ROBOT.
 Fighter Plane.
 Shuttle Space Plane (Its speed=40000KM/Hour).
Etc.
List of Intel microprocessors. This generational and chronological list of Intel processors attempts to
present all of Intel's processors from the pioneering 4-bit 4004 (1971) to the present high-end offerings,
which include the 64-bit Itanium 2 (2002), Intel Core i7, and Xeon E3 and E5 series processors (2015).
Intel Company designed first microprocessor 4004 in 1971 .It was specific purpose processor.
Intel Company designed second microprocessor 8088 in 1974 .It was general purpose processor.
Intel Company designed Third microprocessor 8086 in 1978 .It was general purpose processor.
Intel Company designed Fourth microprocessor 80386 in 1985-1988.It was general purpose processor.
Intel Company designed Fifth microprocessor 80486 in 1989-1991 .It was general purpose processor.
Intel Company designed Sixth microprocessor Pentium I in 1993-1995 .It was general purpose
processor.
Intel Company designed Seventh microprocessor Pentium II in 1997 .It was general purpose processor.
Intel Company designed Eighth microprocessor Pentium III in 1999 .It was general purpose processor.
Intel Company designed Ninth microprocessor Pentium IV in 2000 .It was general purpose processor.
Working System of Computer System:Input Data

Processing

Output Result

Process:Running state of program is called process.
Process –State Transition Diagram:There are following four categories for process states
1:Dormant State (Creation of jobs/threads/Processing Elements).
2:Ready State (Processing elements are ready to acquire all resources except
CPU).
3:Running State (Execution of jobs in CPU).
4:Suspended (Due to lack of resources).
Types of Processing:There are two types of processing in computer system
 On line processing/Real Time processing(A device directly connected with CPU).
 Off Line Processing/Batch Processing(A device not directly connected with CPU).
On line processing/Real Time processing:When processing takes place immediately as soon as the data is entered into the computer .It
is called on line processing.It provide quick response.
Off Line Processing/Batch Processing:When processing takes place on the stored data to get an output it is called off line
processing.
Example:- Data Stored and processed later stage.
Processing speed and performance determine by using technique of OR.
Block diagram of Processor:Feature of IBM 1401 PC XT: It was announced in late 1950.
 Memory capacity was 16000 characters/Bytes
Events Occur
 SSI,MSI,LSI technology was used
 Processing speed measured in MIPS
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Feature of IBM PC AT: It was announced in 1984.
 Memory capacity was 200 times more characters than IBM 1401.
 VLSI technology was used in this processor.
 PC AT stand for personal computer advanced technology.
 Processing speed of PC AT is more than IBM 1401 PC.
 Size of operational register is more than IBM 1401 PC (Processing speed measured in MIPS).
 It is chips based processor.
Note:-Chips Small components that contains a large amount of electronic circuitry. They are building
blocks of A computer and perform various functions such as doing arithmetic, serving as
computer memory or controlling other chips.
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Memory System in Computer:It is used for storing instructions and data permanently or temporarly for further use. It may also
store audio, video, images, graphics ,s/w etc.
Or
Memory in a computer system is required for storage and subsequent retrieval of the instructions
and data.
Or
Computer memory is any physical device capable of storing information temporarily or
permanently. For example, Random Access Memory (RAM), is a volatile memorythat stores
information on an integrated circuit used by the operating system, software, and hardware.
Example:Hard Disk/Electromagnetic Disk.
CD ROM (Optical Memory). DVD(Optical Memory).
BLU Ray Disk (Optical Memory). Audio/Video Cassette (Magnetic tape)
Pen Drive/Flash Memory.
Zip Disk.
Floppy Disk (Magnetic Disk).
Memory Chips.
RAM, ROM Etc.
Memory Hierarchy:CPU Register.

1:-Decreasing Size.
2:-Increasing Speed.

Cache Memory.

3:-Increasing Cost.
Primary Memory/Main Memory.

Secondary memory/Auxiliary Storage/Mass Storage.

CPU Register/Operational register:It is the fastest memory in speed and smallest in size. It is very costly. It determines
processing speed of CPU. Its speed measured in MIPS.
M
Million
I
Instruction
P
Per
S
Second
Larger the size of register faster may be the speed of CPU.
Example:32 bits register Size→Slower Speed.
64 bits register size→Relatively faster speed.
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Cache memory/High Speed Memory:It is placed between CPU register and primary memory.It is used for increasing speed of
CPU.
Primary Memory/Main Memory:It consists of semi conductor materials. Like Silicon(Si) and Germanium(Ge).
There are two types of primary memory.
 RAM(Random Access Memory).
 SRAM(Static Random Access Memory).
 DRAM(Dynamic Random Access Memory).
 ROM(Read Only Memory).
 PROM(Programmable Read Only memory).
 EPROM(Erasable PROM).
o EEPROM(Electrically EPROM).
Example:-BIOS(Basic Input Output System)/Firmware.
Difference Between RAM and ROM
RAM
ROM
Volatile.
Non Volatile.
Uses by both users and System.
Only for System.
Consist of Si And Ge.
Consist of Si And Ge.
Difference Between SRAM and DRAM
SRAM(Static Random Access Memory)
DRAM(Dynamic Random Access Memory)
No loss of electrical Signal (1↔1,0↔0).
loss of electrical Signal(1→0,0→1).
No need of refreshment.
Need of refreshment.
It is made with transistors.
It is made with cells that stores data as charge
capacitors.
Difference between ROM, PROM, EPROM and EEPROM
Name of Memory
Write Time
Access Time
Cycle
-9
ROM
Many Hours
Nano Second(10 )
1
PROM
Less Hour
Nano Second(10 -9)
10
-9
EPROM
Minute
Nano Second(10 )
100
EEPROM
Second
Nano Second(10 -9)
1000
Secondary Memory/Auxiliary Memory/Backing Store:It is the largest storage device, which is used for storing data and information permanently.
Example:Hard Disk (Electro magnetic disk).
Pen Drive/(PD).
CD ROM(Optical Memory)/Compact Disk Read Only Memory.
DVD(Optical Memory)/Digital Video Disk/Digital Versatile Disk.
Blu Ray Disk(Optical Memory).
Audio/Video cassette (Magnetic tape).
Zip Drive.
Floppy Disk (Magnetic Disk) .
Memory Chips.
Storage Mechanism In Magnetic Disk:In magnetic disk data stored in the form of logical circular tracks and sectors.
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Circular Tracks and sectors.
One Sector=512 Bytes.
Access Time:Seek Time
Latency Time
For read and write, operation head is needed. There are two types of head
 Fixed head.
 Moveable head.
Seek Time:Time required to position the head on a specific track is called seek time.

Latency Time:The time required by a sector to reach below the read/write head is called latency time.

Conclusion of Latency time and Seek Time:-
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Storage Mechanism in hard disk:-
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Disk packs
Access Speed Measurement:RPM (Rotation Per Minute) is used for measuring speed.
RPM may be 3600, 7200, above 10000.
Some Standard of Hard Disk
360 GB Hard Disk
500 GB Hard Disk
1 TB Hard Disk
2 TB Hard Disk
4 TB Hard Disk
Etc
Name of Company:Samsung.
LG.
Philips.
Sony.
Moser Bear.
Lenovo.
Del.
Segate .
i-Ball
Compaq etc.
IBM (International Business Machine).
Optical memory:-In optical memory data and instructions are stored in the form of spiral tracks and
sectors. For read and write operations laser beams are used.
Storage Mechanism in Optical memory(Spiral tracks & sectors are used for storage): CD ROM(Compact Disk read Only Memory) Low density
 DVD(Digital Video Disk)
High Density
 (BRD)BLU RAY DISK
Very Much High Density
 WORM(Write Once Read many)

CD ROM

DVD
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BLU RAY DISK
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Read/Write Operations:Laser beams are needed.
For CD ROM
Low Power of laser beams.
For DVD
High Power of laser beams.
For BLU Ray Disk
Very High Power of laser beams.
Data are stores in spiral tracks and sector type system/Organization.
Storage Capacity of CDROM (700 MB to 800 MB)
Storage Capacity of DVD (4 GB to 5 GB)
Storage Capacity of BLU Ray Disc (6 GB to 12 GB)
Storage Mechanism in Magnetic tape:-

Access Method:To retrieve (Read/Write operation) data from storage device by using following three
technique.
 Sequential Access Method.
 Direct Access Method.
 Random Access Method.
Sequential Access Method.
To access data from storage system in sequential pattern.That is One by One.
Example:- Magnetic Tape.
Direct Access Method.
To access data from storage device by using key value and corresponding
address.
Example:-Magnetic disk,CD ROM,DVD,BRD,Hard Disk.
Random Access Method.
To access data from storage device in random manner.
Example:-Semiconductor Memories.
RAID:-( Redundant Array Of Independent Disks)
It is a technology to improve the secondary storage media by increasing the capacity, performance and
reliability. Multiple –disks database schemes, is termed as RAID.

Chip Organization:Chip consists of semiconductor material. In chip it is an arrangement of decoder, bit line
and word line. There are several technique used for a chip. Following two common
technique uses mostly in chip.
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 2D Chip organization
 2 ½ D Chip Organization
Differences between 2D and 2 ½ D
2D
2½D
It require more circuitry
It require less circuitry
Error detection and correction codes are not Error detection and correction
effectively used.
effectively used
16 bits or 32 bits input/output pins are used
Only one I/O pin is used.

codes

are

Lecture - 7
I/O Organization or Input /Output System:-

Input
Processing (CPU)
OUTPUT
0
I/O Peripherals (Devices)Already Study in Von Neumann architecture.
1
I/O Modules.
2
I/O Technique.
3
I/O Processors.
I/O Module:An I/O module is a mediator between the processor (CPU) and I/O devices.
Function/Task Of Module:
It should be able to provide control and timing signal.

It should communicate with CPU.

It should communicate with I/O devices.
Input Module
Input Module
I/O
Memory
CPU
Output Module
Output Module
Input/Output Technique:The I/O operations can be performed by three basic techniques. These are:

Programmed I/O .

Interrupt Driven I/O.

Direct Memory Access(DMA).
Programmed I/O:It is useful I/O method for computers where hardware costs need to be minimized. It perform
following functions.

Transfer of data from I/O device to the CPU registers/OR.

Transfer of data from CPU register/OR to Memory (RAM).
Interrupt (It is a program):It is a mechanism for transferring a block of data from one memory to another memory.It
also perform following operation.

Initiation of I/O operation.

Completion of I/O operation.

Occurrence of H/W or S/W errors.
Direct Memory Access (DMA):It is a module for transfer large amount of data from CPU to memory.DMA operate in the
following way.

Which operation to be performed.

The address of I/O device which is to be used.
I/O Processors:It include following steps.
Step 1:-Direct Control of CPU on I/O device.
Step 2:- Introduction of I/O module.
Step 3:-CPU need not wait for I/O operations to complete.
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Step 4:- Direct access of I/O module to the memory via DMA.
I/P
Input Module
Input Module
I/O

Output Module

Memory

Output Module

CPU
O/P

What Is scanners:It is an input device that allows we to capture drawing or photographs or text from tangible
source (Paper, slides etc) into electronic form. There are various types of scanners.
 Drum scanners.
 Hand scanners.
 Video scanners.
What Is SMPS:It convert AC current into DC current for computer. It is referred to as Switched Mode Power
Supply.
AC
(Alternative Current) → DC (Direct Current)
Advantage of SMPS: It generates less heat.
 It produces power range between 10 to 50 watts.
 It uses less expensive transformers and circuit.
What Is Modems:It is used for converting analog signal to digital signal and digital to analog signal. It is used for
internet connection.
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There are many types of MODEMs.

Internal Modems.

External Modems.

Pocket Modem.

PC Card Modems.
Modem understands a set of instructions called Hayes command set or AT command Set.
Technology of LCD(nitrogen trifluoride (NF3) )
It is a technology for VDU. It consumes less electric power and produce less harmful radiation.
There are following three types of LCD technology.

Reflective LCD.

Backlit LCD.

Edgelit LCD.
Instruction Execution Register in CPU(Temporary memory):1:-MAR (MEMORY ADDRESS REGISTER)
2:-MBR (MEMORY BUFFER REGISTER)
3:-PC (PROGRAM COUNTER)
4:-IR (INSTRUCTION REGISTER)
MAR:It specifies the address of memory location from which data or instruction is to be accessed (for
read operation) or to which the data is to be stored (for write operation).
MBR:It is a register, which contains the data to be written in the memory (for write operation) or It
receives the data from memory (for read operation).
PC:It keeps track of the instruction that is to be executed next, after the execution of an on-going
instruction.
IR:Here the instructions are loaded before the execution.
System Bus( Collection of wires or printed circuit on board):It is a circuit in which data transfer from:Input→Memory→CPU.
CPU→ Memory→Output.
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Types of Buses:
Data Bus/Line Bus.

Address Bus/Address line.

Control Bus/Control Line.
Pipeline:- It provides a way to start a new task before an old one has been completed. This
technique is called pipeline. There are following two types of pipelining technique.
1:-Instruction Pipeline
2:-Arithmetic pipeline
Fetch/Load→Decode→Execute→Store (By means of pipelines)
Instruction Pipelines (Cycle):Step1 Calculate the address for next instructions.
Step2 Fetch the instruction.
Step3 Decode the operation required by the instructions.
Step4 Calculate the address for operand.
Step5 Perform the operation on the data.
Step6 Calculate the address of the operand.
Step7 Store the operand.
Interrupt:It is a program, which is generated by a number of sources, which may be either internal, or
external to the cpu.It provides to number of sources.Some of the Internal with some event in
which they may be occur.
Types of interrupt:
Program Interrupt(Traps)

Time Interrupt

I/O Interrupt

H/W failure interrupt
Parallel Processing/Flyns Classification of Computers:Data Buffer
Serial Execution Concept
Data Buffer
Parallel Execution Concept
A technique that is used to provide simultaneous data processing tasks for the purpose of increasing the
computational speed of computer.
According to M.J. Flynns, Computers are classified four categories.
 SISD(Single Instruction Single data)
 SIMD(Single Instruction Multiple data)
 MISD(Multiple Instruction Single data)
 MIMD(Multiple Instruction Multiple data)
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SISD:Using this technology, Single Instruction applies on single data stream through pipeline.
Example:-Conventional Von Neumann architecture.

SIMD:Using this technology, Single Instruction applies multiple data stream or Instructions broadcast
on multiple data stream.
Example:-Array Processors.

MISD:Using this technology, Multiple Instruction applies on single data stream.
Example:-Distributed architecture, Vector Processors.

MIMD:Using this technology, Multiple Instruction applies on multiple data stream.
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Example:-Multiprocessor System, Data Flow architecture.
Vector Processing:-

Such types of computing system basically used in following areas.
 Weather forecasting.
 Petroleum Explorations.
 Flight simulations.
 Artificial & Expert System.(Knowledge Based System).Example ROBOT.
 Image processing.
Concept of RISC & CISC Technology:RISC (Reduced Instruction Set Computer).
CISC (Complex Instruction Set Computer).
Above both types of technology used in Processors.
In both types of CPU technology instructions & data passes through pipelines.

Lecture - 8
OM-2/CCC-2/BCC-2
(INTRODUCTION OF COMPUTER S/W (MS WINDOW & MS OFFICE)
Introduction of Computer Software:Computer can neither think nor take any decision itself. We instruct by means of commands or
programs.
Program:It is sequence of instructions, which operate on computer data to perform certain well-defined
task or achieve a goal.Data represented in the form of 0 and 1.Which is known as bits.
Software:A set of programs which run on hardware and govern the functioning of computer system.
Example of S/W:
MS Word

MS Excel.

MS PowerPoint.

Notepad.

Word Pad.

Paint Brush.

Window Media Player (It is used for playing video).

VLC. (It is used for playing video).

WIN AMP. (It is used for playing music).

Coral Draw(It is used for making designing).

Photoshop.(It is used for editing images).

PageMaker.

CAD(Computer Aided Design).

CAM (Computer Aided Manufacturing).

Oracle (It is database management system).

MS Access(It is database management system).
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SQL server(Database management system).
Etc.

Program=Algorithm+Flowchart+ Computer Language+Translator+Operating System + Data Structure.

Algorithm:-Step by step, problem-solving technique is called algorithm.
Example:-1
S=a+b+c
Step:-1
Start/Begin
Step:-2
Read/Input a,b,c
Step:-3
Calculate S=a+b+c
Step:-4
Display/Output/Print S
Step:-5
Stop/End
Example:-2
Si=p*n*r/100
Where:Si
Simple Interest
p
Principal Amount
r
Rate of interest
n
Period
Step:-1
Start/Begin
Step:-2
Read/Input p, n, r
Step:-3
Calculate Si= (p*n*r)/100
Step:-4
Display/Output/Print Si
Step:-5
Stop/End
Example:-3 Write algorithm of following formula.
A=p*(1+r/100)n
A
Amount.
p
Principal Amount.
r
Rate of interest.
n
Period.
Step:-1
Start/Begin
Step:-2
Read/Input p, n, r
Step:-3
Calculate A= p*(1+r/100)n
Step:-4
Display/Output/Print A
Step:-5
Stop/End
Example:-4 Write algorithm for checking year is leap or Not Leap.
Step:-1
Start/Begin.
Step:-2
Read/Input year.
Step:-3
Calculate y=year Mod 4.
// (= Assignment operator)
Step:-4
If y= =0.
// (= = equal operator)
Step:-5
Print “Leap Year”.
Step:-6
If y! =0.
// (! = not equal operator)
Step:-7
Print “Not Leap Year”.
Step:-8
Stop/End.
Note:-Mod is used for calculating remainder.
Characteristics of Algorithm:1.
Finiteness
2.
Definiteness
3.
Effectiveness
4.
Input
5.
Output
Finiteness
:Steps of algorithm must be finite.
Definiteness
:Every step must be defined.
Effectiveness
:Each step must be effective.
Input
:Algorithm must be associated inputation.
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Output
Flowchart:-
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Algorithm must be associated with output components.

:-

The diagrammatical/Graphical representation of any algorithm is called flow chart.
Following Symbols are used in flowchart.

S=a+b+c

Si=p*n*r/100

Start

Start

Read a,b,c

Read p, n,r

S=a+b+c

Si= (p*n*r)/100

Print S



Print Si

Stop
Stop
Computer Language:A programming language is a formal constructed language designed to communicate instructions to a
machine, particularly a computer. Programming languages can be used to create programs to control the
behavior of a machine or to express algorithms.
Computer languages are categorized into two types
1.
LLL(Low Level Language)
1.1 Machine language (0 and 1).
1.2 Assembly Language(Symbols, codes are used instead of 0 and
2.
HLL(High Level Language)
2.1 Natural English like language.
Example:C, C++, JAVA, C#, VC++,COBOL, PASCAL, FORTRAN, BASIC, LISP, PROLOG,
Smalltalk, Python, Beta Etc.
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TRANSLATOR:It is used for converting source (Program) code into object codes. (Machine Codes).There are
following three types of translator.

Assembler(Only for assembly language).

Interpreter(Only for BASIC Language).

Compiler(All HLL except BASIC).
Source Codes
Translator
Object Code (0 & 1)

No any error (bug) in source code
Debug: -To remove error from
source codes.
Advantage of HLL:
Easy To understand.

Fast S/w Development.

Fast debugging (To remove error).

Natural English like language.

Better portability.
Difference between Interpreter and compiler:Interpreter(System S/w)
Compiler(System S/w)
1:-Convert source code into object code line 1:-Convert entire source code into object code
by line.
at a time.
2:-Debugging is very fast.
2:-Debugging is slow.
3:-More Execution time.

3:-Less execution Time.

4:-Used only in QBASIC/BASIC.

4:-Used in all HLL. Except QBASIC/BASIC.

Types of Software:
Application S/W(MS WORD, MS EXCEL,MS Power POINT, Coral Draw,
Photoshop etc).

System S/W. (Translator, Operating System, Loader, Linker).

Utilities S/W (Driver of Motherboard, Monitor, Modem, Sound card etc).

Development S/w Example:- C++, C#, Java, COBOL, PASCAL, BASIC etc
Operating System :-(OS)
It is collection of s/w which is used for managing computer resources such as

Memory System.

File System.

I/O System.

CPU/Processor.

Protection.

Networking management.

Command Interpretation.

Process Management.
OS provides a platform for any application s/w.That is, It is soul of computer. without OS, user never
interact with computer hardware to do some work.
Example:-Category Based OS.
CUI (Command User Interface) Based OS:
MS DOS ( Microsoft Disk Operating system).→Single user.

LINUX→Multiuser.

UNIX→Multiuser.
GUI (Graphical User Interface) Based OS:
MS Windows NT (New Technology).

MS Windows 2000 Professional.
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MS Windows XP.

MS Windows VISTA.

MS Windows 2007.

MS Windows 2008 , MS Windows 2010 etc.
Organization of Computer system with OS
User1 User2 User3 User4 User5 User6…
Application S/w
System S/w
OS
H/W

There are two ways by which user interface with OS.

By System Call

By Commands
System call:-It provides interface with running program and OS.
Command:- It is another way by which user interact with OS.
MS DOS Commands
1:-Internal Commands (Already Available in system).
Date →(It is used for display system date).
Time → (It is used for display time).
CLS → (It is used for clear screen).
Etc.
2-External Commands (We Load by means CD/DVD/PEN Drive)
XCOPY→ (It is used for copying files and folders both)
SCANDISK→ (It is used for checking disk It also repair of disk)
Etc.
C:\> or D:\>,E:\> etc \ Root Directory,>Prompt.
Linux is clone of Unix OS:UNIX is CUI based powerful OS.Linux is the clone of Unix OS.
Feature:
Robust.

Network facility.

Resource sharing.

Communication.

Portability.

Multiuser capability

Multitasking Capability

High security
Minimum H/W requirement for installation:
80286/80386/80486 processor.

40 GB Hard disk.

64 MB RAM.
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UNIX System Organization:User1 user2 user3 user4 user5 user6
Tools & Applications
Shell
Kernel
H/W

Kernel provide interface between user’s command and H/W.It control overall activity of UNIX OS.
Function of Kernel: It manages files.
 Carries out all the data transfer between the file system and H/W.
 Allocation of CPU time to all running programs.
 It also handles interrupts.
Shell:It is a prompt to receive commands given by user and then provide corresponding response of
commands. There are three types of shells.

Bourn Shell. ($):-It is given by Steve Bourne’s.

C shell. (%):-It is given Bill Joy.

Korn Shell. ($):-It is given by David korne.It is very powerful shell and
superset of Bourne shell.
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Introduction to Unix/Linux OS:Linux is clone of Unix OS:It is CUI based OS.Linux is the clone of Unix OS.It was offered by Sun Microsystems and free of
cost downloaded from website of Sun microsystem.It was very popular in the late 1980.Linux may
run on Intel 386 microprocessors.
Feature: Linux is Fast.
 Linux is stable.
 It is open Source S/w.
Drawbacks of Linux: Security
 Lack of Support:-It support and documentation for Linux can be spotty and best.A customer
who downloads Linux from a server may receive only electronic manuals and access to
online help pages.
 Limited S/w selection choice:-It choice StarOffice rather than MS Office.
 Limited H/W support:-It needed driver for related H/W such as printer, MODEM, Speaker
etc.
 Complexity:-Commands used in linux is same as to unix.It is predecessor of Linux.
Commands are case sensitive.
Components of Linux: Memory management subsystem:-It includes
o Large Address spaces
o Protection
o Memory mapping
o Fair physical memory allocation
o Shared virtual memory
 Linux Process and Thread management:-Processors carry out tasks within the OS.A running
state of program is called process.A program is a set of machine codes instructions and data
stored in an executable image on disk.Linux is multiprocessing OS which support many
processes running in parallel. Functional area of process
o State
o Running
o Waiting
o Stopped
o Zombine:-It is halted process.
o Scheduling information:-The scheduler needs to select next job for process
o Identifiers:-Every process in the system has process identifier.
o Links:-Every process in Linux must be associated with pointer.
o File System:-Processes can open and close files as they includes pointers to any files
opened by this process
o Virtual memory:-This memory needed for allocating large program into small size of
memory for processing
 File management Subsystem:-Linux must manage of files of LINUX OS.
 Device drivers:-It is the major part of the Linux kernel.(It provides interface between shell
and H/W).
Commands Used In Linux:login :
<login_name>
password:
<password_name>
who:43

This command displays all logins users.
who am i:This command displays information about us.
cal:- This command display calendar.
$cal 2012
$cal 3 2012
date:This command display date of system
$date
time:This command display time of system
$time
touch:This command is used for creating empty files
$touch <file_names>
$touch file1 file2 file3 file4
cat:-it is used for adding contents into file and reading existing file.
$cat > file1

………..
……….
………..
ctrl+d
note:-ctrl+d is used for save.
$cat file1
To see the contents of file.
cat:-It is also used for concatenating two or more files.
$cat file1 file2 file3>file4
ls:-This command is used for displaying list of files and commands.
$ls
$ls-a It is used for display only hidden files.
ls command using wild card:*
Remaining all characters
?
Only one character
$ls a* It display list of only those files which must begin with character ‘a’
$ls ?a* It display list of only those files which first character begin with any
character and second must be character ‘a’ and remaining are any characters.
$ls a*d It display list of all those files which begin with character ‘a’ and ended with
character ‘d’.
$ls [aeiou]* It display list of all those files which must begin with vowel
character
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$ls [!aeiou]* It display list of all those files which must not begin with vowel
character.
$ls [a-f][a-m][c-k]*  It display list of all those files which first character begin any one
from ‘a’ to ‘f’,second character begin any one from ‘a’ to ‘m’, third character begin any one
from ‘c’ to ‘k’ and remaining are any characters.
$ls-l This command display all the details about the files and directories under a
particular directory.
chmod command:This command is used for setting attributes of files and folders.There are
three types of attributes.
r
read
4
w
write
2
x
execute
1

owner member
group member
other member
Example1:$chmod 741 /home/office/file1 
or
$chmod rwxr__ __x /home/office/file1
Example2:$chmod 777 /home/office/file1 
or
$chmod rwx rwx rwx /home/office/file1 
passwd command:This command is used for changing password.
$passwd 
Enter Old password *****
Enter New password *****
Retype password
*****
cp command:This command is used for copy file and files from one location to another
location.It is also used for renaming file
$cp <source_file> <target_file>
Example:-1
$cp /home/d1/Jitendra /home/d1/d2/Jitendra
Example:-2
$cp /home/d1/Jitendra /home/d1/d2/Meeta
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rm command:This command is used for removing file
$rm <file_name>
Example:-1
$rm /home/d1/Jitendra 
Example:-2
$rm -i /home/d1/Jitendra  (File remove interactively)
Example:-3
$rm -f /home/d1/Jitendra  (File remove forcively)
mv command:This command is used for renaming file and folder
$mv <Old_file_name> <new_file_Name>
Example:-1
$mv /home/d1/Jitendra Amrita
Example:-2
$mv /home/d1/ office
pwd command:This command is used for displaying current working directory.
Example:-1
$pwd
/home/d1/d2
mkmdir/md command:This command is used for creating directory.
$mkdir/md <Directory_name>
Example:-1
$mkdir/md office
rmdir/md command:This command is used for removing directory.
Example:-1
$rmdir office
cd command:This command is used for entering existing directory.
$cd <Directory_name>
Example:-1
$/home/cd office
$/home/office
cd.. command:This command is used for exit from directory.
$/home/office/cd..
$/home/
greap command:- “Globally search a regular expression and print it”
This command is used searching a text or text string.
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Example:-1
$greap “varanasi” /home/d1/d2/file1
Example:-2
$greap a* /home/d1/d2/file2
Example:-3
$greap [Aa]* /home/d1/d2/file3
lp command:This command is used for printing file.
$lp /home/d1/file1
man command:This command is used for provide help of any linux command
$man <command_name>
Example:-1
$man lp
Example:-2
$man chmod
kill command:This command is used for stopping running process.
$kill <PID>
Example:-1
$ps  (It display process ID)
$kill 1240
write command:This command can be used by any user to write something on someone else’s
terminal.
Example:-1
$write /home/user1
How are you.
It is very hot today.
ctrl+d
wall command:This command is used by superuser to send any message for all logined user.
Example:-1
$/etc/wall
System shutting down in 20 minutes.
You are advised to take the required backups
ctrl+d
mail command:It is pretty command to send message various users.
$mail user1 user2 user3 user4
…………………………….
…………………………….
…………………………….
…………………………….
Ctrl+d
vi command:- most important
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It is text editor, which is used for writing program in linux environment.It displays a
windows we can enter and edit text.
$vi <file_name>
Example:-1
$vi file1
Modes of Operation:a:-Command Mode
In this mode all the keys pressed by the user are interpreted to the editor
commands.
b:-Insert Mode
This modes permits insertion of new text, editing of existing text or
replacement of existing text.
c:-The ex command mode
This mode permits us to give commands at the command line.
Text edit Commands:h
moves the cursor one character to the left
i
moves the cursor one character to the right
j
moves the cursor down one line
k
moves the cursor up one line
How to delete text:x
Delete one character
nx
Delete n characters., Where n is number of characters.
How to quit from Linux:In ex mode type :wq Quit and save textual informations.
In ex mode type : q! Quit and without save textual informations.
Scrolling in Linux:ctrl f Scroll the screen forward a full window.
ctrl b Scroll the screen back a full window.
File system in Linux: dev
Device related files.
 bin
Binary executable files.
 lib
Library functions.
 etc
Binary executable files usually required for system administration.
 tmp
Temporary files created by linux or users.
 home
Home directory of all users.
 /home/bin
Additional binary executable files.
Concept of GUI (Graphical User Interface) Based OS:It works on the principal of WYSIWYG (What You See Is What You Get).
It includes following features.

Common Look And feel.

It facilitates user-friendly environment.

It manages resources of computer.

It supports MS Dos. (Microsoft Disk Operating System).

It provides windows environment.

48

Common Graphical user Interface:43

Pointing devices.
 Joystick
Mouse. (It is used for playing computer game).
 Track ball.
 Light Pen.

Pointer.

Windows.

Menus.

Dialog Boxes.

Icons.

Desktop Metaphor (The idea of metaphors has brought the computer
closure to natural environment of the end user).

It facilitates object oriented features.
What is Windows:It is rectangular portion of screen where one can work in user-friendly environment.Windows
appear on desktop screen. Which is handled by mouse technique, keyboard technique & touch screen
technique.
Elements of Windows:
Icons.

Title Bar.

Maximize.

Minimize.

Close.

Menu bar.

Status Bar.

Control Menu Box.

Window Border.

Work area.

Desktop.

Cursor/Insertion Point.

Pointer ().

Tiled format of Windows.

Cascade format of Windows.
Simple Structure of Windows:Title Bar
Menu Bar
Standard Tool Bar
FormatTool Bar
Minimize

Ruler Line

Maximize

Work Area
Task Bar

Control Menu Box

Close

System Tray
Window Border
Status Bar
Start Window

Types of Windows:A:-Applications Windows.
B:-Document windows.
Application Windows:

It consist of its own title bar and menu bar such as
MS Word.
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MS EXCEL.
MS Power Point.
Notepad.
Word Pad.
Window Media Player.
Etc.
Document Windows:It appear inside an application windows which contain files informations, folder information,
s/w information etc.It has own title bar but share menu bar with application windows.
Icon:-It is small graphical picture associated with files, folders, images,s/w etc.






Control Menu Box:It appears upper left corner in each windows. Which consist of following six options?
Restore.
Maximize
Minimize.
Close.
Move.
Size.
Desktop:It is background portion, where windows appear is called desktop.
Menu bar:It consists of list of available menus.
Menu:It consists of commands and options.
Title Bar:It indicate name of application s/w.
Working Technique With Windows:1:Mouse technique
a) Click
b)
Double Click c) Drag
d) Drag & Drop
e)
Point
2:Keyboard Technique:Alt+Space+R
Restore Size of Windows.
Alt+Space+X
Maximize Size of Windows.
Alt+Space+N
Minimize Size of Windows.
Alt+Space+Tab
Minimize To Maximize/ Minimize To Restore.
Alt+ F4
Close Windows.
F1
Help of related Windows.
Alt+Underline Character/Hot Key Open Menu.
Tab
To Select Item.
Alt/F10
To Select Menu.
Alt+Space
Open Control Menu Box.
Concept of Files and Folders/Directories:File:It is collection of related information. File is the heart of any application s/w. Computer file name
must be associated with two parts.
a) Primary File name (Given by user).
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b) Secondary file name (Extension name given by user & System both).
Rule for primary File name:c) File name should start with alphabet characters. (A to Z or a to z).
d) File name should be small and logical.
e) Files should be kept in proper manner, using folders and disk drives.
Secondary File Name/Extension Name:It is used for specific purpose. Such as searching a group of files, deleting a group of
files, copyinig a group of files, renaming a group of files. Some of reserved extension
names are given below.
.doc →→→
document files (MS Word/Word Pad).
.xls
→→→
work sheet files (MS Excel).
.ppt →→→
PowerPoint files.
.mdb →→→
ms access files.
.bmp →→→
bitmap picture files/Paintbrush.
.gif
→→→
graphics files.
.jpg →→→
image files.
.html →→→
web page files.
.txt
→→→
Text files (Note Pad).
.sys →→→
System files.
.prg →→→
Program files.
.tmp →→→
Temporary files.
.cdr →→→
Coral draw files.
.pdf

→→→

.mp3 →→→

Adobe file.
Audio Files.

Etc.
Wild Cards:*

It represent all characters.

?

It represent any one character.

Example based on searching:

To search all files of MS Word in system.
*.doc



To search all files of MS PowerPoint in system
*.ppt



To search all files of MS Excel in system
*.xls



To search all files of Web page in system
*.htm



To search all files of database(MS Access) in system
*.mdb



To search only those file which begin with character ‘a’ & rest are any
characters of word.
a*.doc
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To search all files which first character is any character followed by ‘a’

rest are any character of ms excel.
?a*.xls


To search all images in system.
*.jpg



To search all graphics in system.
*.gif

Application of MS Windows:1. Desk Top Setting:-Press Right Button On Desktop Screen→ Click Properties

1.1. Screen saver.
1.2. Background Setting.
1.3. Appearance.
1.4. Themes.
2. Date And Time Setting:-Start→ControlPannel→Date & Time Setting
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3. Accessories
3.1. Paint Brush S/w:-Start→Program→Accessories→Paintbrush

4.
5.

6.

7.

8.

3.2. Notepad S/W:-Start→Program→Accessories→Notepad
3.3. Word Pad S/W:-Start→Program→Accessories→Wordpad
3.4. Calculator:-Start→Program→Accessories→Calculator
3.5. Games(Entertainment) :-Start→Program→Game→Select Game
3.6. Windows Media Player:Start→Program→Accessories→Entertainment→Windows media Player
3.7. System Tools(It is used for troubleshooting of system)
Start→Program→Accessories→System Tool→
3.7.1.
Scandisk → (Check error and remove Hard disk problems)
3.7.2.
Disk clean up→ (Remove unnecessary files)
3.7.3.
Character Map → (Contain symbols and special characters)
3.7.4.
Backup → (Make an additional copy)
3.7.5.
Disk defragmentation→ ( Consolidate Unused memory)
Creation of Folders(We can create folder any where in system)
Desktop Items
5.1. My Documents.
5.2. Recycles Bin/Trash Bin.
5.3. My Computer.
5.4. Internet Explorer( For accessing Internet Service)
How to play music.
6.1. Through Media Player.
6.2.
Through WIN AMP/Jet Audio Media Player/VLC Media Player.
How to copy files and folders from one location to another.
7.1. CD to CD.
7.2. CD to Hard disk.
7.3. Hard disk to CD.
7.4. CD/Hard Disk To Pen Drive.
Control panel.
8.1. Mouse Setting Property:- Start→Control Pannel→ Mouse Setting.
8.2. System Checking:- Start→Control Pannel→System.
8.3. Font Loading: - Start→Control Pannel→Font.
8.4. Add/Remove H/W:- Start→Control Pannel→Add/Remove H/W.
8.5. Add/Remove S/W:- Start→Control Pannel→Add/Remove S/W.
8.6. User’s Account(Creation and deletion) :- Start→ Control Pannel→User’s
Account
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9. Log off/Log On. (Close/Open All→ Open/Closed internal files →but computer remain on)
10. Shutdown/Turn off & Restart.
Booting Process/Starting up system:It is the process of loading operating system in to main memory of computer.
During booting session, OS checks following components.
a)
Memory Checking/RAM.
b)
I/O system Checking.
c)
CPU checking.
d)
Files System checking.
Types of Booting:Cold Booting (Initial Starting of Computer System).
Warm Booting (Alt+Ctrl+Del/Direct Restart)/Press Reset Button.
1) Cold Booting :When the System Starts from the Starting or from initial State Means when we Starts our
System this is called as cold Booting. In the cold Booting the System will be Started from its beginning
State means first of all, the user will press the Power Button , then this will read all the instructions
from the ROM and the Operating System will b Automatically gets loaded into the System.
2) Warm Booting:The warm Booting is that in which System Automatically Starts when we are Running
the System, For Example due to Light Fluctuation the system will Automatically Restarts So that in this
Chances Damaging of system are More. and the System will no be start from its initial State So May
Some Files will be Damaged because they are not Properly Stored into the System.
Clipboard:It is temporary buffer (Temporary Memory), which is used for containing cut/copies
matters/Contents.
Or
A clipboard is a temporary storage area for data that the user wants to copy from one place to
another.
Control Panel:The Control Panel is a part of the Microsoft Windows graphical user interface which allows users to
view and manipulate basic system settings and controls via applets, such as adding hardware, adding
and removing software, controlling user accounts, and changing accessibility options. It helps in the
setting of H/W and S/W components according to our need.
Work/Function in Control Pannel:Display/Background.
Date & Time.
Mouse Setting.
System information.
User Account.
Font Installation
H/W and S/W Installation and Uninstallation.
Sound and VGA Installation & Uninstalation.

Lecture - 9

Introduction of MS Word: - (Extension/Secondary File name .doc/.docx)
It is a word processing s/w which is used for performing following tasks. or
Microsoft Word is the word processing component of the Microsoft Office Suite. It is used
primarily to enter, edit, format, save, retrieve and print documents.
(a).
Creation of document.
(b).
Deletion of document.
(c).
Creation of template/Blue Print.
(d).
Creation of table.
(e).
Creation of macros.
(f).
Creation of Mail merge.
(g).
Spelling and grammar checking.
(h).
It provides OLE features.
(i).
It provides finding and replacing
(j).
It provides bullets and numbering.
(k).
Autocorrect feature.
(l).
It facilitates equation editors.
(m). Border facility.
(n).
We can set password in document.
(o).
It facilitates different types of fonts and their effects.
(p).
MS word provides facilities of drawing features.
(q).
Setting indents features (Increase and decrease).
(r).
It facilitates Zoom in and Zoom out features.etc.
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Title Bar
Ruler
Format

Menu Bar

Standard Toolbar
Windows environment of MS Word
Commands Used in MS WORD:Ctrl+Shift+*
Ctrl+Shift+>
Ctrl+Shift+<
Ctrl+]
Ctrl+ [
Ctrl+Enter
Alt +Ctrl+R
Alt+Ctrl +.
Alt+ Ctrl +C
Alt+Ctrl+T
Shift+F1
Shift+ F2
Shift+f3
Shift+F4
Shift+F7
Shift+F8
Shift+F10
Shift+F12
Alt+Ctrl+M
Alt+Ctrl+1
Alt+Ctrl+2
F7
Ctrl+K
Ctrl+W
Alt+F+A
Ctrl+F2
Alt+F+U
Alt+F+D
Ctrl+F
Ctrl+G
Alt+V+T
Alt+V+H
Alt+V+Z
Alt+V+U
Etc.

Display non-printing character.
Increase font Size.
Decrease font size.
Increase font.
Decrease font.
Break page/Enter New Page.
Register trademark Symbol.®
Make ellipsis.(…)
Copyright symbol. ©
The Trademark Symbol. ™
Context sensitive help.
Copy text.
Change Case.
Repeat a find or goto action.
Choose Thesaurus commands.
Shrinking documents.
Display a shortcut menu.
Choose the save as commands.
Insert a comment.
Apply the leading 1 style.
Apply the leading 2 style.
Open Spelling and grammer checking.
Hyperlink.
Close file.
Save As.
print.
Page Setup.
Mail Recipients.
Find Dialog Box.
Replace.
Toolbar.
Header & Footer.
Zoom.
Full screen.
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Microsoft Word shortcut keys
Shortcut
Ctrl + 0
Ctrl + A
Ctrl + B
Ctrl + C
Ctrl + D
Ctrl + E
Ctrl + F
Ctrl + I
Ctrl + J
Ctrl + K
Ctrl + L
Ctrl + M
Ctrl + P
Ctrl + R
Ctrl + S
Ctrl + T
Ctrl + U
Ctrl + V
Ctrl + X
Ctrl + Y
Ctrl + Z
Ctrl + Shift + L
Ctrl + Shift + F
Ctrl + Shift + >

Description
Adds or removes 6pts of spacing before a paragraph.
Select all contents of the page.
Bold highlighted selection.
Copy selected text.
Open the font preferences window.
Aligns the line or selected text to the center of the screen.
Open find box.
Italic highlighted selection.
Aligns the selected text or line to justify the screen.
Insert link.
Aligns the line or selected text to the left of the screen.
Indent the paragraph.
Open the print window.
Aligns the line or selected text to the right of the screen.
Save the open document. Just like Shift + F12.
Create a hanging indent.
Underline the selected text.
Paste.
Cut selected text.
Redo the last action performed.
Undo last action.
Quickly create a bullet point.
Change the font.
Increase selected font +1pts up to 12pt and then increase font
+2pts.
Increase selected font +1pts.
Ctrl + ]
Decrease selected font -1pts if 12pt or lower; if above 12,
Ctrl + Shift + <
decreases font by +2pt.
Decrease selected font -1pts.
Ctrl + [
Insert a cent sign (¢).
Ctrl + / + c
Insert a character with an accent (grave) mark, where <char> is
Ctrl + ' + <char>
the character you want. For example, if you wanted an
accented è you would use Ctrl + ' + e as your shortcut key. To
reverse the accent mark use the opposite accent mark, often on
the tilde key.
View or hide non printing characters.
Ctrl + Shift + *
Moves one word to the left.
Ctrl + <left arrow>
Ctrl + <right arrow> Moves one word to the right.
Moves to the beginning of the line or paragraph.
Ctrl + <up arrow>
Ctrl + <down arrow> Moves to the end of the paragraph.
Deletes word to right of cursor.
Ctrl + Del
Deletes word to left of cursor.
Ctrl + Backspace
Moves the cursor to the end of the document.
Ctrl + End
Moves the cursor to the beginning of the document.
Ctrl + Home
Reset highlighted text to the default font.
Ctrl + Spacebar
Single-space lines.
Ctrl + 1
Ctrl + 2
Double-space lines.
1.5-line spacing.
Ctrl + 5
Changes text to heading 1.
Ctrl + Alt + 1
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Ctrl + Alt + 2
Ctrl + Alt + 3
Alt + Ctrl + F2
Ctrl + F1
Ctrl + F2
Ctrl + Shift + >
Ctrl + Shift + <
Ctrl + Shift + F6
Ctrl + Shift + F12
F1
F4
F5
F7
F12
Shift + F3

Shift + F7
Shift + F12
Shift + Enter
Shift + Insert
Shift + Alt + D
Shift + Alt + T
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Changes text to heading 2.
Changes text to heading 3.
Open new document.
Open the Task Pane.
Display the print preview.
Increases the selected text size by one.
Decreases the selected text size by one.
Switches to another open Microsoft Word document.
Prints the document.
Open Help.
Repeat the last action performed (Word 2000+)
Open the Find, Replace, and Go To window in Microsoft
Word.
Spellcheck and grammar check selected text or document.
Save As.
Change the text in Microsoft Word
from uppercase to lowercase or a capital letter at the beginning
of every word.
Runs a Thesaurus check on the selected word.
Save the open document. Just like Ctrl + S.
Create a soft break instead of a new paragraph.
Paste.
Insert the current date.
Insert the current time.

Mouse shortcuts
Description
Click, hold, and drag Selects text from where you click and hold to the point you
drag and let go.
If double-clicking a word, selects the complete word.
Double-click
Double-click
Double-clicking on the left, center, or right of a blank line
makes the alignment of the text left, center, or right aligned.
Double-click
Double-clicking anywhere after text on a line will set a tab
stop.
Selects the line or paragraph of the text that the mouse tripleTriple-click
clicked on.
Zooms in and out of document.
Ctrl + Mouse wheel
Concept of Headers & Footers:Headers:It appears top of each page is called headers.
Headers may be:
Page Numbers.

Number of pages.

Date & Time.

Drawing object.

File name.

Images. Etc.
Footers:It appears bottom of each page is called footers.
Footers may be:
Page Numbers.

Number of pages.

Date & Time.

Drawing object.
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File name.
Images.
Etc.
OLE (Object Linking and Embedding):It is a way of attachment of word file in the form of linked object or embedded object. In case linked
object original file must be change or affected and in the case of embedded object, original file does not
change or affected.
Steps for Linking:Insert→Object→Create New File→Check Link & Icon→Browse→Select & Open File.
Steps For Embedded:Insert→Object→Create New File→Check Icon→Browse→Select & Open File.
Bullets & Numbering:Bullets:Bullets are symbols, graphics, and images for displaying unordered items.
Numbering: -It is used for displaying ordered list of items.
It may be
1. Numbers.
2. Romans.
3. Alphabets (Upper case and Lower case).
Change case(Press F3):It Is Used For Changing Cases. There are many types of cases.

Upper case.

Lower case.

Title case.

Senetence Case.

Toggle case.
Format→Change Case.
Example of Uppercase:RAM IS A GOOD BOY
Example of Lowercase:ram is a good boy
Example of Title case:Ram Is A Good Boy
Example of Sentence case:Ram is a good boy
Example of Toggle case:rAM iS a gOOD bOY
Mail Merge:Mail merge feature is a quick and easy way for mass/Bulk producing letters, forms,
envelopes, mailing labels etc.
Tools→Mail Merge.
Macros:It is a sequence of actions that is named and stored. When we run a macro, word performs all
the assigned actions in a sequence. It provides faster editing and formatting.
ToolsMacrosRecord New Macro(Assigned Into Commands/Tool).
ToolsMacrosStop Macro Commands.
ToolsMacrosRunMacro_Name (For running Macros).
Templates(Designed by User):A standard design or page format is used over and over again to give a consistent appearance to
a series of documents.
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Templates Wizards (Already Made in system):A technique used by some applications to guide the inexperienced or infrequent user through a
complex set of steps by asking questions about the document they are in the process of creating
as they are actually creating it. Wizard can take the form of dialog boxes containing a set of
choices for each stage of creation process or they can also appear as animated on screen
assistant who offer help from time to time.
Table:It consists of rows and columns.

Number of rows=2.
Number Of columns=5.
Hyperlink:It is used for linking one document with other document.
Drop caps:It is used for writing first character in highlighted form or big size corresponding many
lines.

Font:It is a way of writing contents or matters by different ways.
Example:Times New Roman,
Showcard Gothic.
Algerian Etc.
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Paragraph:It consists of a lot amount of sentences. After pressing enter key a new
Pattern 1 paragraph (Hanging Style)
………………………………….
…………………………….
…………………………….
…………………………….
Pattern 2 paragraph (First Line Style)
………………………
…………………………….
…………………………….
…………………………….
Border & Shading:-

Spelling & Grammer Checking:-( It is editing & proofing tool)

CustomizeBY using, this feature of MS word, we can create own toolbar
and menu.This option available in tools menu.
Tools→Customize→Command→New Menu.
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paragraph created.
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Equation editor:This option facilitates for writing mathematical based symbols,
equations etc.
Tools→Customize→Command→Insert→Equation Editor.
Example :-1
y 9.2
3 x  6 y 


n

Example :-2

 xdx

x 1

Tab
It is used for setting stop position of cursor. Default tab stop is .5 inch. There are following
types of tab stop.

Left Tab

Right Tab

Center Tab

Decimal tab
.

Bar tab
Dialog Box:-It contains information about respective terms.Such as Print dialog box,Font dialog
box,Pagesetup dialog box etc.
Find & Replacing:It is used for finding character, word in a given document and replaces it by
desired characters or words.

Printing In MS Word:It produces out put on paper. It is called hard copy. Before printing of document we follow following
steps.
Step1:- Page Setup.
Alt+F+U
Step2:- Print Preview.
Ctrl+F2
Step3:- Printing of document.
Ctrl+P
Page Setup:Margin:a) Left Margin.
b) Right Margin.
c) Top Margin.
d) Bottom Margin.
e) Gutter Margin (For Binding Space).
f) Header & Footer Margin.
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Paper Size:L
W
a) A4 Size
210*227 mm.
b) Letter Size
8.5*11 inch.
c) Legal Size
8.5*14 inch.
d) A5 Size
148*210mm.
e) B5 Size
182*257mm.
f) Photo Size
4*6 inch.
g) Hagaki Size
100*148mm.
h) Custom Size (user defined size).
Page Orientation:a) Portrait (Vertical paper printing).
b) Landscape (Horizontal paper printing).

Print Dialog Box:-
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Getting Started
a document.
Opening Outlook
You may have a shortcut to Word on your desktop, if so double click the
icon and Word will open. If not
follow the steps below:
1. Click on the Start button
2. Highlight Programs
3. Highlight Microsoft Office
4. Click on Microsoft Word 2010

Create a New Document
1. Click the File tab and then click
New.
2. Under Available Templates,
click Blank Document.
3. Click Create.
Using Templates
Word 2010 allows you to apply built-in templates from a wide selection of popular Word templates,
including resumes, agendas, business cards, and faxes.
To find and apply a template in Word, do the following:
1. On the File tab, click New.
2. Under Available Templates, do one of the following:
To use one of the built-in templates, click Sample Templates, click the template that you want,
and then click Create.
cently used, click Recent Templates, click the template that
you want, and then click Create.
To find a template on Office.com, under Office.com Templates, click the template category that
you want, click the template that you want, and click Download to download the template from
Office.com to your computer.
3. Once you have selected your template you can modify it in any way to create the document you
want.
NOTE: You can also search for templates on Office.com from within Word. In the Search Office.com
for templates box, type one or more search terms, and then click the arrow button to search.
Opening a document
1. Click the File tab, and then click Open.
2. In the left pane of the Open dialog box, click the drive or folder that contains the document.
3. In the right pane of the Open dialog box, open the folder that contains the document that you want.
4. Click the document and then click Open.
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Cut, Copy and Paste
If you would like to remove text from your document you can copy or cut the text
from the document. Simply highlight the text and go to the Home tab in the
Clipboard group and click Cut or Copy. You can also right click on your mouse
and select Cut or Copy.
Pasting Text
If you Copy text, you typically need to Paste it somewhere. The Paste feature in
2010 is much more detailed than in previous versions of Word. When you paste content, the Paste
Options button provides different options, depending on the source of the content.
Keep Source Formatting: This option preserves the look of the original text.
Keep Text Only: This option removes all the original formatting from the text.
Link & Keep Source Formatting: This option preserves the look of the original text, and it
maintains a link to the source file and updates the pasted text with any changes that are made to the
source file.
Link & Use Destination Styles: This option formats the text
the text is pasted. It also maintains a link to the source file and updates the pasted text with any
changes that are made to the source file.
Merge Formatting: This option changes the formatting so that it matches the text that surrounds it.
Picture: This option inserts the text as an image.
Use Destination Styles:
is pasted.
Use Destination Theme: This option formats the
document where the text is pasted.
To Paste, click on the area you want your information to be inserted and either go to the Home tab in the
Clipboard group and click Paste or right click on your mouse and select Paste.
Undo
The Quick Access Toolbar holds a variety of commands right at you finger tips. It is located in the top
left of the document above the File and Home tab.
You can add or remove command by clicking on the
arrow
to the right of the Quick Access Toolbar.
If you make an error in your document click on the Undo command and it will remove the last
thing you did.
Show/Hide Formatting Marks
The Show/Hide command allows you to see every time you hit the space bar, hit enter or tab. This
feature can be quite useful when creating documents to understand where everything is placed within
your document and see if any errors have been made.
On the Home tab, in the Paragraph group, click
Show/Hide.
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Formatting Text
Formatting a document can range from modifying text size to adding graphics. It is easy to add creative
touches to any document with the options Microsoft Word has to offer.
Modifying Fonts
The Font Group allows you to change your text font style,
size, color and many other elements.
1. Highlight the text you would like to modify.
2. Click on the drop down arrow of font style and font size
and select the changes you would like to make.
3. While text is highlighted you can also click on the color, bold, italics or underline commands to modify
the text even more.
Change Text Case
You can change the case of selected text in a document by clicking a single button called Change Case
on the ribbon.
1.
Highlight the text for which you want to change the case.
2.
On the Home tab, in the Font group, click Change Case.
3.
Choose an option from the dropdown list, which includes
Sentence case, lowercase, UPPERCASE, Capitalize
Each Word, and tOGGLE cASE.
Adding text effects
1. Select the text that you want to add an effect to.
2. On the Home tab, in the Font group, click Text Effect.
3. Click the effect that you want.
For more choices, point to Outline, Shadow,
Reflection, or Glow, and then click the effect that you
want to add.
Remove text effects
1.
2.

Select the text that you want to remove an effect from.
On the Home tab, in the Font group, click Clear
Formatting.

Format Painter
The Format Painter feature allows you to quickly copy a format that you have applied
to text already in your document.
1. Select the text or graphic that has the formatting that you want to copy.
2. On the Home tab, in the Clipboard group, single click Format Painter. The pointer
will change to a paintbrush icon.
3. Bring your cursor to the text or graphic that you want to format and click on the text.
4. To stop formatting, press ESC or click on the Format Painter command again.
NOTE: Double-click the Format Painter button if you want to change the format of
multiple selections in your document.
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Clear Formatting
To get rid of all the styles, text effects, and font formatting in your document, do the following:
1. Select the text that you want to clear the formatting from. Or press CTRL+A to select everything in
the document.
2. On the Home tab, in the Font group, click Clear Formatting.
NOTE: The Clear Formatting command will not
remove highlighting from your text. To clear
highlighting, select the highlighted text, and then click
the arrow next to Text Highlight Color and click No
Color.

Formatting Documents
Adjusting Line Spacing
The default spacing is 1.15 line spacing and 10 points after each paragraph. The default spacing in
Office Word 2003 documents is 1.0 between lines and
no blank line between paragraphs.
The easiest way to change the line spacing for an entire
document is to highlight the paragraphs or entire
document that you want to change the line spacing on.
1. On the Home tab, in the Paragraph group, click
Line Spacing.
2. Do one of the following:
Click the number of line spaces that you want.
For example, click 1.0 to single-space with the spacing that is used in earlier
versions of Word. Click 2.0 to double-space the selected paragraph. Click
1.15 to single-space with the spacing that is used in Word 2010.
Click Remove Space Before Paragraph to remove any additional
lines added after each paragraph as a default
NOTE: If a line contains a large text character, graphic, or formula, Word
increases the spacing for that line. To space all lines evenly within a
paragraph, use exact spacing and specify an amount of space that is large
enough to fit the largest character or graphic in the line. If items appear cut
off, increase the amount of spacing.

Page Orientation You can choose either portrait (vertical) or landscape (horizontal) orientation for all or
part of your document.
Change Page Orientation

1. On the Page Layout tab, in the Page Setup group,
click Orientation.
2. Click Portrait or Landscape.
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Different Page Orientations on Same Document
1. Highlight the pages or paragraphs that you
want to change to portrait or landscape
orientation.
2. On the Page Layout tab, in the Page Setup
group, click Margins.
1. Click Custom Margins at the bottom of the
drop down menu.
2. A Page Setup dialog box will appear.
3. On the Margins tab, click Portrait or
Landscape.
4. In the Apply to list, click Selected text or This
point forward.
NOTE: If you select some but not all of the text on
a page to change to portrait or landscape
orientation, Word places the selected text on its
own page, and the surrounding text on separate
pages.
Page Margins
Page margins are the blank space around the edges of the page. In general, you insert text and graphics
in the printable area inside the margins
where text and graphics appear on each page. You can change the page margins either by choosing

Setting Predefined Page Margins
1. On the Page Layout tab, in the Page Setup group, click
Margins. The Margins gallery drop down menu will appear.
2. Click the margin type that you want to apply.
Create Custom Margins
1. On the Page Layout tab, in the Page Setup group, click
Margins.
2. At the bottom of the Margins gallery drop down menu, click
Custom Margins.
3. The Page Setup dialog box will appear.
4. Enter new values for the margins in all or some of the Top,
Bottom, Left or Right text boxes.
5. Click OK
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NOTE: Most printers require a minimum width for margin settings, because they can't print all the way to
the edge of the page. If you try to set margins that are too narrow, Microsoft Word displays the message
One or more margins are set outside the printable area of the page.
Page Breaks
Word automatically inserts a page break when you reach the end of a page. If you want the page to
break in a different place, you can insert a manual page break.
Inserting a Page Break
1. Click where you want to start a new page.
2. On the Insert tab, in the Pages group, click Page Break.
NOTE: You can also insert breaks into your document by going to the Page
Layout tab, Page Setup group and clicking on the Breaks command to view a
variety of page and section breaks you can insert into your document.
Deleting a Page Break
You cannot delete the page breaks that Word inserts automatically; you can only delete a page break
that you insert manually.
1. Go to the page break you would like to remove.
2. Select the page break by clicking in the margin next to the dotted line.

3. Press the DELETE key on your keyboard.
Headers, Footers, and Page Numbers
You can add headers, footers and page
numbers numerous ways. The simplest way is
to double click on the top or bottom of the page
and the header and footer area will appear.
Enter the text you wish to be displayed at the
top or bottom of every page.
Add Page Numbers
If you want a page number on each page, you can quickly add a page
number from the gallery.
1. On the Insert tab, in the Header & Footer group, click Page Number.
2. Click the page number location that you want.
3. In the gallery, scroll through the options, and then click the page
number format that you want.
4.
To return to the body of your document, click
Close Header and Footer on the Design tab (under
Header & Footer Tools).
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Add Header or Footer
1. On the Insert tab, in the Header & Footer group, click Header or
Footer.
2. Click the header or footer that you want to add to your document and
your header or footer area will open.
3. Type text in the header or footer area.
4. To return to the body of your document, click Close Header and Footer on the Design tab (under
Header & Footer Tools).
Remove page numbers, headers, and footers
1. Click on the Header, Footer or Page Number Command.
2. A drop down menu will appear.
3. Click Remove at the bottom of the menu.
Bulleted or Numbered List
You can quickly add bullets or numbers to existing lines
of text, or Word can automatically create lists as you
type. By default, if you start a paragraph with an asterisk
or a number 1., Word recognizes that you are trying to
start a bulleted or numbered list. If you don't want your
text turned into a list, you can click the AutoCorrect
Options button

that appears.

Bullets Command
Numbering Command
Insert Bulleted or Numbered List
1. Click on the area where you would like your
list to appear or highlight the text you would
like to be in a list.
2. Go to the Home tab, in the Paragraph group,
click Bullets or Numbering.
3. A bullet(s) or number(s) will be inserted.
Select Bullets or Numbering Style
1. Select the items that you want to add bullets
or numbering to.
2. On the Home tab, in the Paragraph group,
click the arrow next to the Bullets or
Numbering command.
3. Select the bullet or number format you would like to be inserted.
Move a List Left or Right
If you do not like the location of your bullets or numbers you can easily
move them to a preferred location.
1. Click a bullet or number in the list to highlight the list.
2. Drag the list to a new location. The entire list moves as you drag.
The numbering levels do not change.
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Document Ruler
You can use the horizontal and vertical rulers in Word to align text, graphics, tables,
and other elements in your document. To view the horizontal ruler across the top of
your Word document and the vertical ruler along the left edge of your document, you
must be in Print Layout view.
1. To show or hide the horizontal and vertical rulers, click View Ruler at the top of the
vertical scroll bar.
Tab Stops
Creating tab stops can be helpful when creating a large number of documents such as flyers, table of
contents or even when creating a resume. They help you to display and line up information correctly.
Setting Manual Tab Stops
1. Click the tab selector at the left end of the ruler
until it displays the type of tab that you want.
2. Then click in the ruler at the top of your page, where you want to set the tab stop.
The different types of tab stops found on the ruler are:
A Left Tab stop sets the start position of text that will then run to the right as you type.
A Center Tab stop sets the position of the middle of the text. The text centers on this position as you
type.
A Right Tab stop sets the right end of the text. As you type, the text moves to the left.
A Decimal Tab stop aligns numbers around a decimal point. Independent of the number of digits, the
decimal point will be in the same position. (You can align numbers around a decimal character only)
A Bar Tab stop doesn't position text. It inserts a vertical bar at the tab position.
NOTE: You can drag existing tab stops left or right along the ruler to a different position. Just Click and
hold on the tab stop on the ruler then drag it to where ever you would like it to be.
Setting Detailed Tab Stops
If you want your tab stops at precise positions that you can't
get by clicking the ruler, or if you want to insert a specific
character (leader) before the tab, you can use the Tabs
dialog box.
1. Click the Home tab, click the Paragraph Dialog Box
Launcher
2. A Paragraph box will appear, click on the Tabs button at the bottom left of the dialog box.
3. A Tabs dialog box will appear.
4. Under Tab stop position area, type the location where you want
to set the tab stop. Hit enter.
5. Under Alignment, click the type of tab stop that you want. See
the table above for an explanation of the different types of tab
stops.
6. To add dots with your tab stop, or to add another type of leader,
click the option that you want under Leader.
7. Click Set.
8. Repeat steps 4-5 to add another tab stop, or click OK.
9. The Tabs dialog box will disappear and you should see your tabs
set on the document ruler.
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Clear Tab Stops
You can clear tab stops in a variety of ways, the simplest is going to the ruler, click and hold on the tab
stop and drag in down towards the document. The tab stop will disappear. To quickly clear multiple tab
stops and start fresh:
1. Click the Home tab, click the Paragraph Dialog Box Launcher
2. A Paragraph box will appear, click on the Tabs button at the bottom left of the dialog box.
3. A Tabs dialog box will appear.
4. In the list under Tab stop position, click the tab stop position that you want to clear, and then click
Clear. To remove the spacing from all manual tab stops, click Clear All.
5. Click OK.

Working with Graphics
Inserting Shapes
You can add one shape to your file or combine multiple shapes to
make a drawing or a more complex shape. Available shapes include
lines, basic geometric shapes, arrows, equation shapes, flowchart
shapes, stars, banners, and callouts. After you add one or more
shapes, you can add text, bullets, numbering, and Quick Styles to
them.
1. On the Insert tab, in the Illustrations group, click Shapes.
2. A drop down menu will appear, click the shape that you want.
3. Click anywhere in the document, and then drag to place the
shape.
Insert Text to Shapes
Once you have added a shape, you may want to add text inside the
shape. All you have to do is click on the inside of the shape and start
typing.
NOTE: The text that you add becomes part of the shape
if you
rotate or flip the shape, the text rotates or flips also.
Format Shapes
After you insert a shape a new tab called Drawing Tools Format will
appear every time you click on the shape.
1. Click the shape that you want to apply a new or different Quick
Style to.
2. Go to the Drawing Tools Format tab, in the Shape Styles group, click the style that you want to be
applied.

3. To see more Quick Styles, click the More button .
The Drawing Tools Format Tab also allows you to change the shape fill, outline, effects and select how
the text in your document is wrapped around the shape.
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Delete Shapes
If you decide you no longer want the shape in your document then click on the shape and then press
DELETE.
Inserting Text Boxes
A text box is an object that lets you put and type text anywhere in your file.
1. On the Insert tab, in the Text group, click Text Box and a drop down menu will appear.
2. Click on a text box template or click Draw Text Box at the bottom of the drop down menu to draw
your own text box.
3. If you elect to draw your own text box you need to click in the document, and then drag to draw the
text box the size that you want.
4. To add text to a text box, click inside the text box, and then type or paste text.
To format text in the text box, select the text, and then use the formatting options in the Font
group on the Home tab.
To position the text box, click it, and then when the pointer becomes a , drag the text box to a
new location.
NOTE: If you have problems printing text boxes, make sure that the Print drawings created in

Word check box is selected. To do this, click the File tab, click Options, click Display, and then
under Printing Options, select the Print drawings created in Word check box.
Deleting Text Boxes
To remove a text box just click the border of the text box that you want to delete, and then press
DELETE. Make sure that the pointer is not inside the text box, but rather on the border of the text box. If
the pointer is not on the border, pressing DELETE will delete the text inside the text box and not the text
box.
WordArt
WordArt can be used to add special text effects to your document. For example, you can stretch a title,
skew text, make text fit a preset shape, or apply a gradient fill. This WordArt becomes an object that you
can move or position in your document to add decoration or emphasis. You can modify or add to the text
in an existing WordArt object whenever you want. To add WordArt to text in your document, complete
the following steps:
1. On the Insert tab, in the Text group, click
WordArt,
2. A Drop down menu will appear, click the WordArt
style that you want.
3.

Insert Picture/Clip Art
Pictures and clip art can be inserted or copied into a document from many different sources, including
downloaded from a clip art Web site provider, copied from a Web page, or inserted from a folder where
you save pictures.
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Insert Clip Art
1. On the Insert tab, in the Illustrations group, click Clip Art.
2. A Clip Art task pane will appear on the right of your screen, in the Search for box, type a word or
phrase that describes the clip art that you want.
3. Click Go.
4. In the list of results, double click on the clip art to insert it into your document.
Insert Picture from Web
1. Open the document.
2. From the Web page, drag the picture that you want into the Word document.
Insert Picture from File
To insert a picture saved in your computer, insert it by following these steps.
1. Click where you want to insert the picture in your document.
2. On the Insert tab, in the Illustrations group, click Picture.
3. Locate the picture that you want to insert. For example, you might have a picture file located in My
Documents.
4. Double-click the picture that you want to insert and it will appear in your document.
NOTE: To resize a picture, select the picture you've inserted in the document. To increase or decrease
the size in one or more directions, drag a sizing handle away from or toward the center, while you do one
of the following:
Sizing Graphics
You can easily resize pictures, text boxes, shapes, and WordArt in your file. You can also crop pictures
or return them to their original size.
Manually Resize Graphics
1.
Click the pictureshape, text box or WordArtthat you want to resize.
2.
Small circles or squares, also known as sizing handles, will appear at the
corners and sides of a selected object.
3. Click and hold on a sizing handle away from or toward the center to increase or decrease the size of
the picture.
Cropping a Picture
Cropping reduces the size of a pictureby removing vertical or horizontal edges. Cropping is often used to
hide or trim a part of a picture, either for emphasis or to remove unwanted portions.
1.
Click on the picture that you want to crop.
2.
Go to Picture Tools, on the Format tab, in the Size group, click Crop.
3.
Black dotted lines will appear around your picture. Then drag the center
cropping handle on that side inward.
4. As you drag the cropping handle you will notice the
area of your graphic you want removed will become
gray.
5. Once you have cropped out everything you want,
click outside of the graphic for the gray area you want removed to disappear.
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Uncrop a Picture
You can always restore a resized or a cropped picture to its original appearance.
1. Click on your picture
2. Go to Picture Tools, on the Format tab, in the Size group, click Crop.
3. Black dotted lines will appear around your picture. Drag the black lines away from the center of the
picture and the original picture will appear.

Advanced Formatting Techniques
Create Columns
Columns can be used in documents such as brochures, newsletters or to save
space when creating lists.
Add columns before entering text:
1. Go to the Page Layout tab, in the Page Setup group, click Columns.
2. Click the layout that you want. Your document will be formatted in columns.
NOTE: To add a vertical line between the columns, click Columns again, click
More Columns, and then select the Line between check box. You can also
adjust the column width and spacing.
Add columns to part of a document
To do that highlight the text you want formatted in columns, or place your cursor
where you want columns to begin.
1. On the Page Layout tab, in the Page Setup group, click Columns.
2. Click More Columns.
3. Click the number of columns that you want.
4. In the Apply to list, click Selected text or This point forward.
NOTE: To change the layout again further on in your document, select text or click where you want to
change the layout, and then follow the same steps. For example, you can change from one column to a
two-column layout, and then you can change back to the single-column layout on a later page.
SmartArt Graphic
A SmartArt graphic is a visual representation of your information that you can quickly and easily create,
choosing from among many different layouts, to effectively communicate your message or ideas. You
can create SmartArt graphics in Excel,
Outlook, PowerPoint, and Word.
SmartArt graphics enables you to create
designer-quality illustrations with only a
few clicks of your mouse. When you
create a SmartArt graphic, you are
prompted to choose a type of SmartArt
graphic, such as Process, Hierarchy,
Cycle, or Relationship. Each type of
SmartArt graphics contains several
different layouts. After you choose a
layout, it is easy to switch the layout or
type of a SmartArt graphic. Most of your text and other content, colors, styles, effects, and text formatting
are automatically carried over to the new layout.
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When you select a layout, placeholder text (such as [Text]) is displayed, so that you can see how your
SmartArt graphic looks, nor is it displayed during a slide show. However, the shapes are always
displayed and printed, unless you delete them. You can replace the placeholder text with your own
content.
Create a SmartArt Graphic
1. On the Insert tab, in the Illustrations group, click SmartArt.
2. In the Choose a SmartArt Graphic dialog box, click the type and layout that
you want.
3. Enter your text by doing one of the following:
Click [Text] in the Text pane, and then type your text.
Copy text from another location, click [Text] in the Text pane, and then paste your text.

Add or Delete Shapes in SmartArt Graphic
1. Click the SmartArt graphic that you want to add another shape to.
2. Click the existing shape that is located closest to where you want to add the new shape.
3. Under SmartArt Tools, on the Design tab, in the Create Graphic group, click the arrow under Add
Shape.
4. Do one of the following:
To insert a shape after the selected shape, click Add
Shape After.
To insert a shape before the selected shape, click Add
Shape Before.
NOTE: To delete a shape from your SmartArt graphic, click the shape you want to delete, and

then press DELETE. To delete your entire SmartArt graphic, click the border of your SmartArt
graphic, and then press DELETE.
Format SmartArt Graphic
You can apply color variations to the shapes in your SmartArt
graphic.
1. Click your SmartArt graphic.
2. Under SmartArt Tools, on the Design tab, in the
SmartArt Styles group,
3. Select the SmartArt Style you wish to apply to add line
styles, bevels or 3-D effects.
4. In the SmartArt Styles group you can also click Change Colors to further modify your SmartArt
graphic.
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NOTE: If you don't see the SmartArt Tools or Design tabs, make sure that you've selected a SmartArt
graphic. You may have to double-click the SmartArt graphic to open the Design tab.
5. Click the color variation that you want.
Tables
Using tables in Word can provide you with additional elements to any document. Tables can be used to
create lists or format text in an organized fashion.
Inserting a Table
1. Click where you want to insert a table.
2. On the Insert tab, in the Tables group, click Table
3. A drop down box will appear; click and hold your mouse then drag to
select the number of rows and columns that you want inserted into
your document. You will see your table appearing in your document
as you drag on the grid.
4. Once you have highlighted the rows and columns you would like let
go of your mouse and the table will be in your document
Add Row/Column to Table
1. Click on the table.
2. Under Table Tools, go to the Layout tab
3. Click on the Insert Above or Insert Below to add a row, Click on
Insert Left or Insert Right to insert a column.

4. Click on Delete to remove a column, row or cell.
Delete a Table
1. Rest the pointer on the table until the table move handle
handle.
2. Press BACKSPACE on your keyboard.

appears, and then click the table move

Delete Table Contents.
You can delete the contents of a cell, a row, a column, or the whole table. When you delete the contents
of a table, the table's rows and columns remain in your document.
1. Select the contents that you want to clear by following the table below:
TO SELECT
DO THIS
The entire table In Print Layout view, rest the pointer over the table until the table move handle
appears, and then click the table move handle.
A row or rows
Click to the left of the row.
A column or
columns
Click the column's top gridline or border.
A cell
Click the left edge of the cell.
2. Press DELETE.
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Finalizing a Document
Using the "Spell Check" Feature
As you type your document, red wavy lines will appear under any word that is spelled incorrectly. The
fastest way to fix spelling errors is to:
1. Put your cursor over the misspelled word and right click.
2. A drop down box will appear with correct spellings of the
word.
3. Highlight and left click the word you want to replace the
incorrect word with.
To complete a more comprehensive Spelling and Grammar check, you can use the Spelling and
Grammar feature.
1. Click on the Review tab
2. Click on the Spelling & Grammar command (a
blue check mark with ABC above it).
3. A Spelling and Grammar box will appear.
4. You can correct any Spelling or Grammar issue
within the box.
Print Preview
Print Preview automatically displays when you click
on the Print tab. Whenever you make a change to
a print-related setting, the preview is automatically updated.
1. Click the File tab, and then click Print. To go back to your document, click the File tab.
2. A preview of your document automatically appears. To view each page, click the arrows below the
preview.
Print
The Print tab is the place to go to make sure you are printing what you want.
Click the File tab.
Click the Print command to print a
document.
Click the Print button to print your
document.
This dropdown shows the currently
selected printer. Clicking the
dropdown will display other available
printers.
These dropdown menus show
currently selected Settings. Rather
than just showing you the name of a
feature, these dropdown menus show
you what the status of a feature is and
describes it. This can help you figure
out if you want to change the setting
from what you have.
TIP: To go back to your document
and make changes before you print it,
click the File tab.
2.
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Save a document
To save a document in the format used by Word 2010 and Word 2007, do the following:
1. Click the File tab.
2. Click Save As.
3. In the File name box, enter a name for your document.
4. Click Save.
To save a document so that it is compatible with Word 2003 or earlier, do the following:
1. Click the File tab.
2. Click Save As.
3. In the Save as type list, click Word 97-2003 Document. This changes the file format to .doc.
4. In the File name box, type a name for the document.
5. Click Save.
Help
If you need additional assistance when completing your document you can use the help feature.
1. Click on the blue circle with the white question mark command
2. A Help box will appear.
3. Click in the Search Help textbox and type what you need help
with
4. Click the magnifying glass next to the text box and the possible
solutions will appear.
For additional information Microsoft Office has a great online resource that provides you with step by
step instructions in a variety of topics. This link will bring you directly to the Word 2010 Help and How-To
page: http://office.microsoft.com/en-us/word-help/CL010256357.aspx
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Lecture - 10

MS POWERPOINT: - (EXTENSION NAME .ppt/.pptx)
It is graphics s/w which is used for making effective and interesting presentation.Various categories of
slides are helpful for making presentation.
Description of Power Point:- PowerPoint is often used to create business presentations, but can also be used for
educational or informal purposes. The presentations are comprised of slides, which may contain text, images, and
other media, such as audio clips and movies. Sound effects and animated transitions can also be included to add
extra appeal to the presentation. However, overusing sound effects and transitions will probably do more to
annoy your audience than draw their attention. (Yes, we have all heard the car screeching noise enough times for
one lifetime.) Example of Slides:
Title Slide.
Title Only Slide.
Title & Text Slide.
Title & Two column text.
Blank Slide.
Content Slide.
Title & Content Slide.
Title & Two content.
Title, Content & Two Content.
Title, Text & Content.
Title & Chart.
Title & Organization chart.
Title, Media clip & Text. Etc.
Slide:-It is an individual page, where we put our ideas or views.
How To Make an Effective Presentation:
Collect whole information.

Organized this information step by step.

Use appropriate font size & colors.

Use maximum graphics and images rather than textual information.

Use judiciously animation effect and transition.

Use already made template/Design/Model.
Etc.
Steps For Making Presentation:
Put all information on various slides systematically.

Apply suitable background.

Apply suitable built in Animation or Custom animation.

Apply suitable transition.

Slide Show (Press F5).
COMMANDS TO CONTROL POWERPOINT WINDOWS
To do this
Press these shortcut keys
Go to previous presentation window
CTRL+SHIFT+F6
Go to next presentation window
CTRL+F6
Maximize PowerPoint application window
ALT+F10
Maximize presentation window
CTRL+F10
Restore presentation window to previous size
CTRL+F5
COMMANDS TO USE IN AN OUTLINE
Promote paragraph
ALT+SHIFT+LEFT ARROW
Demote paragraph
ALT+SHIFT+RIGHT ARROW
Move selected paragraphs up
ALT+SHIFT+UP ARROW
Move selected paragraphs down
ALT+SHIFT+DOWN ARROW
Show heading level 1
ALT+SHIFT+1
Expand text under a heading
ALT+SHIFT+PLUS
Collapse text under a heading
ALT+SHIFT+MINUS
Show all text and headings
ALT+SHIFT+A
Turn character formatting on/off
Keypad /
Viruses:-Artificial Viruses(Vital Information Resource Under Seize)
“Virus” was invented by Len Adleman in 1983 It is computer program, which is used for performing
unwanted task. Example:-WORM, Time Bomb, Trojan horse, Laden Mara Gaya, 28 Ferb Happy Birthday Etc.
Antivirus:- It is used for protecting and killing viruses.
Example:-Nortan Antivirus, Spyware,Kasper,K7 ,Kaspersky, Webroot, ESET, McAfee and GDATA. ,AVG, BitDefender , Avira, Panda Security, F-Secure, alwarebytes' Anti Malware, Trend Micro,
ZoneAlarm, eScan, Quick Heal, Comodo, Guardian AntiVirus etc
Source of Viruses:Internet, Pen Drive, Floppy,Downloadable Programs,Cracked Software, Email
Attachments,Booting From CD.etc
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A Beginner s Guide to PowerPoint 2010
I.

The Opening Screen

You will see the default opening screen is actually composed of three parts:
1.
2.
3.

The Slides/Outline tabs on the left which displays thumbnails or lists of all slides
The main Slide pane (center) which allows you to work on individual slides.
Notes Pane (bottom): In the Notes pane, you can type notes about the current slide. You can distribute
your notes to your audience or see your notes in Presenter view when you give your presentation.

By default, PowerPoint 2010 applies the Blank Presentation template, which appears in the previous illustration, to
new presentations. Blank Presentation is the simplest and most generic of the templates in PowerPoint 2010, and is a
good template to use when you first start to work with PowerPoint.
To create a new presentation that is based on the Blank Presentation template, do the following:
1.

Click the File tab.

2.

Point to New, and under Available Templates and Themes select Blank Presentation.

3.

Click Create.
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II.

The Title Slide

When you open a new presentation in PowerPoint 2010, the program assumes that you will begin your slide show with
a Title slide. Adding a title and subtitle to this slide layout is as easy as clicking in the text boxes provided and
typing.

III.

One of the first things you will want to think about is the look or design theme of your slides.
PowerPoint has a number of built in themes you can choose from. Design themes were first introduced
in PowerPoint 2007. They work in a similar way as the design templates in earlier versions of
PowerPoint. A really nice feature of the design themes is that you can immediately see the effect
reflected on your slides, before making your decision.
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IV.
a.
b.
c.
d.

V.

Apply a Design Theme
Click on the Design tab of the ribbon.
Hover your mouse over any of the design theme icons shown.
The design is reflected immediately on your slide, so you can see how it will look if you apply this design
theme to your presentation.
Click the design theme icon when you find one that suits your needs. This will apply that theme to your
presentation.
Test Out More Design Themes

The design themes that are immediately visible on the Design tab of the ribbon are not all the themes available. You
can scroll through the existing design themes by clicking on the up or down arrows to the right of the themes shown,
or click the drop down arrow to reveal all of the available design themes at one time.
More design themes are available to download from the Microsoft site, by clicking on that link.

VI.

Design Theme Color Schemes
Once you have selected a style of design theme that you like for your PowerPoint presentation, you are not
limited to the color of the theme as it is currently applied.
1. Click on the Colors button at the right end of the design themes on the Design tab of the ribbon.
2. Hover your mouse over the various color schemes shown in the drop down list. The current choice
will be reflected on the slide.
3. Click the mouse when you find the right color scheme.
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VII.

Select a Font Family

Each design theme is assigned a font family. Once you have selected the design theme for your PowerPoint
presentation, you can change the font family to one of the many groupings within PowerPoint 2010.
1.
2.
3.

Click the Fonts button at the right end of the design themes shown on the Design tab of the ribbon.
Hover your mouse over any of the font families to see how this group of fonts will look in your presentation.
Click the mouse when you have made your selection. This font family will be applied to your presentation.
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VIII.

Change the PowerPoint Background Style

Just as you were able to change the background on a plain PowerPoint slide, you can do the same while using one of
the many design themes.
1.
2.
3.
4.

Click the Background Styles button on the Design tab of the ribbon.
Hover your mouse over any of the background styles.
The background style will be reflected on the slide for you to evaluate.
Click the mouse when you find a background style that you like.

IX.

Background Graphics Can Be Hidden

Sometimes you want to show your slides with no background graphics. This is often the case for printing purposes.
The background graphics will remain with the design theme, but can be hidden from view.
1.
2.

Check the Hide Background Graphics box on the Design tab of the ribbon.
The background graphics will disappear from your slides, but can be turned back on at any later time, by simply
removing the check mark in the box.
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X.

Font Size and Color

A number of factors, such as room lighting and room size, can affect the readability of your slides during a
presentation. Therefore, when creating your slides, choose font colors, styles and a font size that will make it easy for
your audience to read what is on the screen, no matter where they are seated.
When changing font colors, choose ones that contrast strongly with your background. When choosing a font /
background color combination, you might also want to consider the room you will be presenting in. Light color fonts
on a dark background are often easier to read in a very dark room. Dark color fonts on light backgrounds, on the
other hand, work better in rooms with some light.
In the case of font styles, avoid fancy fonts such as script styles. Difficult to read at the best of times on a computer
screen, these fonts are almost impossible to decipher when projected on to a screen. Stick to standard fonts such as
Arial, Times New Roman or Verdana.
The default sizes of fonts used in a PowerPoint presentation - 44 point text for titles and 32 point text for subtitles and
bullets - should be the minimum sizes you use. If the room you are presenting in is very large you might need to
increase the font size. Font sizes may be smaller if the presentation is meant to be viewed on a computer screen.
XI.
1.
2.
3.

Steps to changing the font style and size

Select the text you wish to change by dragging your mouse over the text to highlight it.
Click the font drop-down list. Scroll through the available fonts to make your selection.
While the text is still selected, choose a new size for the font from the font size drop-down list.
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XII.

Steps to change the font color -

1.

Select the text.

2.

Locate the Font Color button on the toolbar. It is the letter A button to the left of the Design button. The colored
line under the letter A on the button indicates the current color. If this is the color you want to use, simply click
the button.

3.

To change to a different font color, click the drop-down arrow beside the button to display other color choices.
You may choose a standard color shown, or click the More Colors... button to see other options.

4.

De-select the text to see the effect.

XIII.

Adding Media to Your Slides
1. Add Clip Art and Pictures Using a Content Slide Layout

PowerPoint 2010 offers you a number of different ways to add clip art and pictures to a presentation. Perhaps the
easiest way to do so is to select a slide layout that contains a placeholder for content such as clip art and pictures.
On the Home tab of the ribbon either click on the New Slide button or change the current slide layout by clicking on
the drop down arrow beside Layout.
There are a number of different Content slide layouts available for you to choose from. To add a single picture or a
piece of clip art, click on a simple layout such as Title and Content and the layout of your current slide will change to
match your choice.

If you have chosen one of the simple content layouts, your PowerPoint 2010 slide should resemble the graphic below.
The content icon in the middle of the slide contains links to six different types of content that you can add to the slide.
The clip art button is in the middle of the bottom row of icons.
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Tip - If in doubt about which button to use, simply place your mouse over a button until the little help balloon
appears. These balloons or Tool Tips will identify what the button is used for.

2.

Resize Clip Art

Clip art comes in different sizes. Some will be larger than your slide while others will be tiny. Either way you may need
to resize the image you want to include in your presentation.
When you click on a clip art image, a border and tiny white circles appear on the edges of the image. These circles are
called resizing handles (or selection handles). Dragging one of these handles allows you to enlarge or shrink your
picture.
The best way to resize clip art or any picture, is to use the resizing handles located on corners of the picture, rather
than the ones at the top, bottom or sides of the picture. Using the corner handles will keep your image in proportion
as you resize it. If you don't maintain your image's proportion it is likely to end up looking distorted or fuzzy in your
presentation.
3.

Inserting Photos

Like clip art, photographs and other pictures can be added to a slide by choosing a Content Layout slide and clicking
on the appropriate icon (for pictures it's the mountain icon).
An alternative to this method is to select the Insert tab on the ribbon and click on the Picture icon, as shown in the
image at the top of this page.
An advantage of using this approach for either pictures or clip art is that you do not need to use one of the preset
slide layouts containing a content icon to insert an image into your slide. The example shown in the following pages,
inserts the picture into a Title slide layout.
Search Your Computer for the Photos
If you have made no changes to the settings in PowerPoint 2010 since the original install, PowerPoint will default to
the My Pictures folder to look for your pictures. If this is where you have stored them, then select the correct picture
and click on the Insert button.
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If your pictures are located elsewhere on your computer, use the drop-down arrow at the end of the Look in box and
find the folder containing your pictures.

4. Crop Unnecessary Elements from the Photos
Once the photo has been inserted into the PowerPoint 2010 slide, you may wish to remove extra elements
from the picture. Most photos can be made just a little better by cropping unnecessary elements, such as
background walls, floors, shoes or other unnecessary objects that do not enhance the photo.
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Here s How to Crop your Image:
Picture Tools
Click on the picture to select it. This will activate the Picture Tools link above the ribbon. Click the Picture
Tools link to reveal all the options relating to pictures.
Crop Tool
The Crop tool is located on the right side of the Picture Tools. Click the crop tool and you will notice that there
are black "crop" handles around the border of the picture. Drag these handles to remove the excess elements
that are unnecessary to the picture.
Note - It is important to note that even though the picture has been modified by cropping, these extra
elements are simply hidden from view and are still part of the picture. Think in terms of a piece of paper that
you rolled partly up, like a scroll. The items on the rolled part are still there, but simply hidden from view.
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XIV.

Slide Management Adding, Rearranging and Deleting Slides

So far we have looked at creating only one slide, but you will actually want to create a number of them to develop a
slide show. And once you have several slides, you may find you want to reorder them or delete some of them
altogether. Here is how to do that.
1. Use the New Slide Button
Click on the New Slide button on the Home tab of the ribbon to add a new slide to your presentation. Any new slides
created will retain the design theme you set for your slideshow in the first slide.

2. Deleting a Slide in the Slide tab

Slide Views: Use the Slide View That is Right for the Task
Slides in any PowerPoint presentation can be viewed in a variety of ways depending on the task at hand.
To access all the different slide views, click on the View tab of the ribbon at the top of the PowerPoint screen. On the
left end of the ribbon you will see buttons with the different options to view your slides.
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Deleting Slides
Select the Slide to be Deleted
On the Slides tab of the Slides / Outline task pane on the left of your screen, click on the thumbnail of the slide you
wish to delete. Press the Delete key on your keyboard.

3. Move Slides Using the Slides / Outline Pane
a. Click on the slide you wish to move, to select it.
b. Drag the slide to the new location.
c. A horizontal line appears as you drag the slide. When the horizontal line is in the correct location,
release the mouse.
d. The slide moves to the new location.

93

XV.

Setting up the PowerPoint Slide Show
1.

Slide Transitions - Choose a Slide Transition
1. Click on the Transitions tab of the ribbon to access the slide transition options. The most common
slide transitions are shown as icons on the ribbon.
2.Click the drop down arrow to see the complete list of transitions available, or scroll through the list,
one row at a time.
With PowerPoint 2010, you have the ability to see the transition effect on the slide by hovering the
mouse over the transition choice, prior to making your selection.
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There are several options that you can choose to add to your PowerPoint 2010 slides.

is slide or Apply to All

There are Many Sound Effects to Choose From
Sound effects can be effective if applied wisely to PowerPoint slide transitions. For example -- a presentation
that is about the increasing sales figures might be effective with a cash register sound effect on a slide transition.
There is also an option to Loop Until Next Sound which you can apply to the slide transition. In my opinion, this
should be used only sparingly, and only in certain situations (such as a presentation for small children). The
sound effect will keep repeating until another sound effect is reached, and could be very distracting to the
audience. A single sound effect will certainly make your point.
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2. Previewing your Show

The Slideshow tab will let you set up how your show will progress. First you may want to preview your raw show to see
if the slides seem in the proper order and if you like the transitions.
To preview, click the Slideshow tab and select either From Beginning (to see show from the first slide on) or From
Current Slide (to see show from a slide selected in the Slide Pane onwards).
3. Using the Set Up Show feature to create the delivery of your show

Note that timings for your slides were supposed to be set up in the Slide Transitions step. You can always go back and
adjust them.
The easiest way to set the slide timings is to rehearse and time your PowerPoint presentation by progressing through
the slides as if you were seeing them for the first time. As you click the mouse to advance the slides, PowerPoint can
record the timings on the slides for you.
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XVI.
Saving and Distributing your PowerPoint Show
1. Name and save your presentation
As with any software program, it is a good idea to name and save your presentation immediately and
then to save your changes frequently while you work:
Click the File tab.
Click Save As, and then do one of the following:
For a presentation that can be opened only in PowerPoint 2010 or PowerPoint 2007, in the Save as
type list, select PowerPoint Presentation (*.pptx).
For a presentation that can be opened in either PowerPoint 2010 or earlier versions of PowerPoint,
select PowerPoint 97-2003 Presentation (*.ppt).
On the left-hand pane in the Save As dialog box, click the folder or other location where you want to
save your presentation.
In the File name box, type a name for your presentation, or do nothing to accept the default file
name, and then click Save.
There are other formats to which you can save if you are not sure whether your end users have
access to PowerPoint. These include PDF and video.
2. Printing your show for handouts
To set your printing options (including number of copies, printer, slides to print, number of slides per
page, color options, and more) and then print your slides, do the following:
Click the File tab.
Click Print, and then under Print, in the Copies box, enter the number of copies that you want to
print.
Under Printer, select the printer that you want to use.
Tip If you want to print in color, be sure to select a color printer.
Under Settings, do one of the following:
To print all slides, click Print All Slides.
To print one or more slides that you selected, click Print Selection.
Note: It is always a good idea to set your printing to more than 1 slide per page to save paper.
Tip To select multiple slides to print, click the File tab, and then in Normal view, in the left-hand pane
that contains the Outline and Slides tabs, click the Slides tab, and then press and hold CTRL while you
select the slides that you want.

3. Follow these steps to create a CD to present your slide show on another computer.
Open the presentation that you want to copy, or, if you are working with a new presentation that has
not been saved, save the presentation.
If you want to save your presentation to a CD, rather than to a network or to a local disk drive on your
computer, insert a CD into the CD drive.
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Click the File tab.
Click Save & Send, click Package Presentation for CD, and then in the right pane, click Package for CD.
To choose the presentations that you want to copy and the order in which you want them to play, do
the following:
To add a presentation, in the Package for CD dialog box, click Add, and then in the Add Files dialog box,
select the presentation that you want to add and click Add. Repeat this step for each presentation that
you want to add. Repeat this step also if you want to add other related, non-PowerPoint files to the
package.
If you add more than one presentation, the presentations will appear on a Web page that lets you
navigate to the contents of the CD in the order in which they are listed in the Files to be copied list in the
Package for CD dialog box. To change the order, select a presentation that you want to move, and then
click the arrow buttons to move the presentation up or down in the list.
To remove a presentation or file from the Files to be copied list, select the presentation or file, and then
click Remove.
Click Options, and then under Include these files, do one or both of the following:
1. To ensure that files that are linked to your presentation are included in the package, select the
Linked files check box. Files that are linked to your presentation can include Microsoft Office
Excel worksheets that are linked to charts, sound files, movie clips, and more.
2. To use embedded (embedded object: Information (object) contained in a source file and
inserted into a destination file. Once embedded, the object becomes part of the destination file.
Changes you make to the embedded object are reflected in the destination file.)TrueType fonts
(TrueType font: A font (typeface) that appears on a printed document exactly the way it appears
on the screen. TrueType fonts are scalable to any font size. Several of these fonts are installed
Notes
1. If your presentation does not currently include embedded fonts, checking the
Embedded TrueType fonts check box includes the fonts when packaged. The Embedded
TrueType fonts check box applies to all presentations that are copied, including linked
ones.
2. If your presentation already includes embedded fonts, PowerPoint automatically honors
the setting of the presentation to include the embedded fonts. automatically when you
install Windows.), select the Embedded TrueType fonts check box.
Click OK to close the Options dialog box.
Next o one of the following:
1. If you are copying your presentation to a network or to a local disk drive on your computer, click
Copy to Folder, enter a folder name and location, and then click OK.
2. If you are copying your presentation to a CD, click Copy to CD.

4. Save your presentation as a video
Why turn your presentation into a video?
When you want to give a high-fidelity version of your presentation to colleagues or customers (either as an e-mail
attachment, published to the web, on a CD or DVD), save it and let it play as a video. It is also an excellent format to
include in Blackboard or post on YouTube.
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In PowerPoint 2010, you can now save your presentation as a Windows Media Video (.wmv) file, and distribute it
confidently, knowing that your animated, narrated, multimedia presentation will play without a glitch. If you do not
want to use the .wmv file format, you can use a preferred third party utility to convert your file to another format
(.avi, .mov, etc).

Some tips to remember when recording your presentation as a video:
You can record and time voice narration and laser pointer movements in your video.
You can control the size of the multimedia file and the quality of your video.
You can include animations and transitions in your movie.
Viewers do not need to have PowerPoint installed on their computers to watch it.
If your presentation contains an embedded video, the video will play correctly without your needing to control
it.
Depending on the size your presentation, creating a video can take a long time to create. The longer the
presentation and the more animations, transitions, and other media that you include, the longer it will take.
However, you can continue to use PowerPoint while you wait.
Here s how to do it:
2.
3.
4.
5.
6.
7.
8.

9.

10.
11.
12.

13.

Create your presentation.
(Optional) Record and time narration in a slide show and Turn your mouse into a laser pointer.
Save the presentation.
On the File menu, click Save & Send.
Under Save & Send, click Create a video.
To display all video quality and size options, under Create a video, click the Computer & HD Displays down
arrow.
Do one of the following:
To create a video with very high quality, yet a large file size, click Computer & HD Displays.
To create a video with a moderate file size and medium quality, click Internet & DVD.
To create a video with the smallest file size, yet low quality, click Portable Devices.
Click the Don't Use Recorded Timings and Narrations down arrow and then, do one of the following:
If you did not record and time voice narration and laser pointer movements , click Don't Use Recorded Timings
and Narration.
Tip The default time spent on each slide is set to 5 seconds. To change that, to the right of Seconds to
spend on each slide, click the up arrow to increase, or the down arrow to decrease the seconds.
If you recorded and timed narration and pointer movements , click Use Recorded Timings and Narrations.
Click Create Video.
In the File name box, enter a file name for the video, browse for folder that will contain this file, and then click
Save. You can track the progress of the video creation by looking at the status bar at the bottom of your screen.
The video creation process can take up to several hours depending on the length of the video and the
complexity of the presentation.
Tip For longer videos, you can set it up so that they create over
the following morning.
To play your newly-created video, go to the designated folder location, and then double-click the file.

99

100

58
Lecture
- 11

MS EXCEL: - (EXTENSION .XLS)
Microsoft Excel is a software program produced by Microsoft Corp. that allow users to organize,
format and calculate data with formulas using a spreadsheet system. This software as part of the
Microsoft office suite and is compatible with other applications in the office suite.
MS. EXCEL is a software for performing following tasks/Functions/Works.

Solving Mathematical problems.

Making invoice/Bill.

Making Reports.

Solving goal-seeking problems.

Solving scenario based problems.

Creation of macros.

Plotting Graphs/Charts.

Sketching trend lines/regression analysis for prediction.

Making marks sheet and class lists.

Creation of Templates (Like a blue print).

Making forms.

It also provides facilities for managing database (Collection of related
records).

Accessing of records in MS excel database is called filtering.
Etc.
Above tasks may perform on sheet/spreadsheet/work sheet.A work sheet may exist inside workbook.
Spreadsheet consist of 65536 rows and 256 columns (MS EXEL 2003).And number of rows and
columns in MS excel 2007/2010. are 1048576 and 16384 respectively.
Number of worksheet may depend upon capacity of memory.
Rows represented by numbers and columns are represented by alphabets.

A1, A2, A3, A4…, B1, B2, B3… are called cell references.
TYPES OF CELL REFERENCE:1. RELATIVE CELL REFERENCE.
2. ABSOLUTE CELL REFERENCE.
3. MIXED CELL REFERENCE.
EXAMPLE OF CELL REFERENCES:
RELATIVE CELL REFERENCE.
 A1, A6, B122, D1, D10…

ABSOLUTE CELL REFERENCE
 $A$1, $A$6, $B$122…

MIXED CELL REFERENCE
 $A1, $A6, $B122…
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Microsoft Excel shortcut keys
Shortcut
Description
Edit the selected cell.
F2
After a name has been created, F3 will paste names.
F3
Repeat last action. For example, if you changed the color of text in
F4
another cell, pressing F4 will change the text in cell to the same
color.
F5
Go to a specific cell. For example, C6.
Spell check selected text or document.
F7
Create chart from selected data.
F11
Enter the current time.
Ctrl + Shift + ;
Enter the current date.
Ctrl + ;
Insert New Worksheet.
Alt + Shift + F1
While typing text in a cell, pressing Alt + Enter will move to the
Alt + Enter
next line, allowing for multiple lines of text in one cell.
Open the Excel formula window.
Shift + F3
Bring up search box.
Shift + F5
Open the Format Cells window.
Ctrl + 1
Select all contents of the worksheet.
Ctrl + A
Bold highlighted selection.
Ctrl + B
Italic highlighted selection.
Ctrl + I
Insert link.
Ctrl + K
Save the open worksheet.
Ctrl + S
Underline highlighted selection.
Ctrl + U
Change the format of selected cells.
Ctrl + 1
Strikethrough highlighted selection.
Ctrl + 5
Bring up the print dialog box to begin the printing process.
Ctrl + P
Undo last action.
Ctrl + Z
Open Excel Name Manager.
Ctrl + F3
Minimize current window.
Ctrl + F9
Maximize currently selected window.
Ctrl + F10
Switch between open workbooks or windows.
Ctrl + F6
Move between work sheets in the same document.
Ctrl + Page up
Ctrl + Page down Move between work sheets in the same document.
Move between Two or more open Excel files.
Ctrl + Tab
Create a formula to sum all of the above cells.
Alt + =
Insert the value of the above cell into the cell currently selected.
Ctrl + '
Format number in comma format.
Ctrl + Shift + 1
Format number in currency format.
Ctrl + Shift + 4
Format number in date format.
Ctrl + Shift + 3
Format number in percentage format.
Ctrl + Shift + 5
Format number in scientific format.
Ctrl + Shift + 6
Ctrl + Shift + 2
Format number in time format.
Ctrl + Arrow key Move to next section of text.
Select entire column.
Ctrl + Space
Select entire row.
Shift + Space
Delete the selected column or row.
Ctrl + Insert a new column or row.
Ctrl + Shift + =
Move to cell A1.
Ctrl + Home
Ctrl + ~
Switch between showing Excel formulas or their values in cells.
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HOW TO PERFORM CALCULATION ON SHEET:1. OPERATORS:1.1. ARITHMETIC OPERATORS (+, -, *, /, ^)*(product),/(Division),^(Exponent).
1.2. RELATIONAL OPERATORS (>, >=, <, <=, <>, =). <>(Not equal).
1.3. CONCATENATION OPERATORS(&).
1.4. LOGICAL OPERATORS (AND, OR, NOT).
1.5. RANGE OPERATOR ( : )Example:-A1:A50
2. BASIC PROPERTIES OF FORMULA:1.6. Formula always starts with equal (=) sign.
1.7. A formula may consist of text, numbers, ranges, cell references etc.
1.8. When entered formula into cell it return only result.
Example:Let cell
A1=12
B1=4
C1=2
IN ACTIVE CELL
FOR ADDITION in cell D2
=A1+B1+C1
18
FOR MULTIPLICATION in cell F3
= A1*B1*C1
96
FOR EXPONENTIATION in cell K10
=A1^C1
144
FOR DIVISION in cell A7
=A1/ (B1+C1)
2
SHEET LINKING AND BOOK LINKING:SHEET LINKING
IN BOOK1 (ON SHEET2)
=Sheet1!A1*Sheet1!B1+Sheet1!C1
IN BOOK1 (ON SHEET3)
=Sheet1! A2*Sheet1! B2+Sheet2! A2
BOOK LINKING
OPEN BOOK1 ,BOOK2 and BOOK3
SHEET 1 ON BOOK3
=[Book2]Sheet2!A1*[Book1]Sheet1!B1*[Book1]Sheet1!A1
FUNCTIONS IN MS EXCEL:It is sub program which is used for performing well-defined specific tasks.
There are many types of functions.
1. Arithmetic functions (MATH & TRIG FUNCTIONS).
2. Logical Functions.
3. String Functions.
4. Date and time functions.
5. Statistical Functions.
6. Financial Functions.
7. Lookup reference Functions.
Notation: - f( ) A function with no arguments/Parameters.
f(x,y )A function with arguments/Parameters x and y.
f(x1,x2,x3,x4… )A function with n arguments.

103

61
Arithmetic functions (Math and Trig Functions).
There are following types of arithmetic functions.
SUM( )
SUMIF( )
PRODUCT( )
ABS( )
LOG10( )
LN( )
LOG( )
ROUND( )
CEILING( ) FLOOR( )
SQRT( )
SUMPRODUCT( )
SIN( )
COS( )
TAN( )
PI( )
EVEN( )
ODD( )
RAND( )
EXP( )
ROMAN( )
SUM (N1, N2, N3…):This function is used for performing addition of given n arguments.
Example:=SUM (2, 3, 4, 5, 6, 7)
27
=SUM (A1:A22, B1:B22, C1:C22)
SUMIF (RANGE, CRITERIA, RANGE_SUM)
This function return conditional sum.
Example:A
B
5
7
9
12
13
17
17
22
21
27
25
32
29
37
33
42
37
47
=SUMIF (A1:A9,">=20", B1:B9)
185
PRODUCT (N1, N2, N3…):This function is used for performing multiply of given n arguments.
Example:=product(2,3,4)
24
=PRODUCT (A1:A4)
ABS (NUMBER):It returns absolute value.
Example:=ABS (-9)
or
|-9|
9
Note:- |x|=x when x>=0
|x|=-x when x<0
FACT (Number):It returns factorial values. Number must be positive and integer.
Example
=fact (4)→4*3*2*1
24
=fact (5) →5*4*3*2*1
120
LOG10 (NUMBER):This function returns log value to the base 10.
Example
=LOG10 (14)
1.14612804
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FACT( )
TRUNC( )
SUMSQ( )
MOD( )
POWER( )

62
LN (NUMBER):This function returns log value to the base e.The Value of e exists between 2 and 3.
Example
=Ln (14)
2.63905733
LOG (NUMBER, ANY_BASE):This function returns log of any number to any base.
Example
=LOG (14, 16)
0.95183873
ROUND (NUMBER, SPECIFY_DIGITS):It is used for rounding any number to specify_digits.
=round (342.5678, 2)
342.57
=round (342.5673, 3)
342.567
TRUNC (NUMBER, SPECIFY_DIGITS):It is used for truncating any number upto specify_digits.
Example:=trunc (342.5678, 2)
342.56
CEILING (NUMBER, SIGNIFICANT_DIGITS):This function return a number up to, nearest integer multiple of significant_digits.
Example:=ceiling (67.45, 13)
78
FLOOR (NUMBER, SIGINFICANT_DIGITS):This function return a number down to, nearest integer multiple of significant digits.
Example:=floor (67.45, 13)
65
SQRT (NUMBER):This function return square root of any positive number.
Example:=sqrt (25)
5
SUMSQ (n1, n2, n3…):This function return sum of square.
Example:=SUMSQ (2, 4, 5)
45
=SUMSQ (A1:A9, B1:B9)
SIN (NUMBER):This function return sine of any angle.
Example:=SIN (90*PI ()/180)
1
Cos (NUMBER):This function return cosine of any angle.
Example:=COS (45*PI ()/180)
0.707107
Tan (NUMBER):This function return tangent of any angle.
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Example:=Tan (45*PI ()/180)
1
Pi ( ):This function returns value of 22/7.
Example:=PI ( )
3.141593.
MOD (number, divisor):This function returns remainder value.
Example:=MOD (15, 4)
3
EVEN (Number):This function returns upto nearest even integer value.
Example:=even (4.2)
6
ODD (Number):This function returns upto nearest odd integer value.
Example:=odd (4.2)
5
RAND ( ):This function returns random numbers between 0 and 1.
Example:=RAND ( )
0.4632
EXP (Number):This function returns exponential value of any number.
=exp (4)
54.59815
Note:- 2<e<3
POWER (m, n):This function returns power of m to n.
=power (2, 3)
8
Roman (number):This function converts any number into roman value.
=roman (23)
XXIII
Sumproduct (n1, n2,n3,n4…):It return sum of product.
Example:=SUMPRODUCT (A1:A16,B1:B16)
Logical Function:This category of function returns logical values. Either True or False.
There are following types of logical functions.
AND( )
OR( )
NOT( )
If( ) TRUE( )
FALSE( )
AND (Logical1, Logical2, Logical3…):This function return true when all logical expressions are true. In addition, return false if any
one logical expression is false.
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Example:=and (4>3, 6<3, 9>77)
False
=and (4>3, 6>3, 9<77)
True
OR (Logical1, Logical2, Logical3…):This function return true when any one logical expression is true. In addition, return false if all
logical expressions are false.
Example:=or (4>3, 6<3, 9>77)
True
=or (4<3, 6<3, 9>77)
False
NOT (Logical):It reverses logical value.
Example:=not (6>4)
False
Example:=not (and (4>3, 8>9, 76>6))
True
True

if (Condition,”True_Expression”,”False_expression”)
Example:=if (9>4, 6*2, 9*3)
12.
=if (9<4, 6*2, 9*3)
27.

False

Lecture - 12
Make a payroll system.

SNO

ENAME

BASIC

HRA

DA

TA

GS

IT

LIC

NET_SAL

HRA=IF (C2>=25000, C2*50%, IF (C2>=20000, C2*30%, IF (C2>=15000, C2*20%, C2*15%)))
DA=IF (C2>=25000, C2*40%, IF (C2>=20000, C2*25%, IF (C2>=15000, C2*15%, C2*10%)))
TA=IF (C2>=25000, C2*30%, IF (C2>=20000, C2*15%, IF (C2>=15000, C2*10%, C2*8%)))
GS=BASIC+HRA+DA+TA
IT=IF(G2>=50000,G2*25%,IF(G2>=35000,G2*20%,IF(G2>=25000,G2*15%,IF(G2>=15000,G2*10
%,0))))
LIC=IF(G2>=50000,G2*15%,IF(G2>=35000,G2*12%,IF(G2>=25000,G2*9%,IF(G2>=15000,G2*7%,
G2*6%))))
NET_SAL= GS- IT- LIC
EXAMPLE 2:CLASS LIST:CLASS LIST
Sno

Name

Hindi

English

Phy

Math
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Che

Tot

Per

Div

Grade

Status

65
Tot=SUM(C4:G4)
Per=H4/5
Div=IF(I4>=60,"I",IF(I4>=45,"II",IF(I4>=33,"III","NC")))
Grade=IF(I4>=85,"A",IF(I4>=75,"B",IF(I4>=65,"C",IF(I4>=55,"D",IF(I4>=45,"E",IF(I4>=33,"F",
" "))))))
Status=IF(AND(C4>=33,D4>=33,E4>=33,F4>=33,G4>=33),"SC","F")
EXAMPLE 3:
Marks Sheet:INSTITUTE OF COMPUTER SCIENCES& MANAGEMENT
Enroll
Name
Fname
Mname
Cname Office Management
P_Code
OM1
OM2
OM3
OM4
OM5
OM6

Paper's name

Mode

Aggregate_Total

Private Regular

Certificate
Max_Marks

Computer Fundamental
MS OFFICE
DBMS
WEBPAGE
DESIGNING
TALLY
ASSIGNMENT

Signature of Director

Session

MIn_Marks

70
70
70

25
25
25

70

25

100
120
500

45
55
200

OBT_Marks

Total

0

Status

Per

Div

0

Behavior

Result

Attendance

Character

0

Checked By

Seal of Institution

Total=SUM (G11:G16)
Per =H11/5
Div =IF (I11>=60,"I", IF (I11>=45,"II", IF (I11>=33,"III", IF (I11>0,"NC", " "))))
Status =IF (AND (G11>=F11, G12>=F12, G13>=F13, G14>=F14, G15>=F15, G16>=F16),
"Passed","Failed")
Behavior
=IF(I11>=85,"Best",IF(I11>=75,"Better",IF(I11>=60,"Good",IF
(I11>=45,"Normal",IF
(I11>=33,"Poor","Very Poor")))))
Attendance =IF (I11>=85,"95%", IF (I11>=75,"85%", IF (I11>=65,"75%", IF (I11>=45,"50%",
IF (I11>=33,"40%", IF (I11>0,"20%"," "))))))
UTTAR PRADESH RAJARSHI TANDON OPEN UNIVERSITY ALLAHABAD
P_Code
Name of Papers
Max_Marks Min_Marks Obt_marks
Per
Status
CCC-01
MS OFFICE &
100
35
56
66.33
SC
INTERNET
CCC-02
FOXPRO
100
35
66
Div
SC
CCC-03

THE TECHNOLOGY

TOTAL
Per=ROUND(H6/3,2)

100

35

77

300

105

199

108

Passed With I

SC

66
Div=IF(AND(H3>=G3,H4>=G4,H5>=G5,I3>=60),"Passed With
I",IF(AND(H3>=G3,H4>=G4,H5>=G5,I3>=45)," Passed With
II",IF(AND(H3>=G3,H4>=G4,H5>=G5,I3>=35)," Passed With III","F")))
Status=IF(AND(H3>=G3),"SC","NC")

EXAMPLE 4:INVOICE/CASH MEMO:ABC Drugs & Medicine
Name Of Customer
Address
Contact Number
Sno
Particular
1
M1
2
M2

Qty
12
15

Rate
45
80

Amount
$ 540.00
1,200.00
-

Aggregate_Total

Authorized signature

VAT
$27.00
60.00
-

Net_Amt
$ 567.00
1,260.00
1,827.00

Received By

Note:-Sold of goods never return.
Amount=C7*D7
VAT=IF(E7>=50000,E7*20%,IF(E7>=35000,E7*15%,IF(E7>=25000,E7*10%,IF(E7>=15000,E7*8%
,E7*5%))))
NET_Amt=E7+F7
Aggregate_total=SUM (G7:G18)
3:-String Function/Text Functions:Sequence of characters is called string. It encloses within double quotes.
Example:“RAM is a student”
String
“Mahesh Kumar Singh”
String
“1324344589463”
String.
Types of String functions/Text Functions:char( )
code( )
concatenate( )
exact( )
find( )
left( )
len( )
lower( )
mid( )
proper( )
replace( )
right( )
search( )
substitute( )
trim( )
upper( )
Char(number):This function returns character of corresponding ASCII code.
Example:-
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=CHAR (69)
E
Code (text):This function returns ASCII code of corresponding text.
Example:=Code (”A”)
65
=Code (“ICSM”)
73
Concatenate (text1, text2,…):This function is used for joining two or more text string into one text string.
Example:=Concatenate (“Ram”,” “,”Kumar”,” “,”Singh”)
Ram Kumar Singh.
Example:=CONCATENATE (A1," ",D3," ",B5)→A1=Manoj,D3=Kumar,B5=Singh
Manoj Kumar Singh.
Exact (Text1, Text2):This function is used for comparing two text string, and return true if both are
exactly same otherwise false.
Example:=Exact(“RAM”,”ram”)
False
Example:=Exact(“RAM”,”RAM”)
True
Find (Find_text, Within_text,start_num):This function return starting position of one text string within another text string.
Example:=FIND ("R","VARANASI",1)
3
=FIND ("A","VARANASI",5)
6
Left (Text, number_Char)
It return left most number of characters. Specified by number_char
Example:=Left ("VARANASI",4)
VARA
Len (Text)
It counts number of characters of given text string.
Example:=Len ("VARANASI")
8
Lower (Text)
It converts upper text string into lower text string.
Example:=Lower (“RAM”)
ram
Mid (text, start_num, num_chars):It returns character middle from text string.
Example:=mid(“varanasi”,3,4)
rana
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Proper (Text):This function capitalizes first character into upper case and remaining characters are lower case.
Example:=PROPER ("manoj is a good boy")
Manoj Is A Good Boy
Replace(Old_text,Start_Num,Num_Char,New_Char):This function replaces a part of text by new string.
Example:=REPLACE ("varanasi", 2, 4,"ICSM")
vICSMasi
Right (Text, num_Char)
It returns right most number of characters. Specified by num_char
Example:=right ("VARANASI",4)
NASI
Search(Find_Text, Within_Text,Start_Num):This function is used for searching text in given text string.
Example:=SEARCH("n","varanasi",1)
5
Substitute (text,old_text,new_text,instance_num):This function replaces old text_string by new_text string.
EXAMPLE:=SUBSTITUTE ("RAM SHYAM SITA GITA RAM MOHAN","RAM","RAVI", 2)
RAM SHYAM SITA GITA RAVI MOHAN
TRIM (TEXT):This Function Remove many spaces into single space.
EXAMPLE:=Trim (“hellow how are you”)
hellow how are you
Upper (TEXT):It converts lower text string into upper text string.
EXAMPLE:=Upper(“welcome”)
WELCOME
4:-Date & Time Functions:now()
today()
date()
weekday()
year()
month()
day()
hour()
minute()
second()
Now ( ):This function return current date and time of system.
=Now( )
2/1/2013 16:25
Today ( ):- This function return current date of system.
=today ()
2/1/2013
Format
mm/dd/yy
Date (year, month, day):This function returns given arguments as date format.
Example:=Date(2012,12,8)
12/8/2012
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Weekday (serial_Number):This function returns code of the day.
1=sunday,2=Monday…7=Saturday.
Example:=WEEKDAY ("1/2/2013")
4
Year(“Serial_Number”):This function return year of corresponding serial numbers.
Example:=year("3/2/2012")
2012
Month(“Serial_Number”):This function returns Month of corresponding serial numbers.
Example:=month("3/2/2012")
3
Day (“Serial_Number”):This function return day of corresponding serial numbers.
Example:=day("3/2/2012")
2
Hour (“Serial_Number”):This function return hour of corresponding serial numbers.
Example:=Hour ("12:20:23")
12
Minute (“Serial_Number”):This function return minute of corresponding serial numbers.
Example:=Minute ("12:20:23")
20
Second (“Serial_Number”):This function return second of corresponding serial numbers.
Example:=Second ("12:20:23")
23
5:-Statistical Function:This categories of function perform statistical task. There are following types of functions
including.
max()
min()
average()
count()
countif()
mode()
median()
max(n1,n2,n3,n4…):This function returns the largest value.
Example:=max (2, 4, 3, 7, 6, 5, 4, 99, 2,3,4)
99
min (n1, n2,n3,n4…):This function returns the smallest value.
Example:=min (2, 4, 3, 7, 6, 5, 4, 99, 1, 2, 3, 4, 5)
1
Average (n1, n2, n3, n4…):This function return average value.
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Example:=average (2, 4, 3, 7, 6, 5, 4, 99)
16.25
count(n1, n2,n3,n4…):This function count number of cells.
Example:=count (3, 2, 5, 4, 3)
5
countif (range, criteria):This function count number according criteria.
Example:A
1

8

2

15

3

22

4

29

5

36

6

43

7

50

8

57

9

64

=COUNTIF (A1:A9,">=30")
5
Mode (n1, n2, n3…)
This function is used for display most frequently used numbers.
Example:=mode(2,2,2,3,3,2,2,2,2,2,5,5)
2
Median (n1, n2, n3, n4,….):This function is used for finding mid values.
Example 1:=median (3, 2, 5, 4, 7)
4
Example 2:=median (3, 2, 5, 4, 7, 9)
4.5
6:-Financial Function:DB( )
DDB( )
FV( )
PV( )

SLN( )

PMT( )

DB (COST, SALVAGE, LIFE, PERIOD):This function is used for calculating depreciation of assets using fixed declining balance
method.
Example:Purchase cost of an asset (Say Fridge)=10000/After 4 years its values (salvage) =7000/-
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Life=4
What will be depreciation for next 1 year?
=db(10000, 7000,4, 1)
850.00
DDB (COST, SALVAGE, LIFE, PERIODE):This function is used for calculating depreciation of assets using double declining balance
method. Example:=ddb (10000, 7000, 4, 1)
3,000.00
FV (rate, nper, pmt):It returns the future value of an investment. Based on periodic constants payments and
constant interest rate.
Example:Suppose we want to deposit 12000/- per year in RD(recurring Deposit) account.
PMT=12000/Rate of interest=7.5% per annum.
Number of periode (nper) =5 years.
=FV (7.5%, 5, 12000).
69,700.69.
PV (rate, nper, pmt):It returns the present value of an investment. The total amount of that a series of future
Payment is worth now.
Example:- =PV (7.5%, 5, 12000).
48,550.62
SLN (cost, salvage, Period):This function calculates straight-line depreciation of an asset.
Example:Purchase cost of an asset (Say Fridge)=10000/After 4 years its values (salvage)=7000/Period=4
=SLN (10000, 7000, 4)
Rs 750
PMT (rate, nper,pv):It calculates premium value of loan amount.
Example:Loan Amount(PV)=200000/Rate=12%
nper=10 Years
=PMT(12%,10,200000)
Rs.35,396.83
7:-Lookupreference Function:This categories of function is used for searching. There are following two functions are used.
 hlookup()
 vlookup()
Hlookup (lookup_value, Range, row_number, false)→ for horizontal searching
Vlookup (lookup_value, Range, Col_number, false) →for vertical searching
Example:Name
Basic
HRA
DA
TA
GS
Amit
5678
1200
800
567
8245
Ajay
8765
1300
897
543
11505
Vijay
4456
1700
678
456
7290
Sanjay
3467
800
879
765
5911
Rakesh
8877
900
890
434
11101
Ratan
8976
1600
875
654
12105
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=HLOOKUP (A1, A1:F7, 4, FALSE)
Vijay
=VLOOKUP (Vijay, A1:F7, 6, FALSE)
7290

Lecture - 13

Chart (Graph):- Most Important
It is a graphic component of data series in MS Excel.It is an effective way for
representating and understanding data series in Excel. There are many types of charts.
 Column Chart.
 Bar Chart.
 Line Chart.
 Area Chart.
 X,Y Scattered chart.
 Radar Chart.
 Pie Chart.
 Doughtnut Chart.
 Cone Chart.
 Cylinder Chart.
 Pyramidical chart.
 Bubble Chart.
 Stock Chart.
Components of chart:Chart Title. Chart area.
Plot area.
Legends.
X-axis Title.
Y-Axis Title. Z-Axis Title. Data series. Grid Lines. Data Markers.

DELHI
Q1
Q2
Q3
Q4

12
14
12
17

15
17
19
20

ABC Pvt Ltd(Sales In Crore)
MUMBAI
KOLKATA
9
12
15
10
ABC PVT LTD

CHENNAI
13
10
13
19
Chart Title
Chart area

25

20
Q1

15

Plot area

Amt

Q2
Q3
10

Q4

Grid Line

5

0
DELHI

MUMBAI

KOLKATA

CHENNAI

Legend

City

Data Series
Y-axis

X-axis

Column Charts :It consists of a series of vertical columns. That allows comparison of two or more
Data series.
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Bar Chart:It consists of a series of horizontal bars.It allows comparisons of two or more data series.

Line Chart:It consists of a series of lines with different colors and shading.
25

20

Q1

15

Q2
Q3
10

Q4

5

0
DELHI

MUMBAI

KOLKATA
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CHENNAI
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Area Chart:It is stacked line chart, with the area between the lines filled with color and shading.
Data series are plotted one on top of other.

X-Y Scattered Chart:The value of data series is plotted as the intersection point of x-axis and y-axis.
25

20

Q1

15

Q2
Q3
10

Q4

5

0
0

1

2

3

4

5

Radar Chart:It allows the data values in relation to the center point and to each other. Data of the same data
series are connected by lines.
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Pie Chart:It is the best way for representing data series in percent form.
DELHI
Q1
12
Q2
14
Q3
12
Q4
17
Total Amount=12+14+12+17= 55.
% of Q1
=
12/55*100
=
21.81818%.
% of Q2
=
14/55*100
=
25.45455%.
% of Q3
=
12/55*100
=
21.81818%.
% of Q4
=
17/55*100
=
30.90909%.
Calculation of Angle:Angle for Q1 =
360*21.81818%
=
78.54545 Degree.
Angle for Q2 =
360*25.45455%
=
91.63636 Degree.
Angle for Q3 =
360*21.81818%
=
78.54545 Degree.
Angle for Q4 =
360*30.90909%
=
111.2727 Degree.

DELHI

Q1
Q2
Q3
Q4

Doughnut Chart:It is same as pie chart but represent percentage form of all data series.
ABC PVT Ltd

DELHI
MUMBAI
KOLKATA
CHENNAI
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Cone Chart:It consists of series of cones. That compares data series.

Cylinder Chart:It consists of series of cylinders. That compares data series.

Pyramid Chart:It consists of series of pyramids. That compares data series.
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Trend Lines/Regression Analysis:It is also known as regression analysis, which is used for prediction (Forecasting) of growth. It
may be either positive (Forward) or negative (backward).
There are many types of trend lines.

Linear Trend Lines.

Logarithmic Trend lines.

Polynomial trend lines.

Power Trend Lines.

Exponential Trend Lines.

Moving Trend Lines.
Note:-Regression analysis provides relationship between practical values/actual Values and theoretical
values.
Note:-Trend line may be sketching only in column chart,Bar chart,Line chart.
25
y = -0.5761Ln(x) + 12.708

y = 2x + 8

20
y = 17.442e-0.0359x
Q1

15

Q2
Q3

10

Q4
5

Log. (Q1)
Linear (Q3)

0

Expon. (Q4)
DELHI

MUMBAI

KOLKATA

CHENNAI

Lecture 14
Database Power of MS Excel:It is collection of related records organized into tabular form.A table may consist of
rows and columns. Rows are known as tuples and columns are known as attributes.
Example:- 
Employee records.

Student Records.

Patients Records.

Telephone Directory.

Voter ID Records. Etc
DBMS (Database Management System):It is an efficient system or s/w by which we manage database.
Example:Oracle.
SQL server.
MS Access.
DB-2.
Ingress.
FoxPro.
Etc.
Employee
Name
Basic
HRA
DA
TA
GS
5678
1200
800
567
8245
Amit
Ajay
8765
1300
897
543
11505
Vijay
4456
1700
678
456
7290
Sanjay
3467
800
879
765
5911
Rakesh
8877
900
890
434
11101
Ratan
8976
1600
875
654
12105
Number of attributes=6(Six)
Number of Tuples=6(Six)
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EMP (Table):Eno

Ename

Job

Sal

Deptno

101

Ajay

Steno

12000

10

102

Vijay

Manager

22000

20

103

Mukesh

Clerk

10000

10

Eno, Ename, Job, Sal, Deptno→
Fields Name/Attributes Name/Column Name
Number of Attributes=5
Number of Tuples=3
Cardinality of EMP table=3
Degree/Arity of EMP=5
Filter/Questionaries on database/Query:To access records from excel database is called filtering.
Element for Filtering:Operator
1. Arithmetic Operator( +,-,*,/,^)
2. Relational Operator(>,<,>=,<=,<>)
3. Logical Operator( and,or,not)
4. Predicate Operator
a. begin with
b. not begin with
c. end with
d. not end with
e. between
f. not between
g. greater than or equal to
h. not greater than or equal to
i. less than or equal to
j. not less than or equal to
k. exist
l. not exist
Pivot Table:It is an interactive table for analyzing excel database. It facilitate comparative analysis
using charts, data series.A pivot table may also be updated when data series updated.
Example:SALES REPORT(Sales Amount in Crore)
Name
Product
City
Amount
Amit
TV
VNS
20
Ajay
TV
VNS
22
Mahesh
AC
VNS
23
Neeraj
AC
VNS
25
Mukesh
AC
ALD
27
Neeraj
AC
ALD
27
Suresh
TV
VNS
23
Suresh
TV
ALD
27
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Pivot Chart
Product (All)

30

Sum of Amount

25

20

City
15

VNS
ALD

10

5

0
Ajay

Amit

Mahesh

Mukesh

Name

Lecture - 15
Focus on Analysis:Goal Seek:It determines the input required to produce the desired result.
Or
In computing, goal seeking is the ability to calculate backward to obtain an input that would result in a
given output. This can also be called what-if analysis or back-solving. It can either be attempted
through trial and improvement or more logical means.
Example:Subject
Marks
HINDI
56
ENGLISH
67
MATHS
78
PHYSICS
55
CHEMISTRY
TOTAL
256
PER
51.2
TOTAL
=SUM(B2:B6)
PER =B7/5
CHEMISTRY=?
PER=63%
SELECT%
CELLTOOLSG
OAL SEEK
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PRESS OK
Subject
HINDI
ENGLISH
MATHS
PHYSICS
CHEMISTRY
TOTAL
PER

Marks
56
67
78
55
59
315
63

Scenario Manager:Scenarios are part of a suite of commands sometimes called what-if analysis tools. A scenario is
a set of values that Microsoft Excel saves and can substitute automatically in your worksheet. You can
use scenarios to forecast the outcome of a worksheet model.
Loan
Rate
Period
Premium
200000
10%
5
($52,759.50)
Premium=PMT (B2, C2, A2).
Now we make a scenario for following amounts.
Loan
Rate
Period
Premium
200000
10%
5
($52,759.50)
200000
10.5%
10
200000
11%
15
300000
10%
5
300000
10.5%
10
300000
11%
15
400000
10%
5
400000
10.5%
10
400000
11%
15
Step1:-Select Premium Cell.
Step2:-Select And Click Scenario from Tools menu.
Step3:-Click Add Option from Scenario Manager.
Step4:-Scenario Name=200k & 5yrs.
Changing Cell=$A$2, $B$2, $C$2.
Step5:-Press Ok.
Step6:-Click Add.
Step7:-After feeding above Values Scenario Manager Look Like below.
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200k & 5yrs

Scenario Summary
81
200k & 200k & 300k & 300k & 300k & 400k & 400k &
10yrs
15yrs
5yrs
10yrs
15yrs
5yrs
10yrs

Amount

200000

200000

200000

300000 300000

300000

400000

400000

Rate

10%

15%

11%

10%

15%

11%

10%

15%

Period

5

10

15

5

10

15

5

10

Premium

$52,759.50

$39,850. $27,813. $79,13
41
05
9.24

$59,775. $41,719 $105,51
62
.57
8.99

$79,700
.83

Step 8:-Click Summary
TEMPLATE:It is a blue print, which is used for making similar types of worksheet such as
Invoice.Mark sheet. Class List.Balance sheet.Expense Statement.Loan amortization.Sales
Invoice.
Time CardEtc.
There are two categories of templates
1. User Defined Template.
2. Built in Template/System Defined Template.
EXAMPLE User Defined Template:INSTITUTE OF COMPUTER SCIENCES & MANAGEMENT
Class List
Sno
Sname
Hindi
Eng
Maths
Physics
Chem
TOT=SUM(C4:G4)
PER=H4/5
Built in Template (PREDEFINED TEMPLATE).
 Balance sheet.
 Expense Statement.
 Loan amortization.
 Sales Invoice.
 Time Card.
Example Of balance Sheet:-
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Tot
0

Per
0

82
Example of Expense Statement.

Example Of Loan Amortization:-

Example Of Sales Invoice:Example of Invoice.
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Printing In MS Excel:It is hard copy of worksheet. Before printing user set formatting of sheet.
User mainly focus on following points.
1. Margins
 Left Margin.
 Right Margin.
 Top Margin.
 Bottom Margin.
 Header Margin.
 Footer Margin.
 Gutter Margin(For Binding Space).
2. Header & Footer
3. Page orientations
 Landscape→(Vertical Printing)
 Portrait→
(Horizontal Printing)
4. Paper’s Size
 Letter Size
8.5 inch*11 inch
 A4 Size 210 * 297 MM
 A5 Size 8.27*5.83
 Legal 14 inch*8.5 Inch
 Tabloid 17 inch *11 inch
Etc.
Print dialog Box:-
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Lecture - 16

Digital Financial Services
PPF
Public Providend Fund
EPF
Employee Provided Fund
NSC
National Saving Certificate
KVP
Kisan Vikas Patra
NEFT
National Electronic Funds Transfer
RTGS
Real Time Gross Settlement
IFSC
Indian Financial System Code
CFMS
Centralized Funds Management System
PMJDY
Pradhan Mantri Jan-Dhan Yojana
PMSBY
Pradhan Mantri Suraksha Bima Yojana
PMMY
Pradhan Mantri Mudra Yojana
NPS
National Pension Scheme
KYC
Know Your Customer
Financial Year Commencement Date 1 April of Current year
Financial Year Closing Date
31 March of Next Year

Description of IFSC in brief:IFSC: Indian Financial System Code. The Payment Systems such as National Electronic Funds Transfer (NEFT),
Real Time Gross Settlement (RTGS) & Centralized Funds Management System (CFMS) used IFSC Codes. IFSC
developed by the Reserve Bank of India.
The code consists of 11 Characters : (e.g ICIC0000438)
First 4 characters represent the entity (ICIC0000438)
Fifth position has been defaulted with a '0' (Zero) for future use (ICIC0000438)
Last 6 character denotes the branch identity (ICIC0000438)
IFSC is being identified by the RBI as the code to be used for various payment system projects within the country
Describe PPF in brief:PPF account can be extended after the completion of 15 years, subscriber doesn’t need to put any amount after
the maturity. This is the default option meaning if subscriber doesn't take any action with in one year of his PPF
account maturity this option activates automatically. Any amount can be withdrawn from the PPF account if the option
of extension with no contribution is chosen. Only restriction is only one withdrawal is permitted in a financial year.
Rest of the amount keeps earning interest.
Note:1:-Any person can open PPF account.
2:-Total Period of PPF a/c 15 years.
3:-Minimum amount deposited into PPF a/c is Rs.500/4:-Maximum amount deposited into PPF a/c is Rs.150000/5:-12 times can be deposited into PPF a/c in a financial year.
6:- Annual contributions qualify for tax rebate under Section
80C of income tax







Define Atal Pension Yojna (APY) in brief:The Government of India has announced a new scheme called Atal Pension Yojana (APY). APY is a guaranteed
pension scheme and is administered by the Pension Fund Regulatory and Development Authority (PFRDA).
Features:Guaranteed monthly pension for subscribers, ranging from Rs. 1,000 to Rs. 5,000 per month.
Government of India (GoI) will also co-contribute 50% of the subscriber’s contribution or Rs. 1,000 per annum, whichever is
lower. The Government co-contribution is available for those who are not covered by any Statutory Social Security Schemes
and is not an Income Tax payer.
GoI will co-contribute to each eligible subscriber, for a period of 5 years who joins the scheme in the period June 1 to
December 31, 2015. The benefit of five years of Government co-contribution under APY (ATAL PANSION YOJNA) would
not exceed 5 years for all subscribers including migrated Swavalamban beneficiaries.

127

Indicative APY Contribution Chart (Age wise)
Age
of
Entry






Years of
Contribution

Monthly
pension of
Rs. 1000.

Monthly
pension of
Rs. 2000.

Monthly
pension of
Rs. 3000.

Monthly
pension of
Rs. 4000.

Monthly
pension of
Rs. 5000.

18

42

42

84

126

168

210

19

41

46

92

138

183

228

20

40

50

100

150

198

248

21

39

54

108

162

215

269

22

38

59

117

177

234

292

23

37

64

127

192

254

318

24

36

70

139

208

277

346

25

35

76

151

226

301

376

26

34

82

164

246

327

409

27

33

90

178

268

356

446

28

32

97

194

292

388

485

29

31

106

212

318

423

529

30

30

116

231

347

462

577

31

29

126

252

379

504

630

32

28

138

276

414

551

689

33

27

151

302

453

602

752

34

26

165

330

495

659

824

35

25

181

362

543

722

902

36

24

198

396

594

792

990

37

23

218

436

654

870

1,087

38

22

240

480

720

957

1,196

39

21

264

528

792

1,054

1,318

40

20

291

582

873

1,164

1,454

Penalty for default
Under APY, the individual subscribers have to make the contribution on a monthly basis. Banks are required to collect
additional amount for delayed payments, such amount will vary from minimum Rs. 1 per month to Rs. 10 per month as shown
below:
Rs. 1 per month for contribution up to Rs. 100 per month.
Rs. 2 per month for contribution up to Rs. 101 to 500 per month.
Rs. 5 per month for contribution between Rs. 501 to Rs. 1,000 per month.
Rs. 10 per month for contribution beyond Rs. 1,001 per month.
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National Pension Scheme (NPS)
NPS (National Pension System) is a defined contribution based Pension Scheme launched by Government of India with the
following objectives




To provide old age income.
Reasonable market based returns over long run.
Extending old age security coverage to all citizens.
It is based on a unique Permanent Retirement Account Number (PRAN) which is allotted to each Subscriber upon joining NPS.
The Government of India in exercise of their executive powers adopted 'National Pension System' (NPS) based on defined
contributions in respect of all new entrants to Central Government services, excepting the Armed Forces, with effect from 1st
January 2004. Most of the State Governments have since notified a similar pension system for their new entrants. NPS
accumulates savings into subscribers PRA while he is working and use the accumulations at retirement to procure a pension for
the rest of his life.

Pradhan Mantri Mudra Yojana (PMMY):PRADHAN MANTRI MUDRA YOJANA (PMMY), a flagship scheme of Government of India, was launched on 8th
April, 2015 by the Hon’ble Prime Minister to “fund the unfunded” by bringing such enterprises to the formal financial
system and extending affordable credit to them.
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PRADHAN MANTRI JEEVAN JYOTI BIMA YOJANA DETAILS OF THE SCHEME:
The scheme will be a one year cover, renewable from year to year, Insurance Scheme offering life insurance cover for death
due to any reason. The scheme would be offered / administered through LIC and other Life Insurance companies willing to
offer the product on similar terms with necessary approvals and tie ups with Banks for this purpose. Participating banks will be
free to engage any such life insurance company for implementing the scheme for their subscribers.
Scope of coverage:
All savings bank account holders in the age 18 to 50 years in participating banks will be entitled to join. In case of multiple
saving bank accounts held by an individual in one or different banks, the person would be eligible to join the scheme through
one savings bank account only. Aadhar would be the primary KYC for the bank account.
Benefits:
Rs.2 lakh is payable on member’s death due to any reason
Premium:
Rs.330/- per annum per member. The premium will be deducted from the account holder’s savings bank account
through auto debit facility in one installment, as per the option given, on or before 31 st May of each annual coverage period
under the scheme. Delayed enrollment for prospective cover after 31st May will be possible with full payment of annual
premium and submission of a self-certificate of good health. The premium would be reviewed based on annual claims
experience. However, barring unforeseen adverse outcomes of extreme nature, efforts would be made to ensure that there is no
upward revision of premium in the first three years.
Mobile Banking:Mobile banking is a service provided by a bank or other financial institution that allows its customers to conduct some
financial transactions remotely using a mobile device such as a mobile phone or tablet.

Mobile wallet :Mobile wallet is a very young concept in India that has taken on consumer psyche rapidly. Everyone
is loving mobile wallets and embracing them with open arms. Today, mobile wallet is one of the successful
business ideas for start-ups.
What is insurance:An arrangement by which a company or the state undertakes to provide a guarantee of compensation
for specified loss, damage, illness, or death in return for payment of a specified premium.
Here's a list of the investment plans you can benefit from:
1:-Term Plans
Term Insurance helps the customers in safeguarding their families from financial worries
that arise due to unfortunate circumstances. Term plans are pure risk cover plans with or without maturity
benefits. These pure risk plans cover your life at a nominal cost
2:-Health insurance
The purpose of health insurance is to help you overcome unforeseen emergencies without
compromising on any other financial goal. Health insurance helps you pay for all your medical
expenses. A health insurance policy also gives you the benefit of covering your loved ones
under one plan to avoid any financial constraints arising on account of a medical emergency.
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The benefits:
 Cashless hospitalization in all major hospitals pan India
 Coverage of pre and post hospitalization expense
 Coverage of all major day care treatments
3:-Endowment Plans
Endowment Plans are an ideal choice for the risk-averse customer. Endowments are long-term, regular savings plans
with a built-in life cover. Provided you have paid all your premiums, at the end of the term the policyholder receives the sum
assured plus accrued /guaranteed bonuses that have been declared over the years, as a lump sum. In case of the unfortunate
death during the term of your plan, the sum assured, will be paid out as a lump sum with the bonuses that the policy is entitled
to.
The benefits of Endowment Plans are as follows:
 Available as money back plans also
 Option to avail a host of additional rider benefits
 Cover your life for a longer period of time
 Loan facility can be availed against most of the plans.
4:-Whole Life Insurance
Whole Life Insurance plans provide cover throughout your lifetime. The premium could be paid
for as long as a lifetime or for a limited period.
5:-Group Insurance
Group insurance covers a group of people, usually members of societies, employees of a common
employer, or professionals.
6:-Retirement Plans
Retirement Plans make sure that you have support in the twilight years of your life. The
savings you set aside today become your wealth and support in the years to come.
6:-Children Plans
Insurance today offers a very simple assurance in terms of monetary support to a child
and family incase of death or disability of parent and helps ensure that the shortage of fund
never hampers dreams or aspirations of your child. In short, Children's Plans ensure a secured
financial future for your child.
7:-Wealth Plans
Wealth plans invest the premium in to the equity, debt and cash markets by allocating units,
which like any other mutual fund have a NAV.
Term Insurance helps the customers in safeguarding their families from financial worries that arise due to unfortunate
circumstances. Term plans are pure risk cover plans with or without maturity benefits. These pure risk plans cover
your life at a nominal cost.
Term plans also let you avail the benefit to cover your outstanding debts like mortgage, home loan etc. In case of
something happens to you, the financial burden is borne by the insurance company and not your loved ones.






Term Plan offers you the following benefits:
High insurance Cover at lower costs
Financial security against loans and mortgages,
Single premium payment option available
Available with host of Additional rider benefits
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Lecture

Introduction of Computer Network and Internet
What is communication Signal and Technology:DATA COM M UNICATI ON AND COM PUTER NETWORK
Data communications refers to the transmission of this digital data between two or more
computers and a computer network or data network is a telecommunications network that allows
computers to exchange data. The physical connection between networked computing devices is
established using either cable media or wireless media. The best-known computer network is the
Internet.
Transmission of electrical signal/Optical signal by means of communication channel/media from one
node to another node is called communication.
Sender(S) -------------------------------------------------------------Receiver (R)

Channel/Media
Types of signal for network: Analog Signal
 Digital Signal
 Light Signal
Note:-Transmission speed measured in bits per second/baud rate/Bandwidth.
For performing transmission a protocol must be needed. Set of formalized access rule is called protocol.
Example: TCP/IP Protocol (Transmission Control protocol /Internet protocol).
 UDP (User data Gram Protocol)
Role/Function/Task of Protocol: It transfer error free message.
 It identifies destination address.
 It also identifies/Search idle channel for communication.
 Error recoveries.
 Retransmission control.
 Interface management.
Concept of Computer Network:Before discussion the internet first of all we should discuss about the network, because if our concept
will not be clear about the network then we cannot understand concept of internet. So let us start the
discussion of the network. Network word made-up with two words.
Net/work
Net
+ Work
Web/cobweb + task/function
It means like the spider web (cobweb) some task/function/work is happining so on this concept
something is running.
Network
“In information technology a network is a series of points or nodes interconnected by
communication path/channel.”
Note: A device, generally the computer that is directly attached to the network, is called a node
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Computer Network
A computer network is a collection of two or more than two where components interconnected
by communication channels that allow sharing of resources and information.
What is computer network:A network consist of two or more computers connected together on desk or it can consist of
many LAN connected together to form a wide area network (WAN) across continent.
OR
Network:-The shairing of resources between two or more people.
OR
A network with which you might be familiar is the school computer lab. Consider resources that can be
shared on a network. For example, the school computer lab may share a single printer. Think of
advantages of sharing resources. Why are most business computers part of a network?
What is internet:It is interconnected computer network by which Communication must be possible through global
interconnected computer network. Tim Berner Lee at MIT/LCS(Massatutes Institutes of
Technology/Laboratory of Computer science) gives the concept of internet.It is a very large network
of interconnected computers across the world.
What is Intranet:Intranet is the use of internet technologies within an organization (or company) to achieve better
results than the conventional means of data access and transfer. Information page of intranet
coded into HTML/DHTML, Dot net/Java etc.
TCP/IP protocol is responsible for intranet services.
Internet:-A lots of network all over worlds are connected to make the internet.
Intranet:- Lots of networks connected within an organization (locations could be
geographically distant) such as bank network, Maruti udyog limited etc.
Difference between Internet & Intranet: Intranet is network within the organization where as internet is a worldwide network.
Intranet has access to internet but not vice-versa
Types of computer Network: Point-To-Point Computer Network. (By Means Wires).
 Broadcast computer network. (By means of microwaves).
Classification Computer network
There are three different types of network for different purpose
1- LANWAN
23- MAN
LAN (Local Area Network)
A Local Area Network is a network that connects computers and devices in a limited geographical area
such as home, school, computer laboratory, office building, or closely positioned group of buildings.
Characteristics:
(i)
A diameter not more than a few kms.
(ii)
A total data rate of at least several Mbps.
(iii)Complete ownership by a single organization.
MAN (Metropolitan Area Network)
A Metropolitan area network is a large computer network that usually spans a city or a large campus.
Characteristics:
(i)
Covers entire city, but uses LAN technology.
(ii)
Have data rates below 1 Mbps.
(iii)
Owned by multiple organizations.

133

3
WAN (Wide Area Network)
A (WAN) is a computer network that covers a large geographic area such as a city, country, or spans
even intercontinental distances, using a communications channel that combines many types of media
such as telephone lines, cables, and air waves.
Characteristics:
(iv) More scalable than LAN and MAN.
(v)
Connects many sites spread across large geographic distances with many computers at each
site.
(vi) Provides sufficient capacity to permit the computers to communicate simultaneously.
Why Computer network: Communication medium/Channel
 Resource shairing
 Higher reliability
 Cost minimize
Network Topology:It is the layout of computer network.There are following types of
network topology.
 Star topology.
 Ring topology.
 Bus Topology.
 Tree Topology.
 Mesh Topology.

Fully Mesh Topology

Partially Mesh Topology
 Combined Topology

Star-Bus Topology.

Star-Ring Topology.
A Network Topology is the way computer systems or network equipment connected to each other.
Topologies may define both physical and logical aspect of the network. Both logical and physical
topologies could be same or different in a same network.

POINT-TO-POINT
Point-to-point networks contains exactly two hosts (computer or switches or routers or servers)
connected back to back using a single piece of cable. Often, the receiving end of one host is connected
to sending end of the other end and vice-versa.

[Image: Point-to-point Topology]
If the hosts are connected point-to-point logically, then may have multiple intermediate devices. But the
end hosts are unaware of underlying network and see each other as if they are connected directly.
BUS TOPOLOGY
In contrast to point-to-point, in bus topology all device share single communication line or cable. All
devices are connected to this shared line. Bus topology may have problem while more than one hosts
sending data at the same time. Therefore, the bus topology either uses CSMA/CD technology or
recognizes one host has Bus Master to solve the issue. It is one of the simple forms of networking
where a failure of a device does not affect the others. But failure of the shared communication line
make all other devices fail.
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[Image: Bus Topology]
Both ends of the shared channel have line terminator. The data is sent in only one direction and as soon
as it reaches the extreme end, the terminator removes the data from the line.
STAR TOPOLOGY
All hosts in star topology are connected to a central device, known as Hub device, using a point-topoint connection. That is, there exists a point to point connection between hosts and Hub. The hub
device can be Layer-1 device (Hub / repeater) or Layer-2 device (Switch / Bridge) or Layer-3 device
(Router / Gateway).

[Image: Star Topology]
As in bus topology, hub acts as single point of failure. If hub fails, connectivity of all hosts to all other
hosts fails. Every communication happens between hosts, goes through Hub only. Star topology is not
expensive as to connect one more host, only one cable is required and configuration is simple.
RING TOPOLOGY
In ring topology, each host machine connects to exactly two other machines, creating a circular network
structure. When one host tries to communicate or send message to a host which is not adjacent to it, the
data travels through all intermediate hosts. To connect one more host in the existing structure
administrator may need only one more extra cable.

[Image: Ring Topology]
Failure of any host results in failure of the whole ring. Thus every connection in the ring is point of
failure. There exists methods which employs one more backup ring.
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M ESH TOPOLOGY
In this type of topology, a host is connected to one or two or more than two hosts. This topology may
have hosts having point-to-point connection to every other hosts or may also have hosts which are
having point to point connection to few hosts only.

[Image: Full Mesh Topology]
Hosts in Mesh topology also work as relay for other hosts which do not have direct point-to-point links.
Mesh technology comes into two flavors:
TREE TOPOLOGY
Also known as Hierarchical Topology is the most common form of network topology in use
present day. This topology divides the network in to multiple levels/layers of network. The
highest most layer is known as Core layer, and is central point of the network, i.e. root of the
tree from which all nodes fork.

[Image: Tree Topology]
All neighboring hosts have point-to-point connection between them. Like bus topology, if the root goes
down, the entire network suffers. Though it is not the single point of failure. Every connection serves as
point of failure, failing of which divides the network into unreachable segment and so on.
DAISY CHAIN
This topology connects all its hosts in a linear fashion. Similar to Ring topology, all hosts in this
topology are connected to two hosts only, except the end hosts. That is if the end hosts in Daisy Chain
are connected then it represents Ring topology.

[Image: Daisy Chain Topology]
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Each link in Daisy chain topology represents single point of failure. Every link failure splits the
network into two segment. Every intermediate host works as relay for its immediate hosts.
HYBRID TOPOLOGY
A network structure whose design contains more than one topology is said to be Hybrid Topology.
Hybrid topology inherits merits and demerits of all the incorporating topologies.

[Image: Hybrid Topology]
The above picture represents an arbitrarily Hybrid topology. The combining topologies may contain
attributes of Star, Ring, Bus and Daisy-chain topologies. Most WANs are connected by means of dual
Ring topology and networks connected to them are mostly Star topology networks. Internet is the best
example of largest Hybrid topology.
Protocol:-Set of formalized access rule is called protocol.
 TCP/IP (Transmission Control Protocol/Internet protocol)
 Ftp (File Transfer Protocol).
 Http (Hypertext Transfer Protocol).
 SLIP (Serial Line Internet Protocol).
 PPP (Point to Point Protocol).
A protocols defines the following three aspects of communications
 Syntax:-The format of data being exchanged, character set used, type error
correction used, type of coding scheme being used.
 Semantics:-Type and order of messages used to ensures reliable and error free
information transfer.
 Timing:-Define data rate selection and correct timing for various events during
data transfer.
Who Govern Internet:ISOC (Internet Society).
IAB (Internet Architecture Board).
IETF (Internet Engineering Task Force).
How Connect Internet:1. Broad Band Connection.
2. VSAT (Very Small Aperture terminal).
3. Mobile Phone.
4. Wi-Fi System.
5. USB Modem.
Data Communication Modes/Data Flow:1. Simplex Communication Modes.
2. Half-Duplex communication Modes.
3. Full Duplex Communication Modes.
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Synchronous and Asynchronous communication Modes:Synchronous communication Modes:It performs communication between two nodes or among many nodes on same clock of pulse.
Example:Sender---------------------------------------------------------------------------Receiver
Clock Pulse
Clock Pulse
TS=t1
TR=t1
Message=M1 =10010101
Message=M1=10010101
Asynchronous communication Modes:It perform communication between two nodes or among many nodes on different clock of pulse
or Bits transmitted different clock of pulse
Example:Sender---------------------------------------------------------------------------Receiver
Clock Pulse
Clock Pulse
TS=t1
TR=t1+ t2…+ t8
Message=M1 =10010101
t1=1, t2=0, t3=0, t4=1, t5=0, t6=1, t7=0, t8=1,
Communication H/w:Basic data communication processs, the following H/W are required
 Sender & Receiver H/w
 Nodes and Work Station It is done using various communication devices and
s/w interconnected for information exchange (Such as Router, Bridge,
Gateway, Switch etc).
 Multiplexer:- It is a form data transfer in which communication channels are
used for several transmissions. There are following two types of multiplexers
 TDM (Time Division Multiplexing)
 FDM (Frequency Division Multiplexing)
 Communication Device: Bluetooth devices.
 Infrared devices.
 Modem (over phone line).
 Network card (using Ethernet)/LAN CARD.
 Smartphone.
 Wi-Fi devices (using a router).
Communication Channels.:Communication channels refer to the way this information flows within the
organization and with other organizations. In this web known as communication, a manager
becomes a link. Decisions and directions flow upwards or downwards or sideways depending
on the position of the manager in the communication web.
Physical Connections
It determines how many bits can be transmitted in a single instance of time.
If only 1 bit of information can be transmitted over the data transmission medium at a time then
it is considered a serial transmission.
If more than 1 bit of information’s are transmitted over the data transmission medium at a time
then it is considered a parallel communications.
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Types of physical connection/Trans mission Media/Channel:There are two categories of transmission media/Channel
 Guided Transmission Media:-It uses a cabling system that guided the data signals among a
specific path.There are many types of guided transmission media.
Open Wire:-It is used to describe the electrical wire strung along power poles.It is
suited for short distances of less than 40 ft.

Twisted Pair:-It is used in telephone line.It consist of wire used for the +ve data signal
and a wire used for -ve data signal. It minimizes electromagnetic interference between
pairs. Transmission speed upto 9600 bits per seconds are possible upto distance 100
meters.
Or
Twisted pair is the ordinary copper wire that connects home and many business
computers to the telephone company. To reduce crosstalk or electromagnetic
induction between pairs of wires, two insulated copper wires are twisted around
each other.

Coaxial cable:-A coxial cable has a stiff copper wire as the core surrounded by
insulating material.
There are two types of coaxial cable.



50 Ohm:-It is used for cable TV network.
75 Ohm:-It is used for broadband connection.
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Optical Fiber Cable (OFC):-It is the latest transmission media, superior than other transmission
media. Data are transmitted in the form of light. There are two types of light sources. It works on the
principal of total internal and reflection theory of light.


LED (Light Emitting Diode).

LASER(Light Amplification by Stimulated Emission Radiation)
There are many types of OFC:a:-8.3 micron core/125 micron cladding.
b:-62.5 micron core/125 micron cladding.
c:-50 micron core/125 micron cladding.
d:-100 micron core /140 micron cladding.
Unguided Transmission Media/Channel:- It uses wireless communication consists of a means for the
data signals to travel but nothing to guide them along a specific path.It is commonly used for WAN
network.
Above 100 MHz the waves travel in straight lines and can therefore be narrowely focused.
Concentrating all the energy into small beam using parabolic antenna gives a much higher signals to
noise ratio.There are two types of microwaves signals.Radio, Microwave and satellite channels use
electromagnetic propagation in space. These channels line in their capability to cover large
geographical areas and inexpensive than wired installation.
o
Terrestrial Microwaves.(Frequency Range 4 to 6 Ghz & 21 to 23 Ghz).
o
Satellite Microwaves. It is suited for 36000 KM area.Frequency range 4GHz to 6 GHz.
Connection Devices for network:
Repeaters:-It is also called regenerator, It boosted up weakened signal.
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Hubs:-It is also called multiport repeaters or concentrators. It is similar to repeater, except that
it broadcasts data received by any ports to all other ports on the hubs.



Bridges:-It has all features of repeaters. It is used to connect dissimilar networks like Ethernet
system.



Routers:-It is used for connecting dissimilar communication protocols for wide area network.



Gateways:-It is much more complex and powerful than routers. There are very expensive.
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Communication architecture Network /Network Model:The communication architecture specifies independent layers that contain modules for
performing defined functions. The architecture defines the functions of the module & relationship
between them. There are two Models.
1) OSI Model (Open System Interconnection)
2) TCP/IP Model (Transmission Control Protocol/Internet Protocol)
 OSI Model(Open System Interconnection)
o It consist of hierarchy of 7 layers


Physical Layer→ Bits Orientation Layer



Data Link Layer→ Frames (Collection of bits) Orientation Layer.



Network Layer→ Addressing Layer (Put address on each frame).



Transport Layer→ It transmits frames from source to destination.



Session Layer→ Accumulate all incoming frames in specific session.



Presentation Layer →Resembled all frames into original message.



Application Layer→ It is a layer where user access service of network.

Application Layer:
This layer is responsible for providing interface to the application user. This layer
encompasses protocols which directly interact with the user.
Presentation Layer:
This layer defines how data in the native format of remote host should be presented in
the native format of host.
Session Layer:
This layer maintains sessions between remote hosts. For example, once user/password
authentication is done, the remote host maintains this session for a while and does not
ask for authentication again in that time span.
Transport Layer:
This layer is responsible for end-to-end delivery between hosts.
Network Layer:
This layer is responsible for address assignment and uniquely addressing hosts in a
network.
Data Link Layer:
This layer is responsible for reading and writing data from and onto the line. Link errors are
detected at this layer.
Physical Layer:
This layer defines the hardware, cabling and wiring, power output, pulse rate etc.
 TCP/IP Model(Transmission Control/Internet Protocol)
o It consists of Four layers used in wireless media.
 Physical Layer→ Bits Orientation Layers.
 DLL→ Packets (Discrete messages) orientation Layers.
 Network Layers/Internet Layer→ Addressing on each packet.
 Transport Layers→ Transmission of packets from source to destination.
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Application Layers→ It is a layer where user access service of network.

Application Layer:
This layer defines the protocol which enables user to internet with the network such as FTP,
HTTP etc.
Transport Layer:
This layer defines how data should flow between hosts. Major protocol at this layer is
Transmission Control Protocol. This layer ensures data delivered between hosts is in-order and
is responsible for end to end delivery.
Internet Layer:
IP works on this layer. This layer facilitates host addressing and recognition. This layer defines
routing.
Link Layer:
This layer provides mechanism of sending and receiving actual data. But unlike its OSI Model’s
counterpart, this layer is independent of underlying network architecture and hardware.
Note:Network Switching Technique:There are three types of switching technique.
 Circuit switching technique.
 Message switching technique.
 Packet switching technique.
Circuit switching technique:A physical permanent & dedicated connection established between sender to receiver.
Example:-PSTN, Cable TV Connection
Message switching technique:A physical connection established between sender and receiver during communication
session only.
Example:-E-mail through dialup connection, Telegram Service
Packet switching technique:Data transmitted in the form of packet. It is also called small message. There are two
types of packet switching technique.
 Virtual circuit technique:-A logical and dedicated path established between sender and receiver
during communication session.
Sender---------------------------------------------------------------Receiver.
 Datagram Circuit technique:-Many logical paths established from sender to receiver during
transmission of packets.
Sender
Receiver.
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LAN
LAN




LAN











H/W and S/w:H/W :Server
Terminal
Channel/Media
LAN card/Network Interface Unit(NIU)
S/W :LINUX and Unix OS.
Windows NT.
Windows XP.
Windows Vista.
Windows7.
Windows8.
Windows10.
Server S/W.
Terminal/Work station S/w.
Antivirus.

WAN H/W : Bridges:- It is used to connect two LANs which are associated identical LAN protocols. It
operate at DLL(Data Link Layer) of OSI model.
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 Routers:- It is used to connect networks that may not be similar.It operate network layer of OSI
model.

 Gateways:- It is used to connect two dissimilar LANs.It operate application layer of OSI model.
It converts data packets from one protocol format to another protocol format.
Example of WAN: PSTN(Public Switched Telephone Network).
 ISDN(Integrated Service Digital Network).
 PSDN(Public Switched Data Network).
Application of Network: E-Mail (Electronic Mail). Inventor of Email is VA Shiva Ayyadurai
 EDI(Electronic Data Interchange).
EDI:It is another technique of transferring large amount of textual information from
one organization to another organization.

Some problem based on traditional system: Increased time.
 Low accuracy.
 High labour charges.
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 Increased Uncertainty.
EDI has become a major means of business communications among large companies in U.S.
EDI can do
 EFT (Electronic fund transfer).
 Communication between unrelated companies(Cos).
 It is used for performing paperless task.
Benefit of EDI: It handles large volume of repetitive standard actions.
 It operates on very tight margin.
 It operates under time constraints (Validation).
 It improve activity of companies performance.
Networking Scenario/Computer Network Scenario:1:-Services of Internet:A:- Global E-mail:It is used for transferring messages from one terminal to another terminal. by using E-mail ID.
B:-USENET-Views and news
It is used by BBS of internet.
C:-Telnet(Telephone Network)-Remote Login:It allows an internet user to access a remote host.
D:-ftp(File Transfer Protocol):It permits an internet user to transfer a file from one computer to another computer.
E:-Navigators
Accessing of information by using URL from web./cyberspace.
2:-BITNET (Because Its Time Network):It is a network of New York and University of Yale established by BITNET.
Function:A:-Exachange of data file
B:-Electronic Admission of student
C:-Remote job search
3:-Compuserve
It is commercial network based in US.
Services /Function
A:-Message transfer
B:-Bulletin board services
C:-News report, Sports and weather
D:-Information on computer hardware and software
4:-ISDN
ISDN: - (Integrated Services Digital Networks)
It is special type of communication channel through which ability to deliver digital signal of
data, voice, Video and Fax.It supports 64 kbps data transfer rate.
Types of ISDN
 B-channel (Bearer Channels) → Data Transfer rates are 16Kbps or 64 Kbps
 D-Channel (Data Channel) → Data Transfer rates are 128 Kbps
ISDN services:There are two types of ISDN services
 BRI (Basic rate Interface)
 PRI (Primary rate Interface)
It is the fastest transmission network through which we can transmit data in digital
format. It was launched in Singapore in 1990.
Feature of ISDN: Transmission and processing of digital data
 It process of voice, video, animation etc.
 Teleconferencing
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 Telefax, Videofax etc.
NICNET:- (National Information Center Network)
It is a satellite based nationwide network.It contain information about each villages, district and
city of India. The basic objectives of NICNET are:
 It help government in better planning administratio n.
 To help government maintain communication in times of national emergencies and
natural disasters
Security:Unauthorized access, destruction/revelation of data can violate individual privacy.

Lecture - 19
Security threats and Goals:Following major security threats perceived by users and provides of computer based
system includes.
 Unauthorized disclosure of information.
 Unauthorized alteration or destruction of information.
 Unauthorized use of service.
 Denial of service to legitimate users.
Security Policies:Security policies specify what is desired in terms of protection and security.
Security Mechanism:It specifies how to affect the security policies and enforce them in a given system.
Penetration Attempts: Hit & Trial error Attempts.
 Logged on Terminal.
 Password
 Trapdoors:-These are the secret points of entry without access authorization
 Trojan horse:-It is a program to steal user password.More sophisticated version of
Trojan horse programs can make themselves harder to detect by fully emulating
the utility that they are impostering.
 Computer Worms:-It is a program to hack information via network and produce
itself propagation.
 Computer viruses (Vital Information Resources Under Seize ).
Classification of security:Physical security:A:Physically bolt down the PC to a table so that it can be casually Lifted and taken
away.
B:Kept records by using pen drive,CD ROM/DVD/Blu ray disk.
C:Use Keyboard and PC locking system.
D:Use lockable rooms.
E:Protect against environmental conditions
Software security
A:Use original s/w for OS.
B:Use correct procedures for shutting down.
Network Security
Password Security
Services of Internet:
E-Mail

Telnet

ftp
Concept of URL (Uniform Resource Locator):It is used for accessing internet/intranet services.
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OR
The most widely used service on the Internet is the World Wide Web. The World Wide
Web (WWW or Web) consists of a worldwide collection of electronic documents called Web pages.
A browser is a software program used to access and view Web pages. Each Web page has a unique
address, called a URL(Uniform Resource Locator), that tells a browser where to locate the Web page.
A URL consists of a protocol, domain name, and sometimes the path to a specific Web page or location
on a Web page. Most URLs begin with http://, which stands for hypertext transfer protocol, the
communications standard that enables pages to transfer on the Web.
Example:http://www.uprtou.ac.in
http://www.bhu.ac.in
http://www.nic.in
http://www.google.com (Larry Page and Sergey Brin invented Google)
http://www.rediffmail.com
http://www.yahoomail.com
http://www.altavista.com
http://www.timesofindia.com
http://www.bseindia.com
http://www.icsm.org.in
etc.
www : -World Wide Web. → It is huge virtual storage area where all URL are stored. Web
page written into HTML, DHTML, PHP, JAVA Script, VB Script Etc.
//
It indicate URL is valid or not valid.
http:- It is a protocol which is used for accessing valid host from www.
host:- It is a part of URL about which information uploaded into cyberspace.
Browser:It is software by which we access internet services.
Example: Internet explorer.
Netscape navigator.
NCSA mosaic.
Chimera.
Net cruiser.
Mozila.
Opera Mini,googlechrome etc.
Services of Internet:Surfing(Clicking and accessing services of internet).
Searching.
E-mail.
E-commerce.(Business through internet).(B2B,B2C,C2C)
Etc.
Search Engine:It is URL, which is used for searching information through internet or intranet.
Surfing:Click and access information through cyberspace (Internet or intranet) is called surfing.
ftp:It is a protocol which is used for transferring a large amount of textual information, graphical
informations and any types of audio, video informations transmitted smoothly and efficiently.Ftp works
performed in CUI environment.
ftp> Ftp prompt ready for accept commands.
Telnet:-It is remote service for accessing web information from web server using intranet network.It
establish packet based connection Following s/w are used for telnet.
 NetTerm
 Hyperterminal
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Secure CRT
EWAN
Kermit
Anzio Lite

Concept of Domain Name System (DNS):DNS categorized into two types
1. Geographical DNS.
2. Non-Geographical DNS.
Example of Geographical DNS:.in→India.
.au→Australia.
.cn→China.
.de→Germany.
.uk→United Kingdom.
.us→United State.
Example of Non-Geographical DNS :.com→Commercial purpose.
.org →Non-profit organizations.
.edu→Educational purpose.
.ac→ academic purpose.
Example:- www.bhu.ac.in
Concept of IP Address:IP address consists of four decimal digits. Which values exist between 0 to 255.
IP address must be unique in computer network.
d1.d2.d3.d4
d1→0 to 255 First Octet.
d2→0 to 255 Second Octet.
d3→0 to 255 Third Octet.
d4→0 to 255 Fourth Octet.
Total bit Values of IP=8+8+8+8=32 Bits
Role OF TCP/IP Protocol:TCP:-This protocol splits messages into discrete form and resembled at destination/Target.
Encoding →M

→

TCP

→m1m2m3m4m5m6m7m8…(Packets).

(Destination) →Decoding→ m1+m2+m3+m4+m5+m6+m7+m8…(Packets).=M
IP
→
It puts address of destination at each packet. There are two version of IP
1. ipv4 (It takes 32 bits numbers currently used)
2. ipv6(It takes 128 bits numbers came in 1995)
Working of TCP/IP System:-
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Classification of IP Address:Class A
for 16581375 host address. If the first bit of address is 0,It
is address of A. Next 7 bits identify the network and 24 bits identify
the hosts.
Class B
for 256 to 65536 host address.If the first 2 bits of the addresses
are 10,it is class B.The next 14 bits identify the address and last 16 bits
identify the hosts.
Class C
for less than 254 hosts address.If the first three bits of the
address are 110, It is a class C network. The first 3 bits identify class.
Next 21 bits are network address and last 8 bits identify host.
Class D
For Multicast address.If first four bits of the address are 1110,it is
a multicast address. Multicast identifies a group of computers that share
a common application.
CLASS A
Octet 0
Decimal Values Ranges
0 To 127
CLASS B
Octet 10
Decimal Values Ranges
128 To 191
CLASS C
Octet 110
Decimal Values Ranges
192 To 223
CLASS D
Octet 1110 Decimal Values Ranges
224 To 239
CLASS E
Octet 1111 Decimal Values Ranges
240 To 255
IP address Structure:Class A
Range 0-127
0

7bits

Class B
10

14

bits

Class C
110

21bits

Class D
1110

28bits

Local Address(24 Bits)

Range 128-191
Local Address(16 Bits)

Range 192-223
Local Address(8 Bits)

Range 224-239
multicast Address

Class E(For future purposes)
1111

28bits

Range 240-255

multicast Address

Examples of IP address are
Example 1:- 22.231.113.64 Class A
Example 2:-194.66.82.11.
Class C
Application of Internet:1. Railway reservation.
2. Airlines reservation.
3. On Line Business.
4. On line Share trading.
5. On Line Education.
6. Scientific research and development.
7. On Line banking System.
8. ATM (Automatic Teller machine).
9. Searching of jobs and desired information.
10. Speed Post.
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11.
12.
13.
14.
Etc.

On Line Library System.
Video conferencing.
On Line Chatting.
Teleconferencing.

Full form:GPRS
MMS
Http
FAQ
WILL
OFC
CSMA
ISOC
IAB
IETF
PSTN
VSAT
ISDN
LAN
MAN
WAN
WWW
TCP/IP
SLIP
PPP
DNS
SIM
TELNET
PSU
VGA
ISP
ANSI
WIFI
GSM
CCTV
TFT
CMOS
PCO
ATM
ISD
AVI
RADAR
STD
PNG
WAP
IRC
POST
BMP
Gif
Pdf
POS

→
→
→
→
→
→
→
→
→
→
→
→
→
→
→
→
→
→
→
→
→
→
→
→
→
→
→
→
→
→
→
→
→
→
→
→
→
→
→
→
→
→
→
→
→
→

Global Packet Radio Services.
Multimedia Services.
Hypertext Transfer protocol.
Frequently asked question.
Wireless In Local Loop.
Optical Fiber Cabel.
Carrier Sense Multple access
(Internet Society).
(Internet Architecture Board).
(Internet Engineering Task Force).
Public Switched Telephone Network.
Very Small Aperture Terminal.
Integrated Services digital Network.
Local Area Network.
Metropolitan Area Network.
Wide Area Network.
World wide web.
Transmission control Protocol/Internet protocol.
Serial Line Internet Protocol.
Point to Point Protocol.
Domain Name System.
Subscriber Identity Module
Telephone Network
Power Supply Unit
Video Graphics Array
Internet Service Provider
American National Standard Institute
Wireless Fidelity
Global System for Mobile Communications
Closed Circuit Television
Thin Film Transistor
Complementary Metal Oxide Semiconductor
Public Call Office
Automatic Teller Machine
International Subscriber Dialing
Audio Video Interleave
Radio Detection And Ranging
Subscriber Trunk Dialing
Portable Network Graphics
Wireless Application Protocol
Internet Relay Chat
Power On Self Test
Bit Map Picture
Graphics Interchange Format
Portable Data File
Point of Sales Terminal
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JPEG
DBMS
RDBMS
IEEE
PCI
ISA
SIMM
DIMM
SATA
PATA/ATA

→
→
→
→
→
→
→
→
→
→
→
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Address Resolution Protocol
Joint Picture Expert Group
Database Management System
Relational Database Management System
Institute of Electrical and Electronic Engineering
Peripheral Component Interconnect
Industry Standard Architecture
Single In-line Memory Module
Dual in-line memory module
Serial Advanced Technology Attachment
Parallel Advanced Technology Attachment/
Advanced Technology Attachment

Advantages of Computer Network
Communication
Data sharing
Internet Service.
Video conferencing.
Instant and multiple accesses.
Resource Sharing.
Speed.
Centralized Software Management.
Disadvantages of Computer Networks
Security Issues:
Rapid Spread of Computer Viruses:
Expensive Set Up;
Dependency on the Main File Server:
Network faults can cause loss of data.
Network fault could lead to loss of resources
User work dependent upon network
History of Internet
In 1969, the Department of Defense (DOD) of United States of America started a network called
ARPANET (Advanced Research Projects Administration Network). It was started with one
computer in California and three in Utah
Later, the military allowed universities to join the network for sharing the hardware and software
resources, a number of other networks were developed during the late 1970 and early1980, with
BITNET and CSNET among them. BITNET which is acronym for Because It’s Time Network began at
the City University of New York. It was provide electronic mail and file transfers. CSNET, which is an
acronym for Computer Science Network, Its initial purpose was to provide electronic mail. for a variety
of reasons, neither BITNET nor CSNET became a dominant national network.
A new national network, NSFnet, was created in 1986. National Science Foundation (NSF) initially
connected the NSF-funded supercomputer centers at five universities. By 1990, NSFnet had replaced
ARPAnet for most nonmilitary uses and wide variety of organizations had established nodes on this
network. By 1992, NSFnet connected more than 1 million computers around the world. In 1995 a small
part of NSFnet returned to being a research network. Then it grew bigger and gave birth to the presentday very popular Internet.
Internet
Internet is a network of networks.
or
It is an interconnection between several computers of different types belonging to various networks all
over the world..
How does internet work?
When information is passed from one computer system to another it is broken up into pieces called
packets using the TCP and IP protocol. a message consisting of not more than 1500 bytes or characters
is put into a packet. Each packet has the address of sender and the destination. These addresses are
called IP addresses.
The packets are passed from one network to another until they reach their destination. At the destination
the TCP software reassembles the packets into a complete message, if packets are lost or damaged, a
request is sent to resend them. it is not necessary for all packets in a single message to take the same
route through the internet or for the same message o take the same route each time it is sent.
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Lecture – 22
Libre Office
What is Writer?
Writer is the word processor component of LibreOffice. In addition to the usual features of a word
processor (spelling check, thesaurus, hyphenation, autocorrect, find and replace, automatic
generation of tables of contents and indexes, mail merge and others), Writer provides these
important features:
• Templates and styles (see Chapter 3)
• Page layout methods, including frames, columns, and tables
• Automated tables of contents and indexes
• Embedding or linking of graphics, spreadsheets, and other objects
• Built-in drawing tools
• Master documents—to group a collection of documents into a single document
• Change tracking during revisions
• Database integration, including a bibliography database
• Mail merge
• Export to PDF, including bookmarks (see Chapter 10)
• Document digital signature
• Form design and filling
• And many more
These features are covered in detail in the Writer Guide.

The Writer interface
The main Writer workspace is shown in Figure 62. The menus and toolbars are described in
Chapter 1, Introducing LibreOffice. Some other features of the Writer interface are covered in this
chapter.
Figure 62: The main Writer workspace

169

Status Bar
The Writer Status Bar provides information about the document and convenient ways to change
some document features quickly.

Figure 63: Left end of Status Bar

Figure 64: Right end of Status Bar
Page number
Shows the current page number, the sequence number of the current page (if different), and
the total number of pages in the document. For example, if you restarted page numbering at
1 on the third page, its page number is 1 and its sequence number is 3.
If any bookmarks have been defined in the document, a right-click on this field pops up a list
of bookmarks; click on the required one.
To jump to a specific page in the document, double-click on this field. The Navigator opens.
Click in the Page Number field and type the sequence number of the required page and
press Enter.
Word and character count
The word and character count of the document is shown in the Status Bar, and is kept up to
date as you edit. Any text selected in the document will be counted and this count will replace
the displayed count.

To display extended statistics such as character counts excluding spaces, double-click the
word count in the Status Bar, or choose Tools > Word Count.
Page style
Shows the style of the current page. To change the page style, right-click on this field. A list of
page styles pops up; choose a different style by clicking on it.
To edit the current page style, double-click on this field. The Page Style dialog opens.
Language
Shows the language at the cursor position, or for the selected text, that is used for checking
spelling and for hyphenation and thesaurus.
Click to open a menu where you can choose another language for the selected text or for the
paragraph where the cursor is located. You can also choose None (Do not check spelling)
to exclude the text from a spelling check or choose More to open the Character dialog. Any
directly formatted language settings can be reset to the default language from this menu.
Insert mode
This area is blank when in Insert mode. Double-click to change to Overwrite mode; singleclick to return to Insert mode. In Insert mode, any text after the cursor position moves forward
to make room for the text you type; in Overwrite mode, text after the cursor position is
replaced by the text you type. This feature is disabled when in Edit > Changes > Record
mode.
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Selection mode
Click to choose different selection modes. The icon does not change, but when you hover the
mouse pointer over this field, a tooltip indicates which mode is active.
When you click in the field, a context menu displays the available options.
Mode

Effect

Standard selection

Click in the text where you want to position the cursor; click in a
cell to make it the active cell. Any other selection is deselected.
Clicking in the text extends or crops the current selection.
A new selection is added to an existing selection. The result is a
multiple selection.
A block of text can be selected.

Extending selection (F8)
Adding selection (Shift+F8)
Block selection (Ctrl+Shift+F8)

On Windows systems, you can hold down the Alt key while dragging to select a block of text.
You do not need to enter the block selection mode.
Document changes status
The icon that is displayed here changes from this one ( ) if the document has no unsaved
changes, to this one (
) if it has been edited and the changes have not been saved. Click
on the unsaved changes icon to save the document.
Digital signature
If the document has been digitally signed, this icon ( ) is displayed here; otherwise, it is
blank. To view the certificate, double-click the icon.
Section or object information
When the cursor is on a section, heading, or list item, or when an object (such as a picture or
table) is selected, information about that item appears in this field. Double-clicking in this
area opens a relevant dialog. For details, consult the Help or the Writer Guide.
View layout
Click an icon to change between single page, side-by-side, and book layout views. The effect
varies with the combination of window width and zoom factor in use. You can edit the
document in any view. See Figure 65.
Zoom
To change the view magnification, drag the Zoom slider, or click on the + and – signs, or
right-click on the zoom level percent to pop up a list of magnification values from which to
choose. Zoom interacts with the selected view layout to determine how many pages are
visible in the document window.

View layouts: single, side-by-side, book.
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Sidebar
The Writer sidebar (View > Sidebar), shown in Figure 66, is located on the right side of the edit
view. It is a mixture of toolbar and dialog and consists of five decks: Properties, Styles and
Formatting, Gallery, Navigator, and Manage Changes. Each deck has a corresponding icon on the
Tab panel to the right of the sidebar, allowing you to switch between them.

Sidebar settings
Title bar

Tabs

Panel title
Panel contents

Deck

More Options button
Figure 66: Sidebar Properties deck and text content panels
Each deck consists of a title bar and one or more content panels. Toolbars and sidebar panels
share many functions. For example, the buttons for making text bold or italic exist in both the
Formatting toolbar and the Character panel of the Properties deck.
Some panels contain a More Options button (
) which when clicked opens a dialog to give
greater choice of editing controls. The dialog that opens locks the document for editing until the
dialog is closed.
The decks are described below.
• Properties: Contains tools for direct formatting within the document. By default, the tools
are separated into the following four panels for text editing:
– Styles: Display or apply a paragraph style at the cursor position. Create or update a
style.
– Character: Modify text by the font type, size, color, weight, style and spacing.
– Paragraph: Style the paragraph by alignment, lists or bullets, background color, indent,
and spacing.
– Page: Format the page by orientation, margin, size, and number of columns.
If a graphic is selected, then the following panels open:
– Area: Modify the graphic background area fill mode and transparency.
– Graphic: Modify the graphic’s brightness, contrast, color mode and transparency.
– Position: Modifications to width and height.
– Wrap: Permits wrap modifications where these are available.
If a drawing object is selected, then the following panels are available:
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– Area: Fill and transparency edits are available.
– Line: Permits edits to the line style, width, color, arrows, corners and cap styles.
– Position and Size: Enables edits to width, height, rotation and flip attributes.
If a frame is selected, then the wrap panel opens but may be grayed-out if frame wrap is
not available.
Caution
Be aware that by changing the options on the Page panel, you will change the page
style in use, modifying not only the current page but all pages using the same page
style.
•

•

•

•

Styles and Formatting: Manage the styles used in the document, apply existing styles,
create new ones or modify them. This deck is also a floating toolbar that can be opened
from Format > Styles and Formatting on the Menu bar.
Gallery: Add images and diagrams included in the Gallery themes. The Gallery displays as
two sections; the first lists the themes by name (Arrows, Background, Diagrams, etc.) and
the second displays the images in the selected category. Select the New Theme button to
create new categories. To insert an image into a file, or add a new image to the new
category, just drag and drop the selected image using the file manager. This deck is also a
docked toolbar that can be opened from Tools > Gallery or the Gallery button on the
Standard Toolbar.
Navigator: Browse the document and reorganize its content by selecting different content
categories, such as headings, tables, frames, graphics, etc. This deck is similar to the
floating toolbar that can be opened from View > Navigator on the Menu bar or the
Navigator button on the Standard Toolbar. However, the Sidebar Navigator does not
contain a List Box On/Off button.
Manage Changes: Lists all changes done in the document since the Track Changes mode
was activated. This deck is an alternate view of the Manage Changes dialog that can be
opened from Edit > Track Changes > Manage Changes on the Menu bar. This tab is
available only when Enable experimental features has been selected in Tools > Options
> LibreOffice > Advanced.

Changing document views
Writer has several ways to view a document: Print Layout, Web Layout, and Full Screen. To access
these and other choices, go to the View menu and click on the required view. (When in Full Screen
view, press the Esc key to return to either Print or Web Layout view.)
Print Layout is the default view in Writer. In this view, you can use the Zoom slider and the View
Layout icons on the Status Bar to change the magnification.
You can also choose View > Zoom > Zoom from the menu bar to display the Zoom & View Layout
dialog, where you can set the same options as on the Status Bar. In Web Layout view, most of the
choices are not available.
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Figure 67: Choosing Zoom and View Layout
options.

Moving quickly through a document
In addition to the navigation features of the Status Bar (described above), you can use the
Navigator window and the Navigation toolbar, either from the Standard toolbar or from the Sidebar,
as described in Chapter 1, Introducing LibreOffice.
The Navigation toolbar (Figure 68) shows buttons for all the object types shown in the Navigator,
plus some extras (for example, the Find command).

Figure 68: Navigation toolbar
Click a button to select that object type. Now all the Previous and Next button presses (in the
Navigator itself, in the Navigation Toolbar, and on the scroll bar) will jump to the next object of the
selected type. This is particularly helpful for finding items like index entries, which can be difficult to
see in the text. The names of the buttons (shown in the tooltips) change to match the selected
category; for example, Next Graphic, Next Bookmark, or Continue search forward.
For more uses of the Navigator in Writer, see the Writer Guide.

Working with documents
Chapter 1, Introducing LibreOffice, includes instructions on starting new documents, opening
existing documents, saving documents, and password-protecting documents. Chapter 3, Using
Styles and Templates, covers how to create a document from a template.
By default, LibreOffice loads and saves files in the OpenDocument file format (ODF), a
standardized file format (ISO-IEC 26300) used by many software applications.

Tip
Wherever choice of the document file format is possible, choose the default ODF
format when working with LibreOffice.

Saving as a Microsoft Word file
If you need to exchange documents with users of Microsoft Word who are unwilling or unable to
receive ODT files, you can open, edit, and save documents in Microsoft Word formats.
You can also create and edit ODT files and then save them as DOC or DOCX files. To do this:
1) Important—First save your document in the file format used by LibreOffice Writer (ODT). If
you do not, any changes you made since the last time you saved will appear only in the
Microsoft Word version of the document.
2) Then choose File > Save As. On the Save As dialog (Figure 69), in the File type (or Save
as type) drop-down menu, select the type of Word format you need. Files cannot be saved
to the Word version 6.0/95 file format. Click Save.
From this point on, all changes you make to the document will occur only in the new document.
You have changed the name and file type of your document. If you want to go back to working with
the ODT version of your document, you must open it again.

Tip
Saving in ODF format gives you the option to redo the document if the recipient of your
document experiences trouble with the Microsoft format.

Tip
To have Writer save documents by default in the Microsoft Word file format, go to Tools
> Options > Load/Save > General. In the section named Default file format and ODF
settings, under Document type, select Text document, then under Always save as,
select your preferred file format. See Figure 70.
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Saving a file in Microsoft Word format

Figure 70: Tools > Options > Load/Save > General page

Working with text
Working with text (selecting, copying, pasting, moving) in Writer is similar to working with text in
any other program. LibreOffice also has some convenient ways to select items that are not next to
each other, select a vertical block of text, and paste unformatted text.

Selecting items that are not consecutive
To select nonconsecutive items (as shown in Figure 71) using the mouse:
1) Select the first piece of text.
2) Hold down the Ctrl key and use the mouse to select the next piece of text.
3) Repeat as often as needed.
Now you can work with the selected text (copy it, delete it, change the style, or whatever).
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Note
Macintosh users: substitute the Command key when instructions in this chapter say to
use the Ctrl key.

Figure 71: Selecting items that are not next to each other
To select nonconsecutive items using the keyboard:
1) Select the first piece of text. (For more information about keyboard selection of text, see the
topic “Navigating and selecting with the keyboard” in the Help.)
2) Press Shift+F8. This puts Writer in “Adding selection” mode.
3) Use the arrow keys to move to the start of the next piece of text to be selected. Hold down
the Shift key and select the next piece of text.
4) Repeat as often as required.
Now you can work with the selected text.
Press Esc to exit from this mode.

Selecting a vertical block of text
You can select a vertical block or “column” of text that is separated by spaces or tabs (as you might
see in text pasted from e-mails, program listings, or other sources), using LibreOffice’s block
selection mode. To change to block selection mode, use Edit > Selection Mode > Block Area, or
press Ctrl+F8, or click on the Selection icon in the Status Bar and select Block selection from the
list.

Now highlight the selection, using mouse or keyboard, as shown below.

Figure 72: Selecting a vertical block of text
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Cutting, copying, and pasting text
Cutting and copying text in Writer is similar to cutting and copying text in other applications. You
can use the mouse or the keyboard for these operations. You can copy or move text within a
document, or between documents, by dragging or by using menu selections, toolbar buttons, or
keyboard shortcuts. You can also copy text from other sources such as Web pages and paste it
into a Writer document.
To move (drag and drop) selected text using the mouse, drag it to the new location and release it.
To copy selected text, hold down the Ctrl key while dragging. The text retains the formatting it had
before dragging.
To move (cut and paste) selected text, use Ctrl+X to cut the text, insert the cursor at the paste-in
point and use Ctrl+V to paste. Alternatively, use the buttons on the Standard toolbar.
When you paste text, the result depends on the source of the text and how you paste it. If you click
on the Paste button, any formatting the text has (such as bold or italics) is retained. Text pasted
from Web sites and other sources may also be placed into frames or tables. If you do not like the
results, click the Undo button or press Ctrl+Z.
To make the pasted text inherit the paragraph style at the insertion point:
• Choose Edit > Paste Special, or
• Click the arrow button of the combination Paste button, or
• Click the Paste button without releasing the left mouse button.
Then select Unformatted text from the resulting menu.
The range of choices on the Paste Special menu varies depending on the origin and formatting of
the text (or other object) to be pasted. See Figure 73 for an example with text on the clipboard.

Figure 73: Paste Special menu

Finding and replacing text and formatting
Writer has two ways to find text within a document: the Find toolbar for fast searching and the Find
& Replace dialog. In the dialog, you can:
• Find and replace words and phrases
• Use wildcards and regular expressions to fine-tune a search
• Find and replace specific attributes or formatting
• Find and replace paragraph styles
Using the Find toolbar
If the Find toolbar is not visible, you can display it by choosing View > Toolbars > Find from the
Menu bar or by pressing Ctrl+F. The Find toolbar is shown docked at the bottom of the LibreOffice
window (just above the Status Bar) in Figure 74, but you can float it or dock it in another location.
For more information on floating and docking toolbars, see Chapter 1, Introducing LibreOffice.

Figure 74: Docked position of Find toolbar
To use the Find toolbar, click in the box and type your search text, then press Enter to find the next
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occurrence of that term from the current cursor position. Click the Find Next or Find Previous
buttons as needed.
Click the Find All button to select all instances of the search term within the document. Select
Match Case to find only the instances that exactly match the search term. Select the button to the
right of Match Case to open the Find & Replace dialog.
The Find toolbar can be closed by clicking the red X button on the left, or by pressing Esc on the
keyboard when the text cursor is in the search box.
Using the Find & Replace dialog
To display the Find & Replace dialog, use the keyboard shortcut Ctrl+H or choose Edit > Find &
Replace from the Menu bar. If the Find toolbar is open, click the Find and Replace button (
) on
the toolbar. Once opened, optionally click the Other Options symbol to expand the dialog. Click
the button again to reduce the dialog options.
To use the Find & Replace dialog:
1) Type the text you want to find in the Search for box.
2) To replace the text with different text, type the new text in the Replace with box.
3) You can select various options such as matching the case, matching whole words only, or
doing a search for similar words.
4) When you have set up your search, click Find. To replace the found text, click Replace.
For more information on using Find & Replace, see the Writer Guide.

Tip
If you click Find All, LibreOffice selects all instances of the search text in the
document. Similarly, if you click Replace All, LibreOffice replaces all matches.

Caution
Use Replace All with caution; otherwise, you may end up with some hilarious (and
highly embarrassing) mistakes. A mistake with Replace All might require a manual,
word-by-word, search to fix.

Figure 75: Expanded Find & Replace dialog

Inserting special characters
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A special character is one not found on a standard English keyboard. For example, © ¾ æ ç ñ ö ø
¢ are all special characters. To insert a special character:
1) Place the cursor where you want the character to appear.
2) Choose Insert > Special Character or click on the Special Character icon in the main
toolbar to open the Special Characters dialog.
3) Select the characters (from any font or mixture of fonts) you wish to insert, in order, then
click OK. The characters selected for insertion are shown in the lower left of the dialog. As
you select a character, it is shown on the right, along with its numerical code.
Note
Different fonts include different special characters. If you do not find a particular special
character, try changing the Font selection.

Figure 76: The Special Characters dialog, where you can insert special characters

Inserting dashes and non-breaking spaces and hyphens
To prevent two words from being separated at the end of a line, press Ctrl+Shift when you type the
space between the two words. This inserts a non-breaking space.
In cases where you do not want the hyphen to appear at the end of a line, for example in a number
such as 123-4567, you can press Shift+Ctrl+minus sign to insert a non-breaking hyphen.
To enter en and em dashes, you can use the Replace dashes option on the Options tab under
Tools > AutoCorrect Options. This option replaces two hyphens, under certain conditions, with
the corresponding dash.
– is an en-dash; that is, a dash the width of the letter “n” in the font you are using. Type at least one
character, a space, one or two hyphens, another space, and at least one more letter. The one
or two hyphens will be replaced by an en-dash.
— is an em-dash; that is, a dash the width of the letter “m” in the font you are using. Type at least
one character, two hyphens, and at least one more character. The two hyphens will be
replaced by an em-dash.
See the Help for more details. For other methods of inserting dashes, see Chapter 3, Working with
Text in the Writer Guide.

Setting tab stops and indents
The horizontal ruler shows the tab stops. Any tab stops that you have defined will overwrite the
default tab stops. Tab settings affect indentation of full paragraphs (using the Increase Indent and
Decrease Indent buttons on the Formatting toolbar) as well as indentation of parts of a paragraph
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(by pressing the Tab key on the keyboard).
Using the default tab spacing can cause formatting problems if you share documents with other
people. If you use the default tab spacing and then send the document to someone else who has
chosen a different default tab spacing, tabbed material will change to use the other person’s
settings. Instead of using the defaults, define your own tab settings, as described in this section.
To define indents and tab settings for one or more selected paragraphs, double-click on a part of
the ruler that is not between the left and right indent icons to open the Indents & Spacing page of
the Paragraph dialog. Double-click anywhere between the left and right indent icons on the ruler to
open the Tabs page of the Paragraph dialog.
A better strategy is to define tabs for the paragraph style. See Chapters 6 and 7 in the Writer
Guide for more information.

Tip
Using tabs to space out material on a page is not recommended. Depending on what
you are trying to accomplish, a table is usually a better choice.

Changing the default tab stop interval
Caution
Any changes to the default tab setting will affect the existing default tab stops in any
document you open afterward, as well as tab stops you insert after making the change.
To set the measurement unit and the spacing of default tab stop intervals, go to Tools > Options >
LibreOffice Writer > General.

Figure 77: Selecting a default tab stop interval
You can also set or change the measurement unit for rulers in the current document by rightclicking on the ruler to open a list of units. Click on one of them to change the ruler to that unit. The
selected setting applies only to that ruler.

Figure 78: Changing the measurement unit for a ruler

Checking spelling and grammar
Writer provides a spelling checker, which can be used in two ways.
Automatic Spell Check checks each word as it is typed and displays a wavy red line
under any unrecognized words. When the word is corrected, the line disappears.
To perform a combined spelling and grammar check on the document (or a text selection)
click the Spelling and Grammar button. This checks the document or selection and opens
the Spelling and Grammar dialog if any unrecognized words are found. In order to use this,
the appropriate dictionaries must be installed. By default, four dictionaries are installed: a
spelling checker, a grammar checker, a hyphenation dictionary, and a thesaurus.
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Here are some more features of the spelling checker:
• You can right-click on a word with a wavy underline to open a context menu. If you select
from the suggested words on the menu, the selection will replace the unrecognized word in
your text. Other menu options are discussed below.
• You can change the dictionary language (for example, Spanish, French or German) on the
Spelling and Grammar dialog.
• You can add a word to the dictionary. Click Add to Dictionary in the Spelling and Grammar
dialog or in the context menu.
• Click the Options button on the Spelling and Grammar dialog to open a dialog similar to
the one in Tools > Options > Language Settings > Writing Aids described in Chapter 2.
There you can choose whether to check uppercase words and words with numbers, and
you can manage custom dictionaries, that is, add or delete dictionaries and add or delete
words in a dictionary.
• There are a number of different methods by which you can set paragraphs to be checked in
a specific language (different from the rest of the document). For example by clicking on
the Language button on the Status Bar. See Chapter 7, Working with Styles, in the Writer
Guide for more information.
See Chapter 3, Working with Text, in the Writer Guide, for a detailed explanation of the spelling
and grammar checking facility.

Using built-in language tools
Writer provides some tools that make your work easier if you mix multiple languages within the
same document or if you write documents in various languages.
The main advantage of changing the language for a text selection is that you can then use the
correct dictionaries to check spelling and apply the localized versions of Autocorrect replacement
tables, thesaurus, grammar, and hyphenation rules.
You can also set the language for a paragraph or a group of characters as None (Do not check
spelling). This option is especially useful when you insert text such as web addresses or
programming language snippets that you do not want to check for spelling.
Specifying the language in character and paragraph styles can be problematic unless you use a
particular style for a different language. Changing the Language on the Font tab of the Paragraph
Styles dialog, will change the language for all paragraphs that use that paragraph style. You can
set certain paragraphs be checked in a language that is different from the language of the rest of
the document by putting the cursor in the paragraph and changing the language on the Status Bar.
See Chapter 7, Working with Styles, in the Writer Guide for information on how to manage the
language settings of a style.
You can also set the language for the whole document, for individual paragraphs, or even for
individual words and characters, from Tools > Language on the Menu bar.
Another way to change the language of a whole document is to use Tools > Options > Language
Settings > Languages. In the Default languages for documents section, you can choose a
different language for all the text that is not explicitly marked as a different language.
The spelling checker works only for those languages in the list that have the symbol (
) next to
them. If you do not see the symbol next to your preferred language, you can install the additional
dictionary using Tools > Language > More Dictionaries Online.
The language used for checking spelling is also shown in the Status Bar, next to the page style in
use.

Using AutoCorrect
Writer’s AutoCorrect function has a long list of common misspellings and typing errors, which it
corrects automatically. For example, “hte” will be changed to “the”.
AutoCorrect is turned on when Writer is installed. To turn it off, uncheck Tools > AutoCorrect >
While Typing.
Choose Tools > AutoCorrect > AutoCorrect Options to open the AutoCorrect dialog. There you
can define which strings of text are corrected and how. In most cases, the defaults are fine.
To stop Writer replacing a specific spelling, go to the Replace tab, highlight the word pair, and click

181

Delete.
To add a new spelling to the list, type it into the Replace and With boxes on the Replace tab, and
click New.
See the different tabs of the dialog for the wide variety of other options available to fine-tune
AutoCorrect.

Tip
AutoCorrect can be used as a quick way to insert special characters. For example, (c)
will be changed to ©. You can add your own special characters.
LibreOffice has an extensive list of special characters accessible with AutoCorrect. For
example, type :smiling: and AutoCorrect will replace it by ☺.

Using word completion
If Word Completion is enabled, Writer tries to guess which word you are typing and offers to
complete the word for you. To accept the suggestion, press Enter. Otherwise, continue typing.
To turn off Word Completion, select Tools > AutoCorrect > AutoCorrect Options > Word
Completion and deselect Enable word completion.
You can customize word completion from the Word Completion page of the AutoCorrect dialog:
• Add (append) a space automatically after an accepted word
• Show the suggested word as a tip (hovering over the word) rather than completing the text
as you type
• Collect words when working on a document, and then either save them for later use in
other documents or select the option to remove them from the list when closing the
document.
• Change the maximum number of words remembered for word completion and the length of
the smallest words to be remembered
• Delete specific entries from the word completion list
• Change the key that accepts a suggested entry—the options are Right arrow, End key,
Return (Enter), and Space bar
Note
Automatic word completion only occurs after you type a word for the second time in a
document.
Using AutoText
Use AutoText to store text, tables, graphics and other items for reuse and assign them to a key
combination for easy retrieval. For example, rather than typing “Senior Management” every time
you use that phrase, you can set up an AutoText entry to insert those words when you type “sm”
and press F3.
AutoText is especially powerful when assigned to fields. See Chapter 14, Working with Fields, in
the Writer Guide for more information.
Creating AutoText
To store some text as AutoText:
1) Type the text into your document.
2) Select the text.
3) Choose Tools > AutoText (or press Ctrl+F3).
4) In the AutoText dialog, type a name for the AutoText in the Name box. Writer will suggesta
one-letter shortcut, which you can change.
5) In the large box to the left, choose the category for the AutoText entry, for example My
AutoText.
6) Click the AutoText button on the right and select New (text only) from the menu.
7) Click Close to return to your document.

Tip
If the only option under the AutoText button is Import, either you have not entered a
name for your AutoText or there is no text selected in the document.
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Inserting AutoText
To insert AutoText, type the shortcut and press F3.

Formatting text
Using styles is recommended
Styles are central to using Writer. Styles enable you to easily format your document consistently,
and to change the format with minimal effort. A style is a named set of formatting options. When
you apply a style, you apply a whole group of formats at the same time. In addition, styles are used
by LibreOffice for many processes, even if you are not aware of them. For example, Writer relies
on heading styles (or other styles you specify) when it compiles a table of contents.
Caution
Manual formatting (also called direct formatting) overrides styles, and you cannot get
rid of the manual formatting by applying a style to it.

Tip
To remove manual formatting, select the text and choose Format > Clear Direct
Formatting from the Menu bar, or right-click and choose Clear Direct Formatting
from the context menu, or click the Clear Direct Formatting button on the Formatting
toolbar, or use Ctrl+M from the keyboard.
When clearing direct formatting, the text formatting will return to the applied paragraph
style and not the default paragraph style.
Writer defines several types of styles, for different types of elements: characters, paragraphs,
pages, frames, and lists. See Chapter 3, Using Styles and Templates, in this book and Chapters 6
and 7 in the Writer Guide.

Formatting paragraphs
You can apply many formats to paragraphs using the buttons on the Formatting toolbar and by
using the Paragraph panel of the Sidebar’s Properties deck. Not all buttons are visible in a
standard installation, but you can customize the toolbar to include those you use regularly. These
buttons and formats include:
• Apply Style
• Bullets On/Off (with a palette of bullet styles)
• Numbering On/Off (with a palette of numbering styles)
• Align Left, Center Horizontally, Align Right, or Justified
• Align Top, Center Vertically, Align Bottom
• Line Spacing (choose from 1, 1.15, 1.5, 2, or custom spacing
• Increase Paragraph Spacing, Decrease Paragraph Spacing
• Increase Indent, Decrease Indent
• Paragraph (to open the Paragraph dialog)

Formatting characters
You can apply many formats to characters using the buttons on the Formatting toolbar and by
using the Character panel of the Sidebar’s Properties deck. Not all buttons are visible in a standard
installation, but you can customize the toolbar to include those you use regularly. These buttons
and formats include:
• Font Name, Font Size
• Bold, Italic, Underline, Double Underline, Overline, Strikethrough, Outline
• Superscript, Subscript
• Uppercase, Lowercase
• Increase Font Size, Decrease Font Size
• Font Color (with a palette of colors)
• Background Color (with a palette of colors)
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•
•

Highlighting (with a palette of colors)
Character (to open the Character dialog)

Autoformatting
You can set Writer to format parts of a document automatically according to the choices made on
the Options page of the AutoCorrect dialog (Tools > AutoCorrect > AutoCorrect Options).

Tip
If you notice unexpected formatting changes occurring in your document, this is the first
place to look for the cause. In most cases Undo (Ctrl+Z) fixes the issue.
The Help describes each of these choices and how to activate the autoformats. Some common
unwanted or unexpected formatting changes include:
• Horizontal lines. If you type three or more hyphens (---), underscores (
) or equal signs
(===) on a line and then press Enter, the paragraph is replaced by a horizontal line aswide
as the page. The line is actually the lower border of the preceding paragraph.
• Bulleted and numbered lists. A bulleted list is created when you type a hyphen (-), star (*),
or plus sign (+), followed by a space or tab at the beginning of a paragraph. A numbered list
is created when you type a number followed by a period (.), followed by a space or tab at
the beginning of a paragraph. Automatic numbering is only applied to paragraphs formatted
with the Default, Text body or Text body indent paragraph styles.
To turn autoformatting on or off, choose Format > AutoCorrect and select or deselect the items on
the list.

Creating numbered or bulleted lists
There are several ways to create numbered or bulleted lists:
• Use autoformatting, as described above.
• Use list (numbering) styles, as described in Chapter 6, Introduction to Styles, and Chapter
7, Working with Styles, in the Writer Guide.
• Use the Numbering and Bullets buttons on the Formatting toolbar or on the Paragraph
panel of the Sidebar’s Properties deck: select the paragraphs for the list, and then click the
appropriate button on the toolbar or in the Sidebar.
Note
It is a matter of personal preference whether you type your information first, then apply
numbering/bullets, or apply them as you type.
Using the Bullets and Numbering toolbar
You can create nested lists (where one or more list items has a sub-list under it, as in an outline)
by using the buttons on the Bullets and Numbering toolbar (Figure 79). You can move items up or
down the list, create sub-points, change the style of bullets, and access the Bullets and Numbering
dialog, which contains more detailed controls. Use View > Toolbars > Bullets and Numbering to
see the toolbar.
Note
If numbering or bullets are being applied automatically in a way that you find
inappropriate, you can switch them off temporarily by unchecking Format >
AutoCorrect > While Typing.
Using the Sidebar for Bullets and Numbering
The Bullets and Numbering features (drop-down palettes of tools) on the Paragraph panel on the
Properties deck of the Sidebar can also be used to create nested lists and access the Bullets and
Numbering dialog. However, the Sidebar does not include tools for promoting and demoting items
in the list, as found on the Bullets and Numbering toolbar.
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1 Promote One Level
2 Demote One Level
3 Promote One Level with
Subpoints
4 Demote One Level with
Subpoints

5 Insert Unnumbered
Entry
6 Move Up

8 Move Up with Subpoints
9 Move Down with Subpoints
10 Restart Numbering

7 Move Down

11 Bullets and Numbering

Figure 79: Bullets and Numbering toolbar

Hyphenating words
You have several choices regarding hyphenation: let Writer do it automatically (using its
hyphenation dictionaries), insert conditional hyphens manually where necessary, or don’t
hyphenate at all.
Automatic hyphenation
To turn automatic hyphenation of words on or off:
1) Press F11 (⌘+T on Mac) to open the Styles and Formatting window, or, if the Sidebar is
open, click on the Styles and Formatting tab to open the Styles and Formatting deck.
2) On the Paragraph Styles page (Figure 80), right-click on Default Style and select Modify.

Figure 80: Modifying a style
3) On the Paragraph Style dialog (Figure 81), go to the Text Flow page.
4) Under Hyphenation, select or deselect the Automatically option. Click OK to save.

Note
Turning on hyphenation for paragraph Default Style affects all other paragraph styles
that are based on Default Style. You can individually change other styles so that
hyphenation is not active; for example, you might not want headings to be hyphenated.
Any styles that are not based on Default Style are not affected. See Chapter 3, Using
Styles and Templates, for more about styles based on other styles.

Figure 81: Turning on automatic hyphenation
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You can also set hyphenation choices through Tools > Options > Language Settings > Writing
Aids. In Options, near the bottom of the dialog, scroll down to find the hyphenation settings.

Figure 82: Setting hyphenation options
To change the minimum number of characters for hyphenation, the minimum number of characters
before a line break, or the minimum number of characters after a line break, select the item, and
then click the Edit button in the Options section.
Hyphenation options set on the Writing Aids dialog are effective only if hyphenation is turned on
through paragraph styles.
Manual hyphenation
To manually hyphenate words, do not use a normal hyphen, which will remain visible even if the
word is no longer at the end of a line when you add or delete text or change margins or font size.
Instead, use a conditional hyphen, which is visible only when required.
To insert a conditional hyphen inside a word, click where you want the hyphen to appear and press
Ctrl+hyphen. The word will be hyphenated at this position when it is at the end of the line, even if
automatic hyphenation for this paragraph is switched off.

Formatting pages
Writer provides several ways for you to control page layouts: page styles, columns, frames, tables,
and sections. For more information, see Chapter 4, Formatting Pages, in the Writer Guide.

Tip
Page layout is usually easier if you show text, object, table, and section boundaries in
Tools > Options > LibreOffice > Appearance, and paragraph end, tabs, breaks, and
other items in Tools > Options > LibreOffice Writer > Formatting Aids.

Which layout method to choose?
The best layout method depends on what the final document should look like and what sort of
information will be in the document. Here are some examples.
For a book similar to this user guide, with one
column of text, some figures without text beside
them, and some other figures with descriptive text,
use page styles for basic layout, and tables to place
figures beside descriptive text when necessary.
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For an index or other document with two columns of
text, where the text continues from the left-hand
column to the right-hand column and then to the
next page, all in sequence (also known as “snaking
columns” of text), use page styles (with two
columns). If the title of the document (on the first
page) is full-page width, put it in a single-column
section.

For a newsletter with complex layout, two or three
columns on the page, and some articles that
continue from one page to some place several
pages later, use page styles for basic layout. Place
articles in linked frames and anchor graphics to
fixed positions on the page if necessary.

For a document with terms and translations to
appear side-by-side in what appear to be columns,
use a table to keep items lined up, and so you can
type in both “columns”.

Creating headers and footers
A header is an area that appears at the top of a page above the margin. A footer appears at the
bottom of the page below the margin. Information such as page numbers inserted into a header or
footer displays on every page of the document with that page style.
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Note
A header and a footer are properties of the page style. Set or unset headers and
footers of all page styles in use in your document.
Inserting a header or footer
To insert a header, you can either:
• Choose Insert > Header and Footer > Header > Default Style (or some other page style,
if not Default Style), or
• Click above the top margin to make the Header marker appear (Figure 83), and then click
on the +.

Figure 83: Header marker at top of text area
After a header has been created, a down-arrow appears on the header marker. Click on this arrow
to drop down a menu of choices for working with the header (Figure 84).
Figure 84: Header menu

To format a header, you can use either the menu item shown in Figure 84 or Format > Page >
Header. Both methods take you to the same tab on the Page Style dialog.
Inserting header and footer contents
Other information such as document titles and chapter titles is often put into the header or footer.
These items are best added as fields. That way, if something changes, the headers and footers are
updated automatically. Here is one common example.
To insert the document title into the header:
1) Choose File > Properties > Description and type a title for your document.
2) Add a header (Insert > Header and Footer > Header > Default).
3) Place the cursor in the header part of the page.
4) Choose Insert > Fields > Title. The title should appear on a gray background (which does
not show when printed and can be turned off).
5) To change the title for the whole document, go back to File > Properties > Description.
Fields are covered in detail in Chapter 14, Working with Fields, in the Writer Guide.
For more about headers and footers, see Chapter 4, Formatting Pages, and Chapter 6,
Introduction to Styles, in the Writer Guide.

Numbering pages
Displaying the page number
To display page numbers automatically:
1) Insert a header or footer, as described in “Creating headers and footers” above.
2) Place the cursor in the header or footer where you want the page number to appear and
choose Insert > Fields > Page Number.
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Including the total number of pages
To include the total number of pages (as in “page 1 of 12”):
1) Type the word “page” and a space, then insert the page number as above.
2) Press the space bar once, type the word “of” and a space, then choose Insert > Fields >
Page Count.

Note
The Page Count field inserts the total number of pages in the document, as shown on
the Statistics tab of the document’s Properties window (File > Properties). If you
restart page numbering anywhere in the document, then the total page count may not
be what you want. See Chapter 4, Formatting Pages, in the Writer Guide for more
information.
Restarting page numbering
Often you will want to restart the page numbering at 1, for example on the page following a title
page or a table of contents. In addition, many documents have the “front matter” (such as the table
of contents) numbered with Roman numerals and the main body of the document numbered in
Arabic numerals, starting with 1.
You can restart page numbering in two ways.
Method 1:
1) Place the cursor in the first paragraph of the new page.
2) Choose Format > Paragraph.
3) On the Text Flow tab of the Paragraph dialog (Figure 81 on page 102), select Breaks.
4) Select Insert and then With Page Style and specify the page style to use.
5) Specify the page number to start from, and then click OK.

Tip
Method 1 is also useful for numbering the first page of a document with a page number
greater than 1. For example, you may be writing a book, with each chapter in a
separate file. Chapter 1 may start with page 1, but Chapter 2 could begin with page 25
and Chapter 3 with page 51.
Method 2:
1) Insert > Manual break.
2) By default, Page break is selected on the Insert Break dialog (Figure 85).
3) Choose the required page Style.
4) Select Change page number.
5) Specify the page number to start from, and then click OK.

Figure 85: Restarting page numbering after a manual page break
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Changing page margins
You can change page margins in three ways:
• Using the page rulers—quick and easy, but does not have fine control
• Using the Page Style dialog—can specify margins to two decimal places
• Using the Page panel on the Properties deck of the Sidebar
Caution
If you change the margins, the new margins affect the page style and will be shown in
the Page Style dialog the next time you open it.
Because the page style is affected, the changed margins apply to all pages using that
style.
To change margins using the rulers:
1) The gray sections of the rulers are the margins. Put the mouse cursor over the line between
the gray and white sections. The pointer turns into a double-headed arrow and displays the
current setting in a tool-tip.
2) Hold down the left mouse button and drag the mouse to move the margin.

Figure 86: Moving the margins
The small arrowheads (gray triangles) on the ruler are used for indenting paragraphs. They are often in
the same place as the page margins, so you need to be careful to move the margin marker, not the
arrows. The double-headed arrows shown in Figure 86 are mouse cursors shown in the correct
position for moving the margin markers.
To change margins using the Page Style dialog:
1) Right-click anywhere in the text area on the page and select Page from the context menu.
2) On the Page tab of the dialog, type the required distances in the Margins boxes.
To change margins using the Page panel of the Properties deck of the Sidebar:
1) On the open Sidebar (View > Sidebar) select the Properties tab.
2) Open the Page panel if is not open by clicking the plus (+) symbol in the panel title
3) Click the Margin button to open the sub-panel and enter the required dimensions in the
Custom size boxes (clicking the More Options button will open the Page Style dialog).
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Adding comments to a document
Authors and reviewers often use comments to exchange ideas, ask for suggestions, or mark items
needing attention.
You can select a contiguous block of text, which may be multiple paragraphs, for a comment; or
you can select a single point at which the comment will be inserted.
To insert a comment, select the text, or place the cursor in the place the comment refers to, and
choose Insert > Comment or press Ctrl+Alt+C. The anchor point of the comment is connected by
a dotted line to a box on the right-hand side of the page where you can type the text of the
comment. A Comments button is also added to the right of the horizontal ruler; you can click this
button to toggle the display of the comments.
Writer automatically adds at the bottom of the comment the author’s name and a time stamp
indicating when the comment was created. Figure 87 shows an example of text with comments
from two different authors.

Figure 87: Example of comments
Choose Tools > Options > LibreOffice > User Data to configure the name you want to appear in
the Author field of the comment, or to change it.
If more than one person edits the document, each author is automatically allocated a different
background color.
Right-click on a comment to open a context menu where you can delete the current comment, all
the comments from the same author, or all the comments in the document. From this menu, you
can also open a dialog to apply some basic formatting to the text of comments. You can paste
saved text using the Paste button in the menu. You can also change the font type, size, and
alignment in the usual editing manner.
To navigate from one comment to another, open the Navigator (F5), expand the Comments
section, and click on the comment text to move the cursor to the anchor point of the comment in
the document. Right-click on the comment to quickly edit or delete it.
You can also navigate through the comments using the keyboard. Use Ctrl+Alt+Page Down to
move to the next comment and Ctrl+Alt+Page Up to move to the previous comment.
Comments can be printed next to the text in the right margin as they appear on screen. Each page
is scaled down in order to make space for the comments to fit on the underlying paper size.
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Creating a table of contents
Writer’s table of contents feature lets you build an automated table of contents from the headings
in your document. Before you start, make sure that the headings are styled consistently. For
example, you can use the Heading 1 style for chapter titles and the Heading 2 and Heading 3
styles for chapter subheadings.
Although tables of contents can be customized extensively in Writer, often the default settings are
all you need. Creating a quick table of contents is simple:
1) When you create your document, use the following paragraph styles for different heading
levels (such as chapter and section headings): Heading 1, Heading 2, Heading 3, and so
on. These are what will appear in your table of contents.
2) Place the cursor where you want the table of contents to appear.
3) Choose Insert > Table of Contents and Index > Table of contents, Index or
Bibliography.
4) Change nothing in the Insert Index/Table dialog. Click OK.
If you add or delete text (so that headings move to different pages) or you add, delete, or change
headings, you need to update the table of contents.
To do this:
1) Place the cursor within the table of contents.
2) Right-click and choose Update Index or Table of Contents from the context menu.

Note
If you cannot place the cursor in the table of contents, choose Tools > Options >
LibreOffice Writer > Formatting Aids, and then select Enable in the Cursor in
protected areas section.
You can customize an existing table of contents at any time. Right-click anywhere in it and choose
Edit Index or Table of Contents from the context menu. Chapter 12, Creating Tables of Contents,
Indexes and Bibliographies, of the Writer Guide describes in detail all the customizations you can
choose.

Creating indexes and bibliographies
Indexes and bibliographies work in a similar way to tables of contents. Chapter 12, Creating Tables
of Contents, Indexes, and Bibliographies, in the Writer Guide describes the process in detail.
In addition to alphabetical indexes, other types of indexes supplied with Writer include those for
illustrations, tables, and objects, and you can even create a user-defined index. For example, you
might want an index containing only the scientific names of species mentioned in the text, and a
separate index containing only the common names of species. Before creating some types of
indexes, you first need to create index entries embedded in your Writer document.

Working with graphics
Graphics in Writer are of three basic types:
• Image files, including photos, drawings, scanned images, and others
• Diagrams created using LibreOffice’s drawing tools
• Charts created using LibreOffice’s Chart component
See Chapter 11, Graphics, the Gallery, and Fontwork, in this book and Chapter 8, Working with
Graphics, in the Writer Guide.

Printing
See Chapter 10, Printing, Exporting, and E-mailing, in this book and Chapter 5, Printing, Exporting,
Faxing, and E-mailing, in the Writer Guide for details on previewing pages before printing, selecting
print options, printing in black and white on a color printer, printing brochures, and other printing
features.
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Using mail merge
Writer provides very useful features to create and print:
• Multiple copies of a document to send to a list of different recipients (form letters)
• Mailing labels
• Envelopes
All these facilities use a registered data source (a spreadsheet or database containing the name
and address records and other information). Chapter 11, Using Mail Merge, in the Writer Guide
describes the process.

Tracking changes to a document
You can use several methods to keep track of changes made to a document.
1) Make your changes to a copy of the document (stored in a different folder, or under a
different name, or both), then use Writer to combine the two files and show thedifferences.
Choose Edit > Track Changes > Compare Document. This technique is particularly
useful if you are the only person working on the document, as it avoids the increase in file
size and complexity caused by the other methods.
2) Save versions that are stored as part of the original file. However, this method can cause
problems with documents of non-trivial size or complexity, especially if you save a lot of
versions. Avoid this method if you can.
3) Use Writer’s change marks (often called “redlines” or “revision marks”) to show where you
have added or deleted material, or changed formatting. Choose Edit > Track Changes >
Record Changes before starting to edit. Later, you or another person can review and
accept or reject each change. Choose Edit > Track Changes > Show Changes. Rightclick on an individual change and choose Accept Change or Reject Change from the
context menu, or choose Edit > Track Changes > Manage Changes to view the list of
changes and accept or reject them. Details are in the Writer Guide.

Tip
Not all changes are recorded. For example, changing a tab stop from align left to align
right, and changes in formulas (equations) or linked graphics are not recorded.
Caution
A document with active track changes and changes hidden carries the document
editing history that may not be noticed by the current user. Contents deleted or
modified can be recovered. While this is a feature, it is also a security exposure of the
document history.

Using fields
Fields are extremely useful features of Writer. They are used for data that changes in a document
(such as the current date or the total number of pages) and for inserting document properties such
as name, author, and date of last update. Fields are the basis of cross-referencing (see below);
automatic numbering of figures, tables, headings, and other elements; and a wide range of other
functions—far too many to describe here. See Chapter 14, Working with Fields, in the Writer Guide
for details.

Linking to another part of a document
If you type in cross-references to other parts of a document, those references can easily get out of
date if you reorganize the order of topics, add or remove material, or reword a heading. Writer
provides two ways to ensure that your references are up to date, by inserting links to other parts of
the same document or to a different document: hyperlinks and cross-references.
The two methods have the same result if you Ctrl+click the link when the document is open in
Writer: you are taken directly to the cross-referenced item. However, they also have major
differences:
• The text in a hyperlink does not automatically update if you change the text of the linked
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item (although you can change it manually), but changed text does automatically update in
a cross-reference.
When using a hyperlink, you do not have a choice of the content of the link (for example
text or page number), but when using a cross-reference, you have several choices,
including bookmarks.
To hyperlink to an object such as a graphic, and have the hyperlink show useful text such
as Figure 6, you need to give such an object a useful name (instead of a default name like
Graphics6), or use the Hyperlink dialog to modify the visible text. In contrast, crossreferences to figures with captions automatically show useful text, and you have a choice of
several variations of the name.
If you save a Writer document to HTML, hyperlinks remain active but cross-references do
not. (Both remain active when the document is exported to PDF.)

Using hyperlinks
The easiest way to insert a hyperlink to another part of the same document is by using the
Navigator:
1) Open the document containing the items you want to cross-reference.
2) Open the Navigator by clicking its button, choosing View > Navigator, pressing F5, or
opening it in the Sidebar.
3) Click the arrow part of the combination Drag Mode button, and choose Insert as
Hyperlink.
4) In the list at the bottom of the Navigator, select the document containing the item thatyou
want to cross-reference.
5) In the Navigator list, select the item that you want to insert as a hyperlink.
6) Drag the item to where you want to insert the hyperlink in the document. The name of the
item is inserted in the document as an active hyperlink.
You can also use the Hyperlink dialog to insert and modify hyperlinks within and between
documents. See Chapter 12, Creating Web Pages.

Figure 88: Inserting a hyperlink using the Navigator

Using cross-references
Replace any typed cross-references with automatic ones and, when you update fields, all the
references will update automatically to show the current wording or page numbers. The Crossreferences tab of the Fields dialog lists some items, such as headings, bookmarks, figures, tables,
and numbered items such as steps in a procedure. You can also create your own reference items;
see “Setting References” in Chapter 14, Working with Fields, in the Writer Guide for instructions.
To insert a cross-reference to a heading, figure, bookmark, or other item:
1) In your document, place the cursor where you want the cross-reference to appear.
2) If the Fields dialog is not open, click Insert > Cross-reference. On the Cross-references
tab (Figure 89), in the Type list, select the type of item to be referenced (for example,
Heading or Figure). You can leave this page open while you insert many cross-references.
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3)

Click on the required item in the Selection list, which shows all the items of the selected
type. In the Insert reference to list, choose the format required. The list varies according to
the Type. The most commonly used options are Reference (to insert the full text of a
heading or caption), Category and Number (to insert a figure number preceded by the
word Figure or Table, but without the caption text), Numbering (to insert only the figure or
table number, without the word “Figure” or “Table”), or Page (to insert the number of the
page the referenced text is on). Click Insert.

Figure 89: The Cross-references tab of the Fields dialog

Using bookmarks
Bookmarks are listed in the Navigator and can be accessed directly from there with a single mouse
click. You can cross-reference to bookmarks and create hyperlinks to bookmarks, as described
above.
1) Select the text you want to bookmark. Click Insert > Bookmark.
2) On the Insert Bookmark dialog, the larger box lists any previously defined bookmarks. Type
a name for this bookmark in the top box, and then click OK.

Figure 90: Inserting a bookmark
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Using master documents
Master documents are typically used for producing long documents such as a book, a thesis, or a
long report; or when different people are writing different chapters or other parts of the full
document, so you don’t need to share files. A master document joins separate text documents into
one larger document, and unifies the formatting, table of contents (TOC), bibliography, index, and
other tables or lists.
Since LibreOffice version 4.4, Master Document Templates can be added to the Template Manager
and creating a new document based on a Master Document Template creates a Master Document
with the same initial content as the template it is based upon. See Chapter 3, Styles and
Templates, for more about creating and using templates.
Yes, master documents do work in Writer. However, until you become familiar with them, you may
think that master documents are unreliable or difficult to use. See Chapter 13, Working with
Master Documents, in the Writer Guide.

Creating fill-in forms
A standard text document displays information: a letter, report, or brochure, for example. Typically
the reader may either edit everything or nothing in any way. A form has sections that are not to be
edited, and other sections that are designed for the reader to make changes. For example, a
questionnaire has an introduction and questions (which do not change) and spaces for the reader
to enter answers.
Forms are used in three ways:
• To create a simple document for the recipient to complete, such as a questionnaire sent out
to a group of people who fill it in and return it.
• To link into a database or data source and allow the user to enter information. Someone
taking orders might enter the information for each order into a database using a form.
• To view information held in a database or data source. A librarian might call up information
about books.

What is Calc?
Calc is the spreadsheet component of LibreOffice. You can enter data (usually numerical) in a
spreadsheet and then manipulate this data to produce certain results.
Alternatively, you can enter data and then use Calc in a “What if...” manner by changing some of
the data and observing the results without having to retype the entire spreadsheet or sheet.
Other features provided by Calc include:
• Functions, which can be used to create formulas to perform complex calculations on data.
• Database functions, to arrange, store, and filter data.
• Dynamic charts; a wide range of 2D and 3D charts.
• Macros, for recording and executing repetitive tasks; scripting languages supported include
LibreOffice Basic, Python, BeanShell, and JavaScript.
• Ability to open, edit, and save Microsoft Excel spreadsheets.
• Import and export of spreadsheets in multiple formats, including HTML, CSV, PDF, and
PostScript.
Note
If you want to use macros written in Microsoft Excel using the VBA macro code in
LibreOffice, you must first edit the code in the LibreOffice Basic IDE editor. See
Chapter 13 Getting Started with Macros and Calc Guide Chapter 12 Calc Macros.

Spreadsheets, sheets, and cells
Calc works with elements called spreadsheets. Spreadsheets consist of a number of individual
sheets, each sheet containing cells arranged in rows and columns. A particular cell is identified by
its row number and column letter.
Cells hold the individual elements – text, numbers, formulas, and so on – that make up the data to
display and manipulate.
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Each spreadsheet can have several sheets, and each sheet can have many individual cells. In
Calc, each sheet can have a maximum of 1,048,576 rows (65,536 rows in Calc 3.2 and earlier) and
a maximum of 1024 columns. LibreOffice Calc can hold up to 32,000 sheets.

Calc main window
When Calc is started, the main window opens (Figure 91). The parts of this window are described
below.

Title bar
The Title bar, located at the top, shows the name of the current spreadsheet. When a spreadsheet
is newly created from a template or a blank document, its name is Untitled X, where X is a number.
When you save a spreadsheet for the first time, you are prompted to enter a name of your choice.

Title bar

Menu bar

Standard toolbar

Active cell Active cell reference
(Name box)

Column
headers

ormatting toolbar

Formula bar

Row headers

Sheet tab

Status bar
Sidebar

Figure 91: Calc main dialog

Menu bar
When you select an item on the Menu bar, a sub-menu drops down to show commands. You can
also customize the Menu bar; see Chapter 14 Customizing LibreOffice for more information.
• File – contains commands that apply to the entire document; for example, Open, Save,
Wizards, Export as PDF, Print, Digital Signatures.
• Edit – contains commands for editing the document; for example, Undo, Copy, Changes,
Fill, Plug-in.
• View – contains commands for modifying how the Calc user interface looks; for example,
Toolbars, Column & Row Headers, Full Screen, Zoom.
• Insert – contains commands for inserting elements into a spreadsheet; for example,
Pictures, Frames, Special Characters, Charts, Functions.
• Format – contains commands for modifying the layout of a spreadsheet; for example, Cells,
Page, Styles and Formatting, Alignment.
• Sheet – contains the most often used commands for table handling, such as Insert and
Delete Cells, Columns, Rows, and Sheets, as well as Comments and Cell fill.
• Tools – contains various functions to help you check and customize the spreadsheet; for
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example, Spelling, Share Document, Gallery, Macros.
Data – contains commands for manipulating data in the spreadsheet; for example, Define
Database Range, Sort, Statistics, Pivot Tables, Consolidate.
Window – contains commands for the display window; for example, New Window, Split.
Help – contains links to the LibreOffice help system and other miscellaneous functions; for
example, Help, License Information, and Check for Updates.

Toolbars
The default setting when Calc opens is for the Standard and Formatting toolbars to be docked at
the top of the workspace (Figure 91).
Calc toolbars can be either docked and fixed in place, or floating; you can move a toolbar into a
more convenient position on the workspace. Docked toolbars can be undocked and either moved
to different docked position on the workspace, or left as a floating toolbar. Toolbars that are floating
when opened can be docked into a fixed position on the workspace.
The default set of icons (sometimes called buttons) on toolbars provides a wide range of common
commands and functions. You can also remove or add icons to toolbars; see Chapter 14
Customizing LibreOffice for more information.

Formula bar
The Formula Bar is located at the top of the sheet in the Calc workspace. The Formula Bar is
permanently docked in this position and cannot be used as a floating toolbar. If the Formula Bar is
not visible, go to View on the Menu bar and select Formula Bar.

Figure 92: Formula bar
Going from left to right and referring to Figure 92, the Formula Bar consists of the following:
• Name Box – gives the current active cell reference using a combination of a letter and
number, for example A1. The letter indicates the column and the number indicates the row
of the selected cell. If you have selected a range of cells that is also a named range, the
name of the range is shown in this box. You can also type a cell reference in the Name Box
to jump to the referenced cell. If you type the name of a named range and press the Enter
key, the named range is selected and displayed.
•

Function Wizard
– opens a dialog from which you can search through a list of
available functions. This can be very useful because it also shows how the functionsare
formatted.

•

Sum
– clicking on the Sum icon totals the numbers in the cells above the selected cell
and then places the total in the selected cell. If there are no numbers above the selected
cell, then the cells to the left are totaled.
Function
– clicking on the Function icon inserts an equals (=) sign into the selected cell
and the Input line, allowing a formula to be entered.
Input line – displays the contents of the selected cell (data, formula, or function) and allows
you to edit the cell contents. To turn the Input line into a multiline input area for very long
formulas, click the dropdown button on the right.
You can also edit the contents of a cell directly in the cell itself by double-clicking on the
cell. When you enter new data into a cell, the Sum and Function icons change to Cancel

•
•

•

and Accept icons

.

Note
In a spreadsheet the term “function” covers much more than just mathematical
functions. See the Calc Guide Chapter 7 Using Formulas and Functions for more
information.
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Spreadsheet layout
Individual cells
The main section of the workspace in Calc displays the cells in the form of a grid. Each cell is
formed by the intersection of one column and one row in the spreadsheet.
At the top of the columns and the left end of the rows are a series of header boxes containing
letters and numbers. The column headers use an alpha character starting at A and go on to the
right. The row headers use a numerical character starting at 1 and go down.
These column and row headers form the cell references that appear in the Name Box on the
Formula Bar (Figure 92). If the headers are not visible on the spreadsheet, go to View on the Menu
bar and select Column & Row Headers.
Sheet tabs
In Calc, you can have more than one sheet in a spreadsheet. At the bottom of the grid of cells in a
spreadsheet are sheet tabs indicating how many sheets there are in the spreadsheet. Clicking on a
tab enables access to each individual sheet and displays that sheet. An active sheet is indicated
with a white tab (default Calc setup). You can also select multiple sheets by holding down the Ctrl
key while clicking on the sheet tabs.
To change the default name for a sheet (Sheet1, Sheet2, and so on), right-click on a sheet tab and
select Rename Sheet from the context menu. A dialog opens, in which you can type a new name
for the sheet. Click OK when finished to close the dialog.
To change the color of a sheet tab, right-click on the tab and select Tab Color from the context
menu to open the Tab Color dialog (Figure 93). Select a color and click OK when finished to close
the dialog. To add new colors to this color palette, see Chapter 14 Customizing LibreOffice.

Figure 93: Tab color dialog
Status bar
The Calc status bar (Figure 94) provides information about the spreadsheet as well as quick and
convenient ways to change some of its features. Most of the fields are similar to those in other
components of LibreOffice; see Chapter 1 Introducing LibreOffice in this guide and the Calc Guide
Chapter 1 Introducing Calc for more information.
Sheet number

Page style

Cell selection information

Selection mode

Insert/overwrite mode

Digital signature

Unsaved changes

Zoom slider & percentage

Cell or object information

Figure 94: Calc status bar
Sidebar

The Calc Sidebar (View > Sidebar) is located on the right side of the window. It is a mixture of
toolbar and dialog. It is similar to the sidebar in Writer (shown in Chapter 1 and Chapter 4 of this
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book) and consists of five decks: Properties, Styles and Formatting, Gallery, Navigator, and
Functions. Each deck has a corresponding icon on the Tab panel to the right of the sidebar,
allowing you to switch between them.
The decks are described below.
• Properties: This deck includes four content panels.
– Styles: Access to the available cell styles, update cell styles, and new cell styles.
– Character: Controls for formatting the text, such as font family, size, and color. Some
controls, such as superscript, only become active when the text cursor is active in the
Input line of the Formula bar or the cell.
– Alignment: Controls to align the text in various ways, including horizontal and vertical
alignment, wrapping, indenting, merging, text orientation, and vertical stacking.
– Cell Appearance: Controls to set the appearance options, including cell background
color, cell border formats including line color and style, and grid lines.
– Number Format: Quickly change the format of numbers including decimals, currency,
dates, or numeric text. Numerical and label field controls for Forms are also available.
Each of these panels has a More Options button, which opens a dialog giving a greater
number of options. These dialogs lock the document for editing until they are closed.
• Styles and Formatting: This deck contains a single panel, which is the same as that
opened by selecting the Styles and Formatting button (F11) from the Text Formatting
toolbar.
• Gallery: This deck contains a single panel, which is the same as that opened by selecting
Gallery from the Standard toolbar or Tools > Gallery from the Menu bar.
• Navigator: This deck contains a single panel, which is essentially the same as the
Navigator window opened by clicking the Navigator button on the Standard toolbar or
selecting View > Navigator (F5) from the Menu bar. Only the Contents button is absent in
the Sidebar’s Navigator panel.
• Functions: This deck contains a single panel, which is the same as the window openedby
selecting Insert > Function... from the Menu bar.
To the right side of the title bar of each open deck is a Close button (X), which closes the deck to
leave only the Tab bar open. Clicking on any Tab button reopens the deck.
To hide the Sidebar, or reveal it if already hidden, click on the edge Hide/Show button. To adjust
the deck width, drag on the left edge of the sidebar.
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Opening a CSV file
Comma-separated-values (CSV) files are spreadsheet files in a text format where cell contents are
separated by a character, for example a comma or semicolon. Each line in a CSV text file
represents a row in a spreadsheet. Text is entered between quotation marks; numbers are entered
without quotation marks.

Tip
Most CSV files come from databases tables, queries, or reports, where further
calculations and charting are required. On Microsoft Windows, CSV files often have the
XLS file name extension to look like an Excel file, but they are still CSV files internally.
To open a CSV file in Calc:
1) Choose File > Open on the Menu bar and locate the CSV file that you want to open.
2) Select the file and click Open. By default, a CSV file has the extension .csv. However,
some CSV files may have a .txt extension.
3) The Text Import dialog (Figure 95) opens. Here you can select the various options
available when importing a CSV file into a Calc spreadsheet.
4) Click OK to open and import the file.

Figure 95: Text Import dialog
The options for importing CSV files into a Calc spreadsheet are as follows:
• Import
– Character Set – specifies the character set to be used in the imported file.
– Language – determines how the number strings are imported.
If Language is set to Default for CSV import, Calc will use the globally set language. If
Language is set to a specific language, that language will be used when importing
numbers.
– From Row – specifies the row where you want to start the import. The rows are visible
in the preview window at the bottom of the dialog.
• Separator Options – specifies whether the data uses separators or fixed widths as
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delimiters.
– Fixed width – separates fixed-width data (equal number of characters) into columns.
Click on the ruler in the preview window to set the width.
– Separated by – select the separator used in the data to delimit the data into columns. If
you select Other, specify the character used to separate data into columns. This custom
separator must also be contained in the data.
– Merge delimiters – combines consecutive delimiters and removes blank data fields.
– Text delimiter – select a character to delimit text data.
Other options
– Quoted fields as text – when this option is enabled, fields or cells whose values are
quoted in their entirety (the first and last characters of the value equal the text delimiter)
are imported as text.
– Detect special numbers – when this option is enabled, Calc will automaticallydetect all
number formats, including special number formats such as dates, time, and scientific
notation. The selected language also influences how such special numbers are
detected, since different languages and regions many have different conventions for
such special numbers.
When this option is disabled, Calc will detect and convert only decimal numbers. The
rest, including numbers formatted in scientific notation, will be imported as text. A
decimal number string can have digits 0-9, thousands separators, and a decimal
separator. Thousands separators and decimal separators may vary with the selected
language and region.
Fields – shows how the data will look when it is separated into columns.
– Column type – select a column in the preview window and select the data type to be
applied the imported data.
– Standard – Calc determines the type of data.
– Text – imported data are treated as text.
– US English – numbers formatted in US English are searched for and included
regardless of the system language. A number format is not applied. If there are no US
English entries, the Standard format is applied.
– Hide – the data in the column are not imported.
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Saving spreadsheets
To save a spreadsheet, see Chapter 1 Introducing LibreOffice for more details on how to save files
manually or automatically. Calc can also save spreadsheets in a range of formats and also export
spreadsheets to PDF, HTML, and XHTML file formats; see the Calc Guide Chapter 6 Printing,
Exporting, and E-mailing for more information.

Saving in other spreadsheet formats
If you need to exchange files with users who are unable to receive spreadsheet files in Open
Document Format (ODF) (*.ods), which Calc uses as default format, you can save a spreadsheet
in another format.
1) Save the spreadsheet in Calc spreadsheet file format (*.ods).
2) Select File > Save As on the Menu bar to open the Save As dialog (Figure 96).

3)
4)
5)
6)
7)

8)

Figure 96: Save As dialog
In File name, you can enter a new file name for the spreadsheet.
In File type drop-down menu, select the type of spreadsheet format you want to use.
If Automatic file name extension is selected, the correct file extension for the
spreadsheet format you have selected will be added to the file name.
Click Save.
Each time you click Save, the Confirm File Format dialog opens (Figure 97). Click Use
[xxx] Format to continue saving in your selected spreadsheet format or click Use ODF
Format to save the spreadsheet in Calc ODS format.
If you select Text CSV format (*.csv) for your spreadsheet, the Export Text File dialog
(Figure 98) opens. Here you can select the character set, field delimiter, text delimiter, and
so on to be used for the CSV file.

Figure 97: Confirm File Format dialog
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Figure 98: Export Text File dialog for CSV files

Tip
To have Calc save documents by default in a file format other than the default ODF
format, go to Tools > Options > Load/Save > General. In Default file format and
ODF settings > Document type, select Spreadsheet, then in Always save as, select
your preferred file format.

Navigating within spreadsheets
Calc provides many ways to navigate within a spreadsheet from cell to cell and sheet to sheet. You
can generally use the method you prefer.

Cell navigation
When a cell is selected or in focus, the cell borders are emphasized. When a group of cells is
selected, the cell area is colored. The color of the cell border emphasis and the color of a group of
selected cells depends on the operating system being used and how you have set up LibreOffice.
• Using the mouse – place the mouse pointer over the cell and click the left mouse button.
To move the focus to another cell using the mouse, simply move the mouse pointer to the
cell where you want the focus to be and click the left mouse button.
• Using a cell reference – highlight or delete the existing cell reference in the Name Boxon
the Formula Bar (Figure 92 on page 118). Type the new cell reference of the cell you want
to move to and press Enter key. Cell references are case-insensitive: for example, typing
either a3 or A3 will move the focus to cell A3.
• Using the Navigator – press the F5 key to open the Navigator dialog (Figure 99) or click
the Navigator Tab button in the open Sidebar. Type the cell reference into the Column and
Row fields and press the Enter key.
• Using the Enter key – pressing Enter moves the cell focus down in a column to the next
row. Pressing Shift+Enter moves the focus up in a column to the previous row.
• Using the Tab key – pressing Tab moves the cell focus right in a row to the next column.
Pressing Shift+Tab moves the focus to the left in a row to the previous column.
• Using the arrow keys – pressing the arrow keys on the keyboard moves the cell focus in
the direction of the arrow pressed.
• Using Home, End, Page Up and Page Down
– Home moves the cell focus to the start of a row.
– End moves the cell focus to the last cell on the right in the row that contains data.
– Page Down moves the cell focus down one complete screen display.
– Page Up moves the cell focus up one complete screen display.
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Figure 99: Navigator dialog in Calc

Sheet navigation
Each sheet in a spreadsheet is independent of the other sheets, though references can be linked
from one sheet to another. There are three ways to navigate between sheets in a spreadsheet:
• Using the Navigator – when the Navigator is open (Figure 99), double-click on any of the
listed sheets to select the sheet.
• Using the keyboard – use key combinations Ctrl+Page Down to move one sheet to the
right and Ctrl+Page Up to move one sheet to the left.
• Using the mouse – click on one of the sheet tabs at the bottom of the spreadsheet to
select that sheet.
If your spreadsheet contains a lot of sheets, then some of the sheet tabs may be hidden behind the
horizontal scroll bar at the bottom of the screen. If this is the case:
• Using the four buttons to the left of the sheet tabs can move the tabs into view (Figure 100).
• Dragging the scroll bar edge to the right may reveal all the tabs.
• Right-clicking on any of the arrows opens a context menu where you can select a sheet
(see Figure 101).
Note
When you insert a new sheet into a spreadsheet, Calc automatically uses the next
number in the numeric sequence as a name. Depending on which sheet is open when
you insert a new sheet, and the method you use to insert a new sheet, the new sheet
may not be in numerical order. It is recommended to rename sheets in a spreadsheet
to make them more recognizable.
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Move to the first sheet
Move to the next sheet on the left
Move to the next sheet on the right
Move to the last sheet
Insert a new sheet after the last sheet
Sheet tabs
Figure 100: Navigating sheet tabs

Figure 101: Right-click any arrow button
Keyboard navigation
To navigate a spreadsheet using the keyboard, pressing a key or a combination of keys. For a key
combination, press more than one key at the same time. Table 4 lists the keys and key
combinations you can use for spreadsheet navigation in Calc.
Table 4. Keyboard cell navigation
Keyboard
shortcut

Cell navigation

→

Moves cell focus right one cell.

←

Moves cell focus left one cell.

↑

Moves cell focus up one cell..

↓

Moves cell focus down one cell

Ctrl+→

Moves cell focus to the first column on the right containing data in that row if cell
focus is on a blank cell.
Moves cell focus to the last column on the right in the same range of occupied
cells in that row if cell focus is on a cell containing data.
Moves cell focus to the last column on the right in the spreadsheet if there are no
more cells containing data.

Keyboard
shortcut
Ctrl+←

Cell navigation

Ctrl+↑

Moves cell focus to the last column on the left containing data in that row if cell
focus is on a blank cell.
Moves cell focus to the first column on the left in the same range of occupied
cells in that row if cell focus is on a cell containing data.
Moves cell focus to the first column in that row if there are no more cells
containing data.
Moves cell focus from a blank cell to the first cell above containing data in the
same column.
Moves cell focus to the first row in the same range of occupied cells if cell focus is
on a cell containing data.
Moves cell focus from the last cell containing data to the cell in the same column
in the last row of the spreadsheet.
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Ctrl+↓

Moves cell focus from a blank cell to the first cell below containing data in the
same column.
Moves cell focus to the last row in the same range of occupied cells in that
column if cell focus is on a cell containing data.
Moves cell focus from the last cell containing data to the cell in the same column
in the last row of the spreadsheet.

Ctrl+Home

Moves cell focus from anywhere on the spreadsheet to Cell A1 on the same
sheet.

Ctrl+End

Moves cell focus from anywhere on the spreadsheet to the last cell in the lower
right-hand corner of the rectangular area of cells containing data on the same
sheet.

Alt+Page Down

Moves cell focus one screen to the right (if possible).

Alt+Page Up

Moves cell focus one screen to the left (if possible).

Ctrl+Page Down

Moves cell focus to the same cell on the next sheet to the right in sheet tabs if the
spreadsheet has more than on sheet.

Ctrl+Page Up

Moves cell focus to the same cell on the next sheet to the left in sheet tabs if the
spreadsheet has more than on sheet.

Tab

Moves cell focus to the next cell on the right.

Shift+Tab

Moves cell focus to the next cell on the left.

Enter

Moves cell focus down one cell (unless changed by user).

Shift+Enter

Moves cell focus up one cell (unless changed by user).

Customizing the Enter key
You can customize the direction in which the Enter key moves the cell focus by going to Tools >
Options > LibreOffice Calc > General. Select the direction cell focus moves from the drop-down
list. Depending on the file being used or the type of data being entered, setting a different direction
can be useful. The Enter key can also be used to switch into and out of editing mode. Use the first
two options under Input settings in Figure 102 to change the Enter key settings.

Figure 102: Customizing the Enter key
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Selecting items in a spreadsheet
Selecting cells
Single cell
Left-click in the cell. You can verify your selection by looking in the Name Box on the Formula Bar
(Figure 92 on page 118).
Range of contiguous cells
A range of cells can be selected using the keyboard or the mouse.
To select a range of cells by dragging the mouse cursor:
1) Click in a cell.
2) Press and hold down the left mouse button.
3) Move the mouse around the screen.
4) Once the desired block of cells is highlighted, release the left mouse button.
To select a range of cells without dragging the mouse:
1) Click in the cell which is to be one corner of the range of cells.
2) Move the mouse to the opposite corner of the range of cells.
3) Hold down the Shift key and click.

Tip
You can also select a contiguous range of cells by first clicking in the Selection mode
field on the Status Bar (Figure 94 on page 120) and selecting Extending selection
before clicking in the opposite corner of the range of cells. Make sure to change back
to Standard selection or you may find yourself extending a cell selection
unintentionally.
To select a range of cells without using the mouse:
1) Select the cell that will be one of the corners in the range of cells.
2) While holding down the Shift key, use the cursor arrows to select the rest of the range.

Tip
You can also directly select a range of cells using the Name Box. Click into the Name
Box on the Formula Bar (Figure 92 on page 118). To select a range of cells, enter the
cell reference for the upper left-hand cell, followed by a colon (:), and then the lower
right-hand cell reference. For example, to select the range that would go from A3 to C6,
you would enter A3:C6.
Range of non-contiguous cells
1) Select the cell or range of cells using one of the methods above.
2) Move the mouse pointer to the start of the next range or single cell.
3) Hold down the Ctrl key and click or click-and-drag to select another range of cells to add to
the first range.
4) Repeat as necessary.
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Selecting columns and rows
Single column or row
To select a single column, click on the column header (Figure 91 on page 117).
To select a single row, click on the row header.
Multiple columns or rows
To select multiple columns or rows that are contiguous:
1) Click on the first column or row in the group.
2) Hold down the Shift key.
3) Click the last column or row in the group.
To select multiple columns or rows that are not contiguous:
1) Click on the first column or row in the group.
2) Hold down the Ctrl key.
3) Click on all of the subsequent columns or rows while holding down the Ctrl key.
Entire sheet
To select the entire sheet, click on the small box between the column headers and the row headers
(Figure 103), or use the key combination Ctrl+A to select the entire sheet, or go to Edit on the
Menu bar and select Select All.

Figure 103: Select All box

Selecting sheets
You can select one or multiple sheets in Calc. It can be advantageous to select multiple sheets,
especially when you want to make changes to many sheets at once.
Single sheet
Click on the sheet tab for the sheet you want to select. The tab for the selected sheet becomes
white (default Calc setup).
Multiple contiguous sheets
To select multiple contiguous sheets:
1) Click on the sheet tab for the first desired sheet.
2) Move the mouse pointer over the sheet tab for the last desired sheet.
3) Hold down the Shift key and click on the sheet tab.
4) All tabs between these two selections will turn white (default Calc setup). Any actions that
you perform will now affect all highlighted sheets.
Multiple non-contiguous sheets
To select multiple non-contiguous sheets:
1) Click on the sheet tab for the first desired sheet.
2) Move the mouse pointer over the sheet tab for the second desired sheet.
3) Hold down the Ctrl key and click on the sheet tab.
4) Repeat as necessary.
5) The selected tabs will turn white (default Calc setup). Any actions that you perform will now
affect all highlighted sheets.
All sheets
Right-click a sheet tab and choose Select All Sheets from the context menu.
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Working with columns and rows
Note

Inserting columns and rows
When you insert columns or rows, the cells take the formatting of the corresponding
cells in the next column to left or the row above.

Single column or row
Using the Sheet menu:
1) Select a cell, column, or row where you want the new column or row inserted.
2) Go to Sheet on the Menu bar and select either Insert > Columns > Columns Left or >
Columns Right or Insert > Rows > Rows Above or > Rows Below.
Using the mouse:
1) Select a column or row where you want the new column or row inserted.
2) Right-click the column or row header.
3) Select Insert Columns Left, Insert Columns Right, Insert Rows Above, or InsertRows
Below from the context menu.
Multiple columns or rows
Multiple columns or rows can be inserted at once rather than inserting them one at a time.
1) Highlight the required number of columns or rows by holding down the left mouse button on
the first one and then dragging across the required number of identifiers.
2) Proceed as for inserting a single column or row above.

Deleting columns and rows
Single column or row
To delete a single column or row:
1) Select a cell in the column or row you want to delete.
2) Go to Sheet on the Menu bar and select Delete Cells or right-click and select Delete from
the context menu.
3) Select the option you require from the Delete Cells dialog (Figure 104).

Figure 104: Delete Cells dialog
Alternatively:
1) Click in the column or header to select the column or row.
2) Go to Sheet on the Menu bar and select Delete Cells or right-click and select Delete
Columns or Delete Rows from the context menu.
Multiple columns or rows
To delete multiple columns or rows:
1) Select the columns or rows, see “Multiple columns or rows” on page 129 for more
information.
2) Go to Sheet on the Menu bar and select Delete Cells, or right-click and select Delete
Columns or Delete Rows from the context menu.
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Working with sheets
Inserting new sheets
Click on the Add Sheet icon
on the bottom of the screen to insert a new sheet after the last
sheet in the spreadsheet without opening the Insert Sheet dialog. The following methods open the
Insert Sheet dialog (Figure 105), where you can position the new sheet, create more than one
sheet, name the new sheet, or select a sheet from a file.
1) Select the sheet where you want to insert a new sheet, then go to Sheet > Insert Sheet...
on the Menu bar.
2) Right-click on the sheet tab where you want to insert a new sheet and select Insert Sheet
from the context menu.
3) Click in the empty space at the end of the sheet tabs.
4) Right-click in the empty space at the end of the sheet tabs and select Insert Sheet from the
context menu.

Figure 105: Insert Sheet dialog

Moving and copying sheets
You can move or copy sheets within the same spreadsheet by dragging and dropping or using the
Move/Copy Sheet dialog. To move or copy a sheet into a different spreadsheet, you have to use
the Move/Copy Sheet dialog.
Dragging and dropping
To move a sheet to a different position within the same spreadsheet, click and hold on the sheet
tab and drag it to its new position before releasing the mouse button.
To copy a sheet within the same spreadsheet, hold down the Ctrl key (Option key on Mac) then
click on the sheet tab and drag it to its new position before releasing the mouse button. The mouse
pointer may change to include a plus sign depending on the setup of your operating system.
Using a dialog
Use the Move/Copy Sheet dialog (Figure 106) to specify exactly whether you want the sheet in
the same or a different spreadsheet, its position within the spreadsheet, and the sheet name when
you move or copy the sheet.
1) In the current document, right-click on the sheet tab you wish to move or copy and select
Move/Copy Sheet from the context menu or go to Sheet > Move or Copy Sheet... on the
Menu bar.
2) Select Move to move the sheet or Copy to copy the sheet in the Action area.
3) Select the spreadsheet where you want the sheet to be placed from the drop-down list in
To document. This can be the same spreadsheet, another spreadsheet already open, or a
new spreadsheet.
4) Select the position in Insert before where you want to place the sheet.
5) Type a name in the New name text box if you want to rename the sheet when it is moved
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6)

or copied. If you do not enter a name, Calc creates a default name (Sheet 2, Sheet 3, and
so on).
Click OK to confirm the move or copy and close the dialog.

Caution
When you move or copy to another spreadsheet or a new spreadsheet, a conflict may
occur with formulas linked to other sheets in the previous location.

Move/Copy Sheet dialog

Deleting sheets
To delete a single sheet, right-click on the sheet tab you want to delete and select Delete Sheet
from the context menu, or go to Sheet > Delete Sheet... on the Menu bar. Click Yes to confirm the
deletion.
To delete multiple sheets, select the sheets (see “Selecting sheets” on page 130), then right-click
one of the sheet tabs and select Delete Sheet from the context menu, or go to Sheet > Delete
Sheet... from on the Menu bar. Click Yes to confirm the deletion.

Renaming sheets
By default, the name for each new sheet added is SheetX, where X is the number of the next sheet
to be added. While this works for a small spreadsheet with only a few sheets, it can become
difficult to identify sheets when a spreadsheet contains many sheets.
You can rename a sheet using one of the following methods:
• Enter the name in the Name text box when you create the sheet using the Insert Sheet
dialog (Figure 105 on page 132).
• Right-click on a sheet tab and select Rename Sheet from the context menu to replace the
existing name with a different one.
• Double-click on a sheet tab to open the Rename Sheet dialog.
Note
Sheet names must start with either a letter or a number; other characters, including
spaces, are not allowed. Apart from the first character of the sheet name, permitted
characters are letters, numbers, spaces, and the underscore character. Attempting to
rename a sheet with an invalid name will produce an error message.
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Viewing Calc
Changing document view
Use the zoom function to show more or fewer cells in the window when you are working on a
spreadsheet. For more about zoom, see Chapter 1 Introducing LibreOffice in this guide.

Freezing rows and columns
Freezing locks a number of rows at the top of a spreadsheet or a number of columns on the left of
a spreadsheet or both rows and columns. Then, when moving around within a sheet, the cells in
frozen rows and columns always remain in view.
Figure 107 shows some frozen rows and columns. The heavier horizontal line between rows 3 and
23 and the heavier vertical line between columns F and Q indicate that rows 1 to 3 and columns A
to F are frozen. The rows between 3 and 23 and the columns between F and Q have been scrolled
off the page.

Figure 107: Frozen rows and columns
Freezing rows or columns
1) Click on the row header below the rows where you want the freeze, or click on the column
header to the right of the columns where you want the freeze.
2) Click on the Freeze Rows and Columns icon in the main toolbar or go to View on the
Menu bar and select Freeze Rows and Columns. A heavier line appears between the
rows or columns indicating where the freeze has been placed.
Freezing rows and columns
1) Click into the cell that is immediately below the rows you want frozen and immediately to
the right of the columns you want frozen.
2) Click on the Freeze Rows and Columns icon in the main toolbar or go to View on the
Menu bar and select Freeze Rows and Columns. A heavier line appears between the
rows or columns indicating where the freeze has been placed.
Unfreezing
To unfreeze rows or columns, either go to View on the Menu bar and select Freeze Rows and
Columns or click on the Freeze Rows and Columns icon in the main toolbar. The heavier lines
indicating freezing will disappear.

Splitting the screen
Another way to change the view is by splitting the screen your spreadsheet is displayed in (also
known as splitting the window). The screen can be split horizontally, vertically, or both, giving you
up to four portions of the spreadsheet in view at any one time. An example of splitting the screen is
shown in Figure 108 where a split is indicated by additional window borders within the sheet.
Why would you want to do this? For example, consider a large spreadsheet in which one cell
contains a number that is used by three formulas in other cells. Using the split-screen technique,
you can position the cell containing the number in one section and each of the cells with formulas
in the other sections. You can then change the number in one cell and watch how it affects each of
the formulas.

Figure 108: Split screen example
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Splitting horizontally or vertically
1) Click on the row header below the rows where you want to split the screen horizontally or
click on the column header to the right of the columns where you want to split the screen
vertically.
2) Go to View on the Menu bar and select Split Window. Window borders appear between
the rows or columns indicating where the split has been placed, as shown in Figure 109.
Alternatively:
– For a horizontal split, drag the new horizontal window border beneath the rowwhere
you want the horizontal split positioned.
– For a vertical split, drag the new vertical window border across to the right of the column
where you want the vertical split positioned.
Splitting horizontally and vertically
1) Click in the cell that is immediately below the rows where you want to split the screen
horizontally and immediately to the right of the columns where you want to split the screen
vertically.
2) Go to View on the Menu bar and select Split Window. Heavy black lines appear between
the rows or columns indicating where the split has been placed.

Figure 109: Split screen window borders
Removing split views
To remove a split view, do one of the following:
• Drag the split window borders back to their places at the ends of the scroll bars.
• Go to View on the Menu bar and deselect Split Window.
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Using the keyboard
Most data entry in Calc can be accomplished using the keyboard.

Numbers
Click in the cell and type in a number using the number keys on either the main keyboard or
numeric keypad. By default, numbers are right aligned in a cell.
Minus numbers
To enter a negative number, either type a minus (–) sign in front of the number or enclose the
number in parentheses (), for example (1234). The result for both methods of entry will be the
same, for example -1234.
Leading zeroes
To retain a minimum number of integer characters in a cell when entering numbers in order to
retain the number format, for example 1234 and 0012, leading zeros have to be added using one
of the following methods.
Method 1
1) With the cell selected, right-click on the cell, select Format Cells from the context menu or
go to Format > Cells on the Menu bar or use the keyboard shortcut Ctrl+1 to open the
Format Cells dialog (Figure 110).
Figure 110: Format Cells dialog – Numbers page

2)
3)

4)

Make sure the Numbers tab is selected then select Number in the Category list.
In Options > Leading Zeros, enter the minimum number of characters required. For
example, for four characters, enter 4. Any number less than four characters will have
leading zeros added, for example 12 becomes 0012.
Click OK. The number entered retains its number format and any formula used in the
spreadsheet will treat the entry as a number in formula functions.
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Method 2
1) Select the cell.
2) Open the Sidebar (View > Sidebar) and click the Open Panel (+) icon on the Number
Format panel to open it.
3) Select Number in the Category list box.
4) Set the Leading zeroes value box to 4. Formatting is applied immediately.

Figure 111: Set Leading zeroes
If a number is entered with leading zeroes, for example 01481, without first setting the Leading
zeros parameter, then by default Calc will automatically drop the leading 0. To preserve leading
zeros in a number:
1) Type an apostrophe (') before the number, for example '01481.
2) Move the cell focus to another cell. The apostrophe is automatically removed, the leading
zeros are retained and the number is converted to text left aligned.
Numbers as text
Numbers can also be entered as text using one of the following methods.
Method 1
1) With the cell selected, right-click on the cell and select Format Cells from the context menu
or go to Format > Cells on the Menu bar or use the keyboard shortcut Ctrl+1 to open the
Format Cells dialog (Figure 110).
2) Make sure the Numbers page is selected, then select Text from the Category list.
3) Click OK and the number, when entered, is converted to text and, by default, left aligned.
Method 2
1) Select the cell.
2) Open the Sidebar (View > Sidebar) and click the Open Panel (+) icon on the Number
Format panel.
3) Select Text in the Category list box. Formatting is applied to the cell immediately.
4) Click back on the cell. Enter the number and move focus from the cell to have the data
formatted.

Note
By default, any numbers that have been formatted as text in a spreadsheet will be
treated as a zero by any formulas used in the spreadsheet. Formula functions will
ignore text entries.

Text
Click in the cell and type the text. By default, text is left-aligned in a cell.

Date and time
Select the cell and type the date or time.
You can separate the date elements with a slash (/) or a hyphen (–) or use text, for example 10 Oct
2012. The date format automatically changes to the selected format used by Calc.
When entering a time, separate time elements with colons, for example 10:43:45. The time format
automatically changes to the selected format used by Calc.
To change the date or time format used by Calc, use one of the following methods.
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Method 1
1) With the cell selected, right-click on the cell and select Format Cells from the context
menu, or go to Format > Cells on the Menu bar, or use the keyboard shortcut Ctrl+1, to
open the Format Cells dialog (Figure 110).
2) Make sure the Numbers page is selected, then select Date or Time from the Category list.
3) Select the date or time format you want to use from the Format list.
4) Click OK.
Method 2
1) Select the cell.
2) Open the Sidebar (View > Sidebar) and (if necessary) click the Open Panel (+) icon on the
Number Format panel.
3) Select Date in the Category list box.
4) Click the More Options button in the panel title bar to open the Format Cells dialog.
5) Select the date or time format you want to use from the Format list.
6) Click OK.

Figure 112: Select Date and More Options

Autocorrection options
Calc automatically applies many changes during data input using autocorrection, unless you have
deactivated any autocorrect changes. You can also undo any autocorrection changes by using the
keyboard shortcut Ctrl+Z or manually by going back to the change and replacing the autocorrection
with what you want to actually see.
To change the autocorrect options, go to Tools > AutoCorrect Options on the Menu bar to open
the AutoCorrect dialog (Figure 113).
Replace
Edits the replacement table for automatically correcting or replacing words or abbreviations in the
document.
Exceptions
Specify the abbreviations or letter combinations that you do not want LibreOffice to correct
automatically.
Options
Select the options for automatically correcting errors as you type and then click OK.
Localized options
Specify the AutoCorrect options for quotation marks and for options that are specific to the
language of the text.
Reset
Resets modified values back to the LibreOffice default values.
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Figure 113: AutoCorrect dialog

Deactivating automatic changes
Some AutoCorrect settings are applied when you press the spacebar after you enter data. To turn
off or on Calc AutoCorrect, go to Tools on the Menu bar and deselect or select AutoInput.

Speeding up data entry
Entering data into a spreadsheet can be very labor-intensive, but Calc provides several tools for
removing some of the drudgery from input.
The most basic ability is to drop and drag the contents of one cell to another with a mouse. Many
people also find AutoInput helpful. Calc also includes several other tools for automating input,
especially of repetitive material. They include the fill tool, selection lists, and the ability to input
information into multiple sheets of the same document.

Using the Fill tool
The Calc Fill tool is used to duplicate existing content or create a series in a range of cells in your
spreadsheet (Figure 114).
1) Select the cell containing the contents you want to copy or start the series from.
2) Drag the mouse in any direction or hold down the Shift key and click in the last cell you
want to fill.
3) Go to Sheet > Fill Cells on the Menu bar and select the direction in which you want to copy
or create data (Up, Down, Left or Right) or Series and Random Number... from the
submenu.
Alternatively, you can use a shortcut to fill cells.
1) Select the cell containing the contents you want to copy or start the series from.
2) Move the cursor over the small square in the bottom right corner of the selected cell. The
cursor will change shape.
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3)

Click and drag in the direction you want the cells to be filled. If the original cellcontained
text, then the text will automatically be copied. If the original cell contained a number, a
series will be created.

Figure 114: Using the Fill tool
Using a fill series
When you select a series fill from Sheet > Fill Cells > Series..., the Fill Series dialog (Figure 115)
opens. Here you can select the type of series you want.

Figure 115: Fill Series dialog
•

•

Direction – determines the direction of series creation.
– Down – creates a downward series in the selected cell range for the column using the
defined increment to the end value.
– Right – creates a series running from left to right within the selected cell range using the
defined increment to the end value.
– Up – creates an upward series in the cell range of the column using the defined
increment to the end value.
– Left – creates a series running from right to left in the selected cell range using the
defined increment to the end value.
Series Type – defines the series type.
– Linear – creates a linear number series using the defined increment and end value.
– Growth – creates a growth series using the defined increment and end value.
– Date – creates a date series using the defined increment and end date.
– AutoFill – forms a series directly in the sheet. The AutoFill function takes account of
customized lists. For example, by entering January in the first cell, the series is
completed using the list defined in Tools > Options > LibreOffice Calc > Sort Lists.
AutoFill tries to complete a value series by using a defined pattern. For example, a
numerical series using 1,3,5 is automatically completed with 7,9,11,13; a date and time
series using 01.01.99 and 15.01.99, an interval of fourteen days is used.
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•

•
•
•

Unit of Time – in this area you specify the desired unit of time. This area is only activeif
the Date option has been chosen in the Series type area.
– Day – use the Date series type and this option to create a series using seven days.
– Weekday – use the Date series type and this option to create a series of five day sets.
– Month – use the Date series type and this option to form a series from the names or
abbreviations of the months.
– Year – use the Date series type and this option to create a series of years.
Start Value – determines the start value for the series. Use numbers, dates or times.
End Value – determines the end value for the series. Use numbers, dates or times.
Increment – determines the value by which the series of the selected type increases by
each step. Entries can only be made if the linear, growth or date series types have been
selected.

Figure 116: Sort Lists dialog
Defining a fill series
To define your own fill series:
1) Go to Tools > Options > LibreOffice Calc > Sort Lists to open the Sort Lists dialog
(Figure 116). This dialog shows the previously-defined series in the Lists box on the left and
the contents of the highlighted list in the Entries box.
2) Click New and the Entries box is cleared.
3) Type the series for the new list in the Entries box (one entry per line).
4) Click Add and the new list will now appear in the Lists box.
5) Click OK to save the new list.
Defining a fill series from a range in a sheet
You can define a range of text values as a fill series.
1) Select the range containing the text values that you want to use as a fill series.
2) Go to Tools > Options > LibreOffice Calc > Sort Lists to open the Sort List dialog (Figure
116).
3) The selected range is in the box Copy list from. Click Copy to add the range to the sort
list.

Using selection lists
Selection lists are available only for text and are limited to using only text that has already been
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entered in the same column.
1) Select a blank cell in a column that contains cells with text entries.
2) Right-click and select Selection Lists from the context menu. A drop-down list appears
listing any cell in the same column that either has at least one text character or whose
format is defined as text.
3) Click on the text entry you require and it is entered into the selected cell.

Sharing content between sheets
You might want to enter the same information in the same cell on multiple sheets, for example to
set up standard listings for a group of individuals or organizations. Instead of entering the list on
each sheet individually, you can enter the information in several sheets at the same time.
1) Go to Sheet > Select Sheets... on the Menu bar to open the Select Sheets dialog.

2)
3)
4)

Figure 117: Select Sheets dialog
Select the individual sheets where you want the information to be repeated. Use the Shift
and Ctrl (Options on Mac) keys to select multiple sheets.
Click OK to select the sheets and the sheet tabs will change color.
Enter the information in the cells on the first sheet where you want it to appear and it will be
repeated in all the selected sheets.

Note
This technique automatically overwrites, without any warning, any information that is
already in the cells on the selected sheets. Make sure you deselect the additional
sheets when you are finished entering information that is going to be repeated before
continuing to enter data into your spreadsheet.

Validating cell contents
When creating spreadsheets for other people to use, validating cell contents ensures that they
enter data that is valid and appropriate for the cell. You can also use validation in your own work as
a guide to entering data that is either complex or rarely used.
Fill series and selection lists can handle some types of data, but are limited to predefined
information. To validate new data entered by a user, select a cell and go to Data > Validity on the
Menu bar to define the type of contents that can be entered in that cell. For example, a cell may
require a date or a whole number with no alphabetic characters or decimal points, or a cell may not
be left empty.
Depending on how validation is set up, validation can also define the range of contents that can be
entered, provide help messages explaining the content rules set up for the cell and what users
should do when they enter invalid content. You can also set the cell to refuse invalid content,
accept it with a warning, or start a macro when an error is entered. See the Calc Guide Chapter 2
Entering, Editing and Formatting Data for more information on validating cell contents.
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Editing data
Deleting data
Deleting data only
Data can be deleted from a cell without deleting any of the cell formatting. Click in the cell to select
it and then press the Delete key.
Deleting data and formatting
Data and cell formatting can be deleted from a cell at the same time.
1) Click in the cell to select it.
2) Press the Backspace key, or right-click in the cell and select Delete Contents from the
context menu, or go to Edit > Delete Contents) on the Menu bar to open the Delete
Contents dialog (Figure 118). Here you can delete the different aspects of the data in the
cell or to delete everything in the cell.

Figure 118: Delete Contents dialog

Replacing data
To completely replace data in a cell and insert new data, select the cell and type in the new data.
The new data will replace the data already contained in the cell but will retain the original
formatting used in the cell.
Alternatively, click in the Input Line on the Formula Bar (Figure 92 on page 118), then double-click
on the data to highlight it completely and type the new data.

Editing data
Sometimes it is necessary to edit the contents of cell without removing all of the data from the cell.
For example, changing the phrase “Sales in Qtr. 2” to “Sales rose in Qtr” can be done as follows.
Using the keyboard
1) Click in the cell to select it.
2) Press the F2 key and the cursor is placed at the end of the cell.
3) Use the keyboard arrow keys to reposition the cursor where you want to start entering the
new data in the cell.
4) When you have finished, press the Enter key and your editing changes are saved.
Using the mouse
1) Double-click on the cell to select it and place the cursor in the cell for editing.
2) Either:
• Reposition the cursor to where you want to start entering the new data in the cell.
• Single-click to select the cell.
3) Move the cursor to the Input Line on the Formula Bar (Figure 92 on page 118) and click at
the position where you want to start entering the new data in the cell.
4) When you have finished, click away from the cell to deselect it and your editing changes
are saved.
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Formatting data
Note
All the settings discussed in this section can also be set as a part of the cell style. See
the Calc Guide Chapter 4 Using Styles and Templates in Calc for more information.

Multiple lines of text
Multiple lines of text can be entered into a single cell using automatic wrapping or manual line
breaks. Each method is useful for different situations.
Automatic wrapping
To automatically wrap multiple lines of text in a cell, use one of the following methods.
Method 1
1) Right-click on the cell and select Format Cells from the context menu, or go to Format >
Cells on the Menu bar, or press Ctrl+1, to open the Format Cells dialog.
2) Click on the Alignment tab (Figure 119).
3) Under Properties, select Wrap text automatically and click OK.

Figure 119: Format Cells dialog – Alignment page
Method 2
1) Select the cell.
2) Open the Sidebar (View > Sidebar) and click the Open Panel (+) icon on the Alignment
panel.
3) Select the Wrap text option to apply the formatting immediately.

Figure 120: Wrap text formatting
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Manual line breaks
To insert a manual line break while typing in a cell, press Ctrl+Enter. This method does not work
with the cursor in the input line. When editing text, double-click the cell, then reposition the cursor
to where you want the line break.
When a manual line break is entered, the cell width does not change and your text may still overlap
the end of the cell. You have to change the cell width manually or reposition your line break so that
your text does not overlap the end of the cell.

Shrinking text to fit the cell
The font size of the data in a cell can automatically adjust to fit inside cell borders. To do this,
select the Shrink to fit cell size option under Properties in the Format Cells dialog (Figure 119) on
the Alignment page. This dialog is also available by clicking the More Options button in the
Character title bar of the Properties deck on the opened Sidebar.

Formatting numbers
Several different number formats can be applied to cells by using icons on the Formatting toolbar
(highlighted in Figure 121). Select the cell, then click the relevant icon to change the number
format.

Figure 121: Number icons on Formatting toolbar
For more control or to select other number formats, use the Numbers page of the Format Cells
dialog (Figure 110 on page 137):
• Apply any of the data types in the Category list to the data.
• Control the number of decimal places and leading zeros in Options.
• Enter a custom format code.
• The Language setting controls the local settings for the different formats such as the date
format and currency symbol.
Some number formats are available from the Sidebar’s Number Format panel in the Properties
deck. Click the More Options button to open the Format Cells dialog described above.

Formatting a font
To quickly select a font and format it for use in a cell:
1) Select the cell.
2) Click the small triangle on the right of the Font Name box on the Formatting toolbar
(highlighted in Figure 122) and select a font from the drop-down list.
3) Click on the small triangle on the right of the Font Size on the Formatting toolbar and select
a font size from the drop down list.

Figure 122: Font Name and Size on Formatting toolbar
4)
5)

To change the character format, click on the Bold, Italic, or Underline icons.
To change the paragraph alignment of the font, click on one of the four alignment icons
(Left, Center, Right, Justified)
.

6)

To change the font color, click the arrow next to the Font Color icon
to display the color
palette, then select the desired color.
The Properties deck of the Sidebar has five panels, Styles, Character, Number Format,
Alignment and Cell Appearance, which between them contain all the formatting controls from the
Formatting toolbar and more.
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To specify the language used in the cell, open the Font page on the Format Cells dialog. You can
also select the More Options button on either of the Sidebar panels to open the Format Cells
dialog. Changing language in a cell allows different languages to be used within the same
document.
Use the Font Effects tab on the Format Cells dialog to set other font characteristics. See the Calc
Guide Chapter 4 Using Styles and Templates in Calc for more information.

Formatting cell borders
To format the borders of a cell or a group of selected cells, click on the Borders icon
on the
Formatting toolbar, and select one of the border options displayed in the palette.
To format the line style and line color for the borders of a cell, click the small arrows next to the
Line Style
and Line Color (Border Color)
icons on the Formatting toolbar. A line style
palette and a border color palette respectively are displayed.
The Cell Appearance panel of the Properties deck in the Sidebar contains Cell border, Line
style and Line color controls.
For more control, including the spacing between cell borders and any data in the cell, use the
Borders page of the Format Cells dialog (Figure 110 on page 137), where you can also define a
shadow style. Clicking the More Options button on the Cell Appearance title bar, or clicking More
in the panel’s line style drop-down list, opens the Format Cells dialog at the Borders page.
See the Calc Guide Chapter 4 Using Styles and Templates in Calc for more information.
Note
Cell border properties apply only to the selected cells and can only be changed if you
are editing those cells. For example, if cell C3 has a top border, that border can only be
removed by selecting C3. It cannot be removed in C2 despite also appearing to be the
bottom border for cell C2.
Formatting cell background
To format the background color for a cell or a group of cells, click the small arrow next to the
Background Color icon
on the Formatting toolbar. A color palette, similar to the Font Color
palette, is displayed. You can also use the Background tab of the Format Cells dialog (Figure 110
on page 137). The Cell Appearance panel of the Properties deck in the Sidebar contains a Cell
background control with a color palette. See the Calc Guide Chapter 4 Using Styles and
Templates in Calc for more information.

AutoFormatting of cells
Using AutoFormat
You can use Calc’s AutoFormat feature to format a group of cells quickly and easily. It also let you
format different parts of the sheet with the same look and feel very easily.
1) Select the cells in at least three columns and rows, including column and row headers, that
you want to format.
2) Go to Format > AutoFormat on the Menu bar to open the AutoFormat dialog(Figure
123).
3) Select the type of format and format color from the list.
4) If necessary, click More to open Formatting if Formatting is not visible.
5) Select the formatting properties to be included in the AutoFormat function.
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6)

Click OK.

AutoFormat dialog

Defining a new AutoFormat
You can define a new AutoFormat so that it becomes available for use in all spreadsheets.
1) Format the data type, font, font size, cell borders, cell background, and so on for a group of
cells.
2) Go to Edit > Select All on the Menu bar to select the whole spreadsheet.
3) Go to Format > AutoFormat to open the AutoFormat dialog and the Add button is now
active.
4) Click Add.
5) In the Name box of the Add AutoFormat dialog that opens, type a meaningful name for the
new format.
6) Click OK to save. The new AutoFormat is now available in the Format list in the AutoFormat
dialog.

Using themes
Calc comes with a predefined set of formatting themes that you can apply to spreadsheets. It is not
possible to add themes to Calc and they cannot be modified. However, you can modify their styles
after you apply them to a spreadsheet, and the modified styles become available for use in that
spreadsheet after you have saved it.
To apply a theme to a spreadsheet:
1)
2)
3)

Click the Choose Themes icon
in the Tools toolbar. If this toolbar is not visible, go to
View > Toolbars on the Menu bar and select Tools, and the Theme Selection dialog
(Figure 124) opens. This dialog lists the available themes for the whole spreadsheet.
Select the theme that you want to apply. As soon as you select a theme, the theme styles
are applied to the spreadsheet and are immediately visible.
Click OK.
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4)

If you wish, you can now open the Styles and Formatting window to modify specific styles.
These modifications do not modify the theme; they only change the appearance of the style
in the specific spreadsheet you are creating.

Theme Selection dialog

Using conditional formatting
You can set up cell formats to change depending on conditions that you specify. For example, in a
table of numbers, you can show all the values above the average in green and all those below the
average in red.
Conditional formatting depends upon the use of styles and the AutoCalculate feature must be
enabled. Go to Tools > Cell Contents > AutoCalculate on the Menu bar to enable this feature.
See the Calc Guide Chapter 2 Entering, Editing, and Formatting Data for more information.

227

Hiding and showing data
In Calc you can hide elements so that they are neither visible on a computer display nor printed
when a spreadsheet is printed. However, hidden elements can still be selected for copying if you
select the elements around them. For example, if column B is hidden, it is copied when you select
columns A and C.
For more information on how to hide and show data, including how to use outline groups and
filtering, see the Calc Guide Chapter 2 Entering, Editing, and Formatting Data.
Note
When data in cells are hidden, the blank cells remain visible in the spreadsheet.

Hiding and protecting data
To hide sheets, rows, and columns:
1) Select the sheet, row or column you want to hide.
2) Go to Format on the Menu bar and select Sheet, Row or Column.
3) Select Hide from the menu and the sheet, row or column can no longer viewed or printed.
4) Alternatively, right-click on the sheet tab, row header or column header and select Hide
from the context menu.
To hide and protect data in selected cells:
1) Go to Tools > Protect Sheet. The Protect Sheet dialog will open (Figure 125).
2) Select Protect this sheet and the contents of protected cells.
3) Create a password and then confirm the password.
4) Select or deselect the user selection options for cells.
5) Click OK.
6) Select the cells you want to hide.
7) Go to Format > Cells on the Menu bar, or right-click and select Format Cells from the
context menu, or use the keyboard shortcut Ctrl+1 to open the Format Cells dialog.
8) Click the Cell Protection tab (Figure 126) and select an option to hide the cells.
9) Click OK.

Protect Sheet dialog
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Figure 126: Cell Protection page in Format Cells dialog

Showing data
To show hidden sheets, rows, and columns:
1) Select the sheets, rows or columns each side of the hidden sheet, row or column.
2) Go to Format on the Menu bar and select Sheet, Row or Column.
3) Select Show from the menu and the sheet, row or column will be displayed and can be
printed.
4) Alternatively, right-click on the sheet tabs, row headers or column headers and select Show
from the context menu.
To show hidden data in cells:
1) Go to Tools > Protect Sheet.
2) Enter the password to unprotect the sheet and click OK.
3) Go to Format > Cells on the Menu bar, or right-click and select Format Cells from the
context menu, or use the keyboard shortcut Ctrl+1 to open the Format Cells dialog.
4) Click the Cell Protection tab (Figure 126) and deselect the hide options for the cells.
5) Click OK.

Sorting records
Sorting within Calc arranges the cells in a sheet using the sort criteria that you specify. Several
criteria can be used and a sort applies each criteria consecutively. Sorts are useful when you are
searching for a particular item and become even more useful after you have filtered data.
Also, sorting is useful when you add new information to your spreadsheet. When a spreadsheet is
long, it is usually easier to add new information at the bottom of the sheet, rather than adding rows
in their correct place. After you have added information, you then carry out a sort to update the
spreadsheet.
For more information on how to sort records and the sorting options available, see the Calc Guide
Chapter 2 Entering, Editing, and Formatting Data.

Sort Criteria dialog
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To sort cells in a spreadsheet:
1) Select the cells to be sorted.
2) Go to Data > Sort on the Menu bar to open the Sort dialog (Figure 127).
3) Select the sort criteria from the drop down lists. The selected lists are populated from the
selected cells.
4) Select either ascending order (A-Z, 1-9) or descending order (Z-A, 9-1).
5) Click OK and the sort is carried out on your spreadsheet.

Using formulas and functions
You may need more than numbers and text on your spreadsheet. Often the contents of one cell
depend on the contents of other cells. Formulas are equations that use numbers and variables to
produce a result. Variables are placed in cells to hold data required by equations.
A function is a predefined calculation entered in a cell to help you analyze or manipulate data. All
you have to do is enter the arguments and the calculation is automatically made for you. Functions
help you create the formulas required to get the results that you are looking for.
See the Calc Guide Chapter 7 Using Formulas and Functions for more information.

Analyzing data
Calc includes several tools to help you analyze the information in your spreadsheets, ranging from
features for copying and reusing data, to creating subtotals automatically, to varying information to
help you find the answers you need. These tools are divided between the Tools and Data menus.
One of the most useful of these tools is the PivotTable, which is used for combining, comparing,
and analyzing large amounts of data easily. Using the PivotTable, you can view different
summaries of the source data, display the details of areas of interest, and create reports, whether
you are a beginner, an intermediate or advanced user.
Calc also includes many tools for statistical analysis of data, where you can obtain important
numerical information on data obtained from physical measurements, polls, or even business
transactions such as sales, stock quotations, and so on. These statistical data analyses are
available in the menu Data > Statistics.
See the Calc Guide Chapter 8 Using Pivot Tables and Chapter 9 Data Analysis for more
information on pivot tables and other tools available in Calc to analyze your data.

Printing
Printing from Calc is much the same as printing from other LibreOffice components (see Chapter
10 Printing, Exporting, and Emailing in this guide). However, some details for printing in Calc are
different, especially regarding preparation for printing.

Print ranges
Print ranges have several uses, including printing only a specific part of the data or printing
selected rows or columns on every page. For more information about using print ranges, see the
Calc Guide Chapter 6 Printing, Exporting, and E-mailing.
Defining a print range
To define a new print range or modify an existing print range:
1) Select the range of cells to be included in the print range.
2) Go to Format > Print Ranges > Define on the Menu bar. Page break lines aredisplayed
on screen.
3) To check the print range, go to File > Print Preview on the Menu bar or click on the Print
Preview icon
. LibreOffice will display the cells in the print range.
Adding to a print range
After defining a print range, you can add more cells to it by creating another print range. This
allows multiple, separate areas of the same sheet to be printed while not printing the whole sheet.
1) After defining a print range, select an extra range of cells for adding to the print range.
2) Go to Format > Print Ranges > Add on the Menu bar to add the extra cells to theprint
range. The page break lines are no longer displayed on the screen.
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3)
4)

To check the print ranges, go to File > Print Preview on the Menu bar or click on the Print
Preview icon

. LibreOffice will display the print ranges as separate pages.

Note
The additional print range will print as a separate page, even if both ranges are on the
same sheet.
Removing a print range
It may become necessary to remove a defined print range, for example, if the whole sheet needs to
be printed later.
To remove all the defined print ranges, go to Format > Print Ranges > Remove on the Menu bar.
After the print ranges have been removed, the default page break lines will appear on the screen.
Editing a print range
At any time, you can directly edit the print range, for example to remove or resize part of the print
range. Go to Format > Print Ranges > Edit on the Menu bar to open the Edit Print Ranges
dialog where you can define the print range.

Printing options
To select the printing options for page order, details, and scale to be used when printing a
spreadsheet:
1) Go to Format > Page on the Menu bar to open the Page Style dialog (Figure 128).
2) Select the Sheet tab and make your selections from the available options.
3) Click OK.
For more information on printing options, see the Calc Guide Chapter 6 Printing, Exporting, and
E- mailing.

Repeat printing of rows or columns
If a sheet is printed on multiple pages, you can set up certain rows or columns to repeat on each
printed page. For example, if the top two rows of the sheet as well as column A need to be printed
on all pages, do the following:
1) Go to Format > Print Ranges > Edit on the Menu bar to open the Edit Print Ranges
dialog (Figure 129).
2) Type the row identifiers in the Rows to repeat box. For example, to repeat rows 1 and 2,
type $1:$2. This automatically changes Rows to repeat from, - none - to - user defined-.
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Page Style dialog
Type the column identifiers in the Columns to repeat box. For example, to repeat column A,
type $A. In the Columns to repeat list, - none - changes to - user defined -.
4) Click OK.
For more information on editing print ranges, see the Calc Guide, Chapter 6 Printing, Exporting,
and E-mailing.
3)

Edit Print Ranges dialog

Page breaks
While defining a print range can be a powerful tool, it may sometimes be necessary to manually
adjust the Calc printout manually using a manual or page break. A page break helps to ensure that
your data prints properly according to your page size and page orientation. You can insert a
horizontal page break above or a vertical page break to the left of the active cell.
For more information on manual breaks, see the Calc Guide Chapter 6 Printing, Exporting, and
E- mailing.
Inserting a break
To insert a page break:
1) Navigate to the cell where the page break will begin.
2) Go to Insert > Page Break on the Menu bar.
3) Select Row Break to create a page break above the selected cell.
4) Select Column Break to create a page break to the left of the selected cell.
Deleting a page break
To remove a page break:
1) Navigate to a cell that is next to the break you want to remove.
2) Go to Edit > Delete Page Break on the Menu bar.
3) Select Row Break or Column Break depending on your need and break is removed.

Note
Multiple manual row and column breaks can exist on the same page. When you want
to remove them, you have to remove each break individually.

Headers and footers
Headers and footers are predefined pieces of text that are printed at the top or bottom of a page
when a spreadsheet is printed. Headers and footers are set and defined using the same method.
For more information on setting and defining headers and footers, see the Calc Guide Chapter 6
Printing, Exporting, and E- mailing.
Headers and footers are also assigned to a page style. You can define more than one page style
for a spreadsheet and assign different page styles to different sheets within a spreadsheet. For
more information on page styles, see the Calc Guide Chapter 4 Using Styles and Templates.
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Setting a header or footer
To set a header or footer:
1) Navigate to the sheet that you want to set the header or footer for.
2) Go to Format > Page on the Menu bar to open the Page Style dialog (Figure 130).
3) On the Page Style dialog, select Header or Footer tab.
4) Select the Header on or Footer on option.
5) Select Same content left/right option if you want the same header or footer to appear on
all the printed pages.
6) Set the margins, spacing, and height for the header or footer. You can also select AutoFit
height box to automatically adjust the height of the header or footer.
7) To change the appearance of the header or footer, click on More to open the borders and
background dialog.
8) To set the contents, for example page number, date and so on, that appears in the header
or footer, click on Edit to open the style dialog.

Header page of Page Style dialog
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COMPUTER FUNDAMENTAL
SET - 1
1. UNIVAC is
a. Universal Automatic Computer
b. Universal Array Computer
c. Unique Automatic Computer
d. Unvalued Automatic Computer
2. CD-ROM stands for
a. Compactable Read Only Memory
b. Compact Data Read Only Memory
c. Compactable Disk Read Only Memory
d. Compact Disk Read Only Memory
3. ALU is
a. Arithmetic Logic Unit
b. Array Logic Unit
c. Application Logic Unit
d. None of above
4. VGA is
a. Video Graphics Array
b. Visual Graphics Array
c. Volatile Graphics Array
d. Video Graphics Adapter
5. IBM 1401 is
a. First Generation Computer
b. Second Generation Computer
c. Third Generation Computer
d. Fourth Generation Computer
6. MSI stands for
a. Medium Scale Integrated Circuits
b. Medium System Integrated Circuits
c. Medium Scale Intelligent Circuit
d. Medium System Intelligent Circuit
7. The capacity of 3.5 inch floppy disk is
a. 1.40 MB
b. 1.44 GB
c. 1.40 GB
d. 1.44 MB
8. The first computer introduced in Nepal was
a. IBM 1400
b. IBM 1401
c. IBM 1402
d. IBM1402
9. WAN stands for
a. Wap Area Network
b. Wide Area Network
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c. Wide Array Net
d. Wireless Area Network
10. MICR stands for
a. Magnetic Ink Character Reader
b. Magnetic Ink Code Reader
c. Magnetic Ink Cases Reader
d. None
SET - 2
1. EBCDIC stands for
a. Extended Binary Coded Decimal Interchange Code
b. Extended Bit Code Decimal Interchange Code
c. Extended Bit Case Decimal Interchange Code
d. Extended Binary Case Decimal Interchange Code
2. BCD is
a. Binary Coded Decimal
b. Bit Coded Decimal
c. Binary Coded Digit
d. Bit Coded Digit

3. ASCII stands for
a. American Stable Code for International Interchange
b. American Standard Case for Institutional Interchange
c. American Standard Code for Information Interchange
d. American Standard Code for Interchange Information

4. Which of the following is first generation of computer
a. EDSAC
b. IBM-1401
c. CDC-1604
d. ICL-2900

5. Chief component of first generation computer was
a. Transistors
b. Vacuum Tubes and Valves
c. Integrated Circuits
d. None of above

6. FORTRAN is
a. File Translation
b. Format Translation
c. Formula Translation
d. Floppy Translation

7. EEPROM stand for
a. Electrically Erasable Programmable Read Only Memory
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b. Easily Erasable Programmable Read Only Memory
c. Electronic Erasable Programmable Read Only Memory
d. None of the above
8. Second Generation computers were developed during
a. 1949 to 1955
b. 1956 to 1965
c. 1965 to 1970
d. 1970 to 1990
9. The computer size was very large in
a. First Generation
b. Second Generation
c. Third Generation
d. Fourth Generation
10. Microprocessors as switching devices are for which generation computers
a. First Generation
b. Second Generation
c. Third Generation
d. Fourth Generation
SET-3
1. Which of the following devices can be sued to directly image printed text?
a. OCR
b. OMR
c. MICR
d. All of above
2. The output quality of a printer is measured by
a. Dot per inch
b. Dot per sq. inch
c. Dots printed per unit time
d. All of above
3. In analog computer
a. Input is first converted to digital form
b. Input is never converted to digital form
c. Output is displayed in digital form
d. All of above
4. In latest generation computers, the instructions are executed
a. Parallel only
b. Sequentially only
c. Both sequentially and parallel
d. All of above
5. Who designed the first electronics computer – ENIAC?
a. Van-Neumann
b. Joseph M. Jacquard
c. J. Presper Eckert and John W Mauchly
d. All of above
6. Who invented the high level language c?
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a. Dennis M. Ritchie
b. Niklaus Writh
c. Seymour Papert
d. Donald Kunth
7. Personnel who design, program, operate and maintain computer equipment refers to
a. Console-operator
b. Programmer
c. Peopleware
d. System Analyst
8. When did arch rivals IBM and Apple Computers Inc. decide to join hands?
a. 1978
b. 1984
c. 1990
d. 1991
9. Human beings are referred to as Homosapinens, which device is called Sillico Sapiens?
a. Monitor
b. Hardware
c. Robot
d. Computer
10. An error in software or hardware is called a bug. What is the alternative computer jargon for it?
a. Leech
b. Squid
c. Slug
d. Glitch
11. Modern Computer are very reliable but they are not
a. Fast
b. Powerful
c. Infallible
d. Cheap
12. What is the name of the display feature that highlights are of the screen which requires operator
attention?
a. Pixel
b. Reverse video
c. Touch screen
d. Cursor
13. IMB launched its first personal computer called IBM-PC in 1981. It had chips from Intel, disk
drives from Tandon, operating system from Microsoft, the printer from Epson and the application
software from everywhere. Can you name the country which contributed the video display?
a. India
b. China
c. Germany
d. Taiwan

14. Personal computers use a number of chips mounted on a main circuit board. What is the common
name for such boards?
a. Daughter board
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b. Motherboard
c. Father board
d. Breadboard
15. In most IBM PCs, the CPU, the device drives, memory expansion slots and active components are
mounted on a single board. What is the name of this board?
a. Motherboard
b. Breadboard
c. Daughter board
d. Grandmother board
16. What is meant by a dedicated computer?
a. Which is used by one person only
b. Which is assigned one and only one task
c. Which uses one kind of software
d. Which is meant for application software
17. The system unit of a personal computer typically contains all of the following except:
a. Microprocessor
b. Disk controller
c. Serial interface
d. Modem
18. A computer program that converts an entire program into machine language is called a/an
a. Interpreter
b. Simulator
c. Compiler
d. Commander
19. A computer program that translates one program instructions at a time into machine language is
called a/an
a. Interpreter
b. CPU
c. Compiler
d. Simulator
20. A small or intelligent device is so called because it contains within it a
a. Computer
b. Microcomputer
c. Programmable
d. Sensor
SET-4
1. The ALU of a computer responds to the commands coming from
a. Primary memory
b. Control section
c. External memory
d. Cache memory

2. The act of retrieving existing data from memory is called
a. Read-out
b. Read from
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c. Read
d. All of above
3. All modern computer operate on
a. Information
b. Floppies
c. Data
d. Word
4. Instructions and memory address are represented by
a. Character code
b. Binary codes
c. Binary word
d. Parity bit
5. Which of the following code used in present day computing was developed by IBM Corporation?
a. ASCII
b. Hollerith Code
c. Baudot Code
d. EBCDIC Code
6. What is the latest write-once optical storage media?
a. Digital paper
b. Magneto-optical disk
c. WORM disk
d. CD-ROM disk
7. The most important advantage of a video disk is
a. Compactness
b. Potential capacity
c. Durability
d. Cost effectiveness
8. What is the number of read-write heads in the drive for a 9-trac magnetic tape?
a. 9
b. 16
c. 18
d. 27
9. Before a disk drive can access any sector record, a computer program has to provide the record’s disk
address. What information does this address specify?
a. Track number
b. Sector number
c. Surface number
d. All of above
10. As compared to diskettes, the hard disks are
a. More expensive
b. More portable
c. Less rigid
d. Slowly accessed
11. Floppy disks which are made from flexible plastic material are also called?
a. Hard disks
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b. High-density disks
c. Diskettes
d. Templates
12. Regarding a VDU, Which statement is more correct?
a. It is an output device
b. It is an input device
c. It is a peripheral device
d. It is hardware item
13. What is the name of the computer terminal which gives paper printout?
a. Display screen
b. Soft copy terminal
c. Hard copy terminal
d. Plotter
14. Dot-matrix is a type of
a. Tape
b. Printer
c. Disk
d. Bus
15. The two kinds of main memory are:
a. Primary and secondary
b. Random and sequential
c. ROM and RAM
d. All of above
16. A kind of serial dot-matrix printer that forms characters with magnetically-charged ink sprayed dots
is called
a. Laser printer
b. Ink-jet printer
c. Drum printer
d. Chan printer
17. Which printer is very commonly used for desktop publishing?
a. Laser printer
b. Inkjet printer
c. Daisywheel printer
d. Dot matrix printer
18. An output device that uses words or messages recorded on a magnetic medium to produce audio
response is
a. Magnetic tape
b. Voice response unit
c. Voice recognition unit
d. Voice band
19. Which of the following will happen when data is entered into a memory location?
a. It will add to the content of the location
b. It will change the address of the memory location
c. It will erase the previous content
d. It will not be fruitful if there is already some data at the location
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20. A storage area used to store data to a compensate for the difference in speed at which the different
units can handle data is
a. Memory
b. Buffer
c. Accumulator
d. Address
SET-5
1. To locate a data item for storage is
a. Field
b. Feed
c. Database
d. Fetch
2. programs designed to perform specific tasks is known as
a. system software
b. application software
c. utility programs
d. operating system
3. perforated paper used as input of output media is known as
a. paper tapes
b. magnetic tape
c. punched papers tape
d. card punch
4. Time during which a job is processed by the computer is
a. Delay times
b. Real time
c. Execution time
d. Down time
5. a computer which CPU speed around 100 million instruction per second and with the word length of
around 64 bits is known as
a. Super computer
b. Mini computer
c. Micro computer
d. Macro computer
6. An approach that permits the computer to work on several programs instead of one is
a. On-line thesaurus
b. Multiprogramming
c. Over lapped processing
d. Outline processor
7. A directly accessible appointment calendar is feature of a … resident package
a. CPU
b. Memory
c. Buffer
d. ALU
8. The term gigabyte refers to
a. 1024 bytes
b. 1024 kilobytes
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c. 1024 megabytes
d. 1024 gigabyte
9. Which of the following processors use RISC technology?
a. 486dx
b. Power PC
c. 486sx
d. 6340
10. A/n …. Device is any device that provides information, which is sent to the CPU
a. Input
b. Output
c. CPU
d. Memory
11. Current SIMMs have either … or … connectors (pins)
a. 9 or 32
b. 30 or 70
c. 28 or 72
d. 30 or 72
12. The storage subsystem in a microcomputer consists mainly of … or … media with varying
capacities
a. Memory or video
b. Magnetic or optical
c. Optical or memory
d. Video or magnetic
13. Which of the following is not an input device?
a. OCR
b. Optical scanners
c. Voice recognition device
d. COM (Computer Output to Microfilm)
14. The central processing unit (CPU) consists of
a. Input, output and processing
b. Control unit, primary storage, and secondary storage
c. Control unit, arithmetic-logic unit and primary storage
d. Control unit, processing, and primary storage
15. EBCDIC can code up to how many different characters?
a. 256
b. 16
c. 32
d. 64
16. Which is considered a direct entry input device?
a. Optical scanner
b. Mouse and digitizer
c. Light pen
d. All of the above
17. Which is used for manufacturing chips?
a. Bus
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b. Control unit
c. Semiconductors
d. A and b only
18. The computer code for the interchange of information between terminals is
a. ASCII
b. BCD
c. EBCDIC
d. All of above
19. A byte consists of
a. One bit
b. Four bits
c. Eight bits
d. Sixteen bits
20. A hybrid computer
a. Resembles digital computer
b. Resembles analog computer
c. Resembles both a digital and analog computer
d. None of the above
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